疑難排解及監視伺服器端同步處理
此頁面是您疑難排解伺服器端同步處理問題和解決方式的來源。 隨著發現問題並記錄解決方案,請隨時返回檢查更新資訊。
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伺服器端同步處理失敗儀表板
依照此知識庫文章中的步驟,啟用並使用儀表板,以取得同步處理錯誤的相關資訊。
伺服器端同步處理效能儀表板
您可以使用伺服器端同步處理效能儀表板,快速查看使用伺服器端同步處理之信箱的健全狀況。
移至任何儀表板,按一下儀表板標題旁的 [選取] ,然後按一下伺服器端同步處理效能。
此儀表板是由多個圖表組成,每個圖表提供您組織的伺服器端同步處理效能見解。
按一下已設定伺服器端同步處理之信箱清單的數字,取得特定信箱狀態。
按一下每個圖表的格線圖示,檢視用來產生圖表的記錄。
一般警示和建議的解決方式
已停用同步處理的信箱
提醒:系統已停用信箱同步處理約會、連絡人和工作的功能,因為建立與 Exchange Server 之間的安全連線時發生錯誤。 系統已通知電子郵件伺服器設定檔的負責人。
解決方案:https://support.microsoft.com/kb/2993502
建立安全連線時發生錯誤
提醒:建立與電子郵件伺服器之間的安全連線時發生錯誤,因此無法針對信箱接收電子郵件。 系統已停用信箱使其無法接收電子郵件,並且已通知電子郵件伺服器設定檔的負責人。
解決方案:https://support.microsoft.com/kb/2993502
電子郵件訊息含有「擱置的傳送」狀態
如果您建立電子郵件訊息在 Customer Engagement (on-premises) 中,並按一下傳送按鈕,訊息不會傳送,除非電子郵件整合已正確設定並啟用,可從 Customer Engagement (on-premises) 傳送電子郵件。
確認已啟用傳送電子郵件的使用者的傳送電子郵件功能。
按一下設定,然後按一下電子郵件組態。
按一下信箱,然後變更檢視至使用中信箱。
選取傳送電子郵件的使用者的 Customer Engagement (on-premises) 信箱記錄,然後按一下編輯按鈕。
確認使用者已正確設定且啟用傳送電子郵件的功能:
- 如果使用者的 Customer Engagement (on-premises) 信箱記錄設定為使用伺服器端同步處理來處理外寄電子郵件,請確認使用者的電子郵件地址經過核准,同時通過測試並已啟用。 如需有關設定伺服器端同步處理的詳細資訊,請參閱設定電子郵件、約會、連絡人及工作的伺服器端同步處理。
電子郵件地址需要 Office 365 系統管理員的核准
警示:無法傳送/接收電子郵件,因為信箱 <User Name> 的電子郵件地址必須經過 Office 365 管理員核准。 系統已停用信箱使其無法傳送/接收電子郵件,並且已通知電子郵件伺服器設定檔 Exchange Online 的負責人。
原因:
若已將使用者設定為使用 Microsoft Exchange Online 電子郵件伺服器設定檔,不過 Office 365 管理員尚未核准其電子郵件地址,就會發生此錯誤。 具有 Office 365 全域管理員角色的使用者必須針對使用 Microsoft Exchange Online電子郵件伺服器設定檔的每一位使用者核准其電子郵件地址。 Microsoft Exchange Online 設定檔會在 Dynamics 365 for Customer Engagement 應用程式與 Exchange Online 之間使用伺服器對伺服器驗證。 此驗證依賴 Customer Engagement 應用程式和 Exchange Online 之間的信任。 透過以 Office 365 全域管理員身分驗證 Customer Engagement (on-premises) 的電子郵件地址,Customer Engagement 應用程式就能傳送以及接收該使用者的電子郵件,不需要在 Customer Engagement (on-premises) 中提供任何電子郵件認證。
解決方案:
若要核准一個或多個信箱:
以具有 Office 365 中 Office 365 全域管理員角色或 Dynamics 365 服務管理員角色的使用者身分登入 Customer Engagement 應用程式。
移至設定>電子郵件組態。
按一下信箱。
選取使用中信箱或執行進階尋找查詢以識別要更新的信箱清單。
選取您要核准的信箱清單,然後按一下核准電子郵件。
按一下確定核准電子郵件地址。
按一下測試和啟用信箱重新測試已啟用之信箱的電子郵件處理。
電子郵件地址必須經過核准
提醒:系統已停用一或多個信箱使其無法傳送/接收電子郵件,因為其電子郵件地址尚未經過核准。 核准電子郵件地址,然後啟用郵箱以傳送/接收電子郵件」。或「無法接收信箱 <Mailbox Name> 的電子郵件,因為信箱 <Mailbox Name> 的電子郵件地址未經核准,且信箱已停用。 並且已通知相關電子郵件伺服器設定檔 <Email Server Profile name> 的負責人。
解決方案:
信箱必須先經過核准,才會處理電子郵件。 若要核准信箱:
以具有 Office 365 中 Office 365 全域管理員角色或 Dynamics 365 服務管理員角色的使用者身分登入 Customer Engagement 應用程式。
移至設定>電子郵件組態。
按一下信箱。
選取使用中信箱或執行進階尋找查詢以識別要更新的信箱清單。
選取您要核准的信箱清單,然後按一下核准電子郵件。
按一下確定核准電子郵件地址。
按一下測試和啟用信箱重新測試已啟用之信箱的電子郵件處理。
Note
您可以透過下列方法來移除核准信箱的需求:選擇設定>管理>系統設定>電子郵件索引標籤。取消核取只處理已核准使用者的電子郵件和只處理已核准待辦事項的電子郵件,然後按一下確定。 如果您使用 Microsoft Exchange Online 設定檔,必須由 Office 365 全域管理員核准電子郵件地址。
無法判斷信箱位置
提醒:傳送/接收電子郵件訊息 <Message Subject> 時無法判斷信箱位置。 系統已停用信箱 <Mailbox Name> 使其無法傳送/接收電子郵件,並且已通知相關電子郵件伺服器設定檔 <Email Server Profile name> 的負責人。
解決方案:如果您的電子郵件伺服器設定檔 (設定>電子郵件組態>電子郵件伺服器設定檔) 設定為使用自動探索伺服器位置選項,但自動探索無法偵測到信箱的位置,您將看見此警示。 如果發生此問題,請洽詢您的 Exchange 管理員,驗證您的網路已設定使用自動探索。 您可以更新電子郵件伺服器設定檔並在自動探索伺服器位置中按一下 否。 然後針對 Exchange 部署提供 Exchange Web 服務 URL。 例如:https://ExchangeServerName/EWS/Exchange.asmx.
認證不正確或權限不足
提醒:相關電子郵件伺服器設定檔中指定的認證不正確或傳送/接收電子郵件的權限不足,因此無法傳送/接收電子郵件。 系統已停用信箱 <Mailbox Name> 使其無法傳送/接收電子郵件,並且已通知電子郵件伺服器設定檔 <Email Server Profile name> 的負責人。
解決方案:
如果提供不正確認證,或者指定存取信箱的使用者帳戶的信箱權限不足,此錯誤會出現。 檢查信箱的認證和權限。 如果您在電子郵件伺服器設定檔中提供認證,確定使用者有模擬權限及每個關聯信箱的信箱存取權。
如需設定 Exchange 模擬和授予信箱存取的詳細資訊,請參閱:
約會無法同步處理
提醒:因為 [召集人] 欄位不存在,無法同步處理約會。
原因:約會記錄需要 [召集人] 欄位才能同步處理。 根據預設,約會表單預設不包含這個欄位。
解決方案:
若要將[召集人] 欄位新增至約會表單:
移至設定>自訂>自訂系統。
在元件底下,展開實體>約會,然後按一下表單。
按一下約會,然後將召集人欄位拖曳至約會。
按一下儲存>發行。
無法同步處理約會、連絡人和工作
警示:無法同步處理約會、連絡人和工作,因為信箱 <Mailbox Name> 的電子郵件地址是使用其他 Customer Engagement (on-premises) 組織設定的。 最好的做法是在測試時覆寫設定,並啟用主要組織中的信箱。 並且將非主要組織的信箱同步處理方法變更為 [無]。
解決方案:
若要變更主要同步處理組織,並覆寫儲存在 Exchange 中的設定,請按一下:設定>電子郵件組態>信箱> 開啟信箱 >測試和啟用信箱> 選取僅將項目與此 Dynamics 365 for Customer Engagement 組織中的 Exchange 同步,即使 Exchange 已設定為與其他組織同步。 這允許伺服器端同步處理於此 Customer Engagement (on-premises) 執行個體運作,但是其他執行個體不再透過伺服器端同步處理同步處理該信箱。 若要變更約會、連絡人和工作的同步處理方法,請按一下:設定>電子郵件組態>信箱>開啟信箱>針對約會、連絡人和工作選取無。
如需詳細資訊,請參閱:我何時會想要使用這個核取方塊?
潛在的問題和解決方案
無法傳送或接收的電子郵件,當伺服器端同步處理設定為使用 Gmail
如果 Customer Engagement (on-premises) 設定為使用 Gmail 的伺服器端同步處理,您可能會遇到下列其中一個錯誤:
無法接收信箱 <Mailbox Name> 的電子郵件。 請確定信箱中已指定正確的認證,並且擁有足夠的權限可以接收電子郵件。 然後,啟用信箱進行電子郵件處理。
傳送電子郵件訊息「測試訊息」時,發生不明的錯誤。 信箱 <Mailbox Name> 未同步處理。 並且已通知相關電子郵件伺服器設定檔 <Email Server Profile Name> 的負責人。
如需詳細資訊,請參閱此知識庫文章。
定期停用的信箱傳送
信箱傳送錯誤分類如下:
永久錯誤 (例如,401 未授權) 或暫時性錯誤 (例如,網路問題)。
伺服器錯誤 (例如,無效設定檔認證) 或信箱錯誤 (例如,無效信箱認證)。
Customer Engagement (on-premises) 回覆錯誤如下:
對於伺服器或信箱永久錯誤,當偵測錯誤時立即停用信箱。
對於伺服器或信箱暫時性錯誤,最多重試傳遞 10 次,重試間隔為 5 分鐘。 如果在 10 次嘗試之後傳遞失敗,錯誤視為永久,並停用信箱。
檢閱本主題的疑難排解步驟,如果問題成功解決,啟動信箱。
不支援的電子郵件服務設定
伺服器端同步處理不支援下列案例:
將 Exchange/SMTP 和 POP3/Exchange 混合。
建立大量電子郵件行銷廣告活動。
擴充性案例,如 EWS/POP3/SMTP 通訊協定,以及建立自訂電子郵件提供者。
Exchange Server 2003 和 Exchange Server 2007。
Customer Engagement 應用程式或 Customer Engagement (on-premises) (內部部署) 部署中為符合 FIPS 140-2 規範所設定的伺服器端同步處理,需要同樣符合 FIPS 140-2 規範的 POP3/SMTP 電子郵件伺服器。 某些電子郵件伺服器不符合 FIPS 140-2 標準,例如 MSN、Outlook.com 或 Windows Live Mail。
對於伺服器端同步處理不支援的大部分情況,您可以使用 Microsoft Dynamics CRM Email Router。 詳細資訊:整合您的電子郵件系統
Note
建議您不要使用 Outlook 同步處理與同一組織中約會、聯絡人及工作之伺服器端同步處理的混合設定,否則可能會導致更新的 Customer Engagement (on-premises) 資料無法同步處理至所有出席者。
由受邀者追蹤時,在 Customer Engagement (on-premises) 中不會建立約會記錄
考慮關於追蹤 Customer Engagement (on-premises) 事件的下列案例:
活動召集人使用 Outlook 同步處理方式。
活動受邀者使用伺服器端同步處理的同步處理方式。
在 Dynamics 365 for Outlook,召集人建立約會並傳送邀請給受邀者。
在 Dynamics 365 for Outlook,受邀者追蹤約會。
受邀者登入 Customer Engagement (on-premises) 並瀏覽至行銷>活動>約會>我的約會
結果:Customer Engagement (on-premises) 中未建立受邀者的約會。
這是已知問題,且不受支援。 如果召集人是在 Customer Engagement (on-premises) 組織外,身為受邀者的 Customer Engagement (on-premises) 使用者仍然可以在 Customer Engagement (on-premises) 中追蹤約會及建立記錄。
服務約會與活動不會從 Outlook 同步處理至 Customer Engagement (on-premises)
當同步處理,Customer Engagement (on-premises) 中的服務約會與活動變更,會更新 Dynamics 365 for Outlook,但是反之則不成立。 當您變更 Dynamics 365 for Outlook 中的服務約會或活動,變更未同步處理至 Customer Engagement (on-premises)。 服務約會是由客服專員排程,以及需要資源的空閒/忙碌資訊 (只可以在 Customer Engagement (on-premises) 中使用)。
請注意 Exchange Online接收及傳送的限制
對於郵件流量較大的企業客戶,確認您未違反 Exchange Online 接收及傳送的限制。 請參閱 Exchange Online 限制