針對 電腦版 Power Automate 中的安裝問題進行疑難解答
本文提供疑難解答步驟,以解決安裝 電腦版 Power Automate 時可能發生的問題。
適用於: Power Automate
原始 KB 編號: 5001534
一般步驟
若要確保安裝成功,請確定:
您可以使用最新的安裝程式進行 電腦版 Power Automate。
注意
需要本機計算機上的系統管理員許可權,才能使用 MSI 安裝程式安裝 電腦版 Power Automate。
您重新啟動電腦。
某些 Windows 變更需要重新啟動才會生效,否則可能會封鎖您的安裝。
您執行最新版支援的 Windows 作業系統。
如需必要條件的完整清單,請參閱 必要條件和限制。
收集診斷資訊
安裝記錄可以提供安裝的相關實用詳細數據,並協助您診斷和修正問題。 如需尋找記錄位置的詳細資訊,請參閱 電腦版 Power Automate 安裝記錄。
已知問題和因應措施
Power Automate 服務無法啟動:無法載入 DLL 'uiflowsclient.dll'
如果 Power Automate Windows 服務無法啟動,安裝就會失敗,並出現此錯誤。 Windows 事件檢視器 顯示無法啟動的原因為“System.DllNotFound 例外狀況:無法載入 DLL 'uiflowsclient.dll'”。
因應措施
若要解決此問題,請卸載「Microsoft Visual C++ 2015-2022 可轉散發套件」,然後依照下列步驟重新安裝 電腦版 Power Automate:
移至 [ 設定>應用程式>已安裝的應用程式]。
尋找「Microsoft Visual C++ 2015-2022 可轉散發套件」,並將其卸載。
重新安裝 電腦版 Power Automate。 電腦版 Power Automate 安裝程式會在安裝期間重新安裝可轉散發C++。
Power Automate 服務在啟動時當機:無法列舉會話
如果 Power Automate 服務在啟動時當機,安裝就會失敗,並出現此錯誤。 Windows 事件檢視器 會顯示 “FailedToEnumerateSessions” 錯誤。
UIFlowService
服務啟動期間攔截到的例外狀況:
Microsoft.Flow.RPA.Service.Core.UIFlowServiceException:錯誤碼:FailedToEnumerateSessions
原因
安裝程式會將許可權授與 Power Automate 服務,以列舉電腦上的用戶會話。 您可能需要重新指派您的計算機,這些許可權才會生效。
解決方法
若要解決此問題,您可以從命令行執行安裝程式並傳遞 /SKIPSTARTINGPOWERAUTOMATESERVICE
自變數,防止 Power Automate 服務在安裝期間自動啟動。
然後,在安裝后立即手動重新啟動計算機。 如果重新啟動成功,Power Automate Windows 服務會在重新啟動後成功執行,而且不應該再當機或產生事件記錄檔中的「FailedToEnumerateSessions」錯誤。
Power Automate 服務無法啟動:服務帳戶錯誤
安裝失敗,因為Power Automate 服務在啟動時當機,而 Windows 事件檢視器 會顯示下列錯誤:
UIFlowService
服務啟動期間攔截到的例外狀況:
Microsoft.Flow.RPA.Common.DataRepository.KeyValueStoreException:ReliableKeyValueStore 'UIFlowServiceSecretStore' 備份存放區狀況不良。
Windows 無法登入,因為無法載入您的配置檔。 檢查您已連線到網路,且您的網路正常運作。
原因
您的計算機可能有問題,它不允許在安裝期間建立Power Automate服務的NT Service\UIFlowService
Windows 帳戶。
您可以再次執行安裝,並在安裝程式嘗試啟動Power Automate 服務時檢查帳戶是否存在,以確認此情況。 您可以在登入找到帳戶的設定檔:
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\ProfileList\S-1-5-80-3017052307-2994996872-1615411526-3164924635-3391446484
如果此登錄機碼不存在,表示您的計算機不允許建立服務用戶帳戶。
注意
如果未安裝 電腦版 Power Automate,登錄機碼就不會存在。
因應措施
您可以提供 Windows 使用者帳戶來執行服務,而不是預設NT SERVICE\UIFlowService
帳戶 。 此帳戶必須是遠端桌面使用者群組的成員,而且必須具有「以服務登入」許可權。
首先從命令行執行安裝程式,並傳遞 /SKIPSTARTINGPOWERAUTOMATESERVICE
自變數,以防止Power Automate服務在安裝期間自動啟動。
安裝完成時,請執行 Power Automate Machine 運行時間應用程式,並使用 [ 疑難解答] 功能表來變更服務帳戶。 如需變更服務帳戶的詳細資訊,請參閱 變更內部部署服務帳戶。
Power Automate 服務無法啟動:確認您有足夠的許可權可啟動系統服務
您會看到下列事件記錄在 Windows 事件檢視器:
產品:電腦版 Power Automate -- 錯誤 1920。 服務 'Power Automate 服務' (UIFlowService) 無法啟動。 確認您有足夠的許可權可啟動系統服務。
原因
用來啟動Power Automate 服務的帳戶無法啟動服務,因為 拒絕以服務 安全策略登入會防止它。
在安裝期間,會 UIFlowService
以的形式執行 NT SERVICE\UIFlowService
。 所使用的 UIFlowService
帳戶稍後可以變更,但基於安裝目的,它不得封鎖其登入。
注意
如果您發現服務當機記錄檔,類似於下列螢幕快照所示,這表示服務具有足夠的啟動許可權,而且服務會在啟動時當機而封鎖安裝。 若要解決此問題,請參閱本文的其他章節。
“UIFlowService
服務啟動期間攔截到的例外狀況:”
解決方法
更新 [拒絕以服務身分登入] 原則設定,以移除防止NT SERVICE\UIFlowService
以服務身分登入的帳戶或群組。 如需詳細資訊,請參閱 變更內部部署服務帳戶。
無法啟動 LanmanServer 服務
您會在 安裝記錄中看到下列錯誤訊息:
啟動 LanmanServer 服務時擲回的例外狀況:System.InvalidOperationException:無法在計算機上啟動服務 LanmanServer
原因
Power Automate 安裝程式取決於 LanmanServer 服務,並在尚未執行時嘗試啟動它。 如果無法啟動服務,相依於服務的安裝步驟會失敗。
解決方法
若要解決此問題,
- 選取 [Windows 標誌鍵+R],然後在 [執行] 視窗中輸入 services.msc 或服務,以開啟 [服務管理員]。 尋找名為 「Server」 的服務,以滑鼠右鍵按兩下它,然後選取 [ 屬性]。
- 在 [ 一般] 索引標籤中,確定其 [啟動類型 ] 未停用(預設為 [自動 ]。
- 選取 [ 套用 ] 以更新啟動類型。
- 然後,您可以在服務管理員工具中以滑鼠右鍵按兩下服務,然後選取 [啟動],以手動啟動服務。
- 服務執行之後,您可以再次嘗試安裝。