适用于 Microsoft Outlook 的 Copilot for Sales 外接程序中的外接程序更新错误
本文可帮助你排查并解决一条错误消息,该错误消息会反复提示用户更新 Outlook 的 Microsoft Copilot for Sales 加载项。
注意
Microsoft Sales Copilot 在 2024 年 1 月被改名为 Microsoft Copilot for Sales。 本文中的屏幕截图将很快更新为新名称。
谁受影响?
要求类型 | Description |
---|---|
客户端应用 | Copilot for Sales Outlook 加载项 |
平台 | Web 和桌面客户端 |
操作系统 | Windows 和 Mac |
部署 | 用户管理和管理员管理 |
CRM | Dynamics 365 和 Salesforce |
用户 | 所有用户 |
现象
在 outlook Microsoft中打开 Copilot for Sales 窗格时,将显示以下错误消息:
加载项错误: 此加载项的更新可用,需要查看和确认才能安装。
选择 UPDATE 时,行为取决于使用的是Outlook 网页版还是桌面应用。
如果使用的是 Outlook 网页版,则会启动新的浏览器窗口,并导航到 Outlook 加载项弹出窗口上的“适用于 Microsoft Outlook 的 Copilot for Sales”屏幕。 该错误消息仍显示在新的浏览器窗口中。 但是,在原始浏览器窗口中,可以暂时使用 Copilot for Sales,直到页面刷新,并看到原始错误消息。
如果您使用的是 Outlook 桌面应用,则会显示一条后续错误消息,指示该加载项当前正在升级。 关闭 Copilot for Sales 窗格并重新打开它时,Copilot for Sales 会暂时工作,直到关闭或重新打开 Outlook,并再次出现错误。
原因
适用于 Outlook 的新 Copilot for Sales 加载项中发生了权限更改。
某些权限更改需要显式管理员同意或重新安装 Copilot for Sales Outlook 加载项。 这些权限更改始终与 Copilot for Sales Outlook 外接程序的最新更新相关联。 您可以在相应的应用源详细信息页面上检查最新更新何时应用于加载项。 如果看到最近更新了 Copilot for Sales Outlook 加载项,则由于更新,错误可能会绑定到相应的权限更改。
解决方法
第一步是确定 Copilot for Sales Outlook 外接程序是管理员管理的还是用户管理的。 您可以相应地采取解决步骤。
打开 Outlook(Web 或桌面)。
在功能区的主页选项卡上,选择获取加载项。
在 Outlook 加载项窗口中,检查是否在“管理管理”部分下列出了适用于 Microsoft Outlook 外接程序的 Copilot for Sales。
如果外接程序列在“管理员管理”部分下,请让租户管理员执行以下步骤:
在 Microsoft 365 管理中心中,选择设置>集成应用。
在 “集成应用 ”页上,选择 “Copilot for Sales ”应用。
此时将 打开Microsoft Copilot for Sales 面板。
如果“更新”按钮可用,请选择它并按照提示更新加载项。
如果“更新”按钮不可用,请转到“配置”选项卡,选择“Copilot for Sales for Microsoft Outlook”,然后选择“删除”。 完成后,重新安装适用于 Microsoft Outlook 的 Copilot for Sales 加载项。 有关详细信息,请参阅 安装 Copilot for Sales。
如果加载项未列在管理员管理部分下,请先从我的加载项部分中卸载该加载项,然后重新安装。
注意
通过管理员管理的流部署时,更改最多可能需要 24 小时才能对最终用户生效。
详细信息
如果你的问题仍未解决,请转到 Copilot for Sales - Microsoft社区中心 与我们的专家联系。