对服务器端同步进行故障排除和监视

备注

如果您已启用仅统一接口模式,则在使用本文中的过程之前,请执行以下操作:

  1. 在导航栏上选择 Settings齿轮图标。)。
  2. 选择高级设置

    高级设置。

此页是服务器端同步的问题和解决方法的来源。 当发现问题并记录解决方法时,请检查更新信息。

“服务器端同步失败”仪表板

按照此知识库文章中的步骤启用和使用仪表板以获取有关同步错误的信息。

“服务器端同步失败”仪表板。

服务器端同步性能仪表板

通过服务器端同步性能仪表板,您可以使用服务器端同步快速查找在邮箱的运行状况。

转到任何仪表板,请单击仪表板标题旁边的 下拉按钮。,然后单击服务器端同步性能

服务器端同步性能仪表板。

此仪表板由多个图表组成,每个图表提供对您的组织的服务器端同步性能的洞察。

单击为服务器端同步配置的邮箱列表中的一个编号以获得特定邮箱状态。

单击列出的邮箱了解详细信息。

单击每个图表中的网格图标来查看用于生成图表的记录。

单击以查看用于创建图表的记录。

禁用邮箱同步

注意:由于建立与 Exchange Server 的安全连接时出错,因此已禁止该邮箱同步约会、联系人和任务。 已通知电子邮件服务器配置文件的所有者。

解决方法:https://support.microsoft.com/kb/2993502

建立安全连接时出错

注意:由于建立与电子邮件服务器的安全连接时出错,因此邮箱无法接收电子邮件。 已禁止您的邮箱接收电子邮件,并且已通知电子邮件服务器配置文件的所有者。

解决方法:https://support.microsoft.com/kb/2993502

电子邮件的状态为“待发送”

如果在 Customer Engagement (on-premises) 中创建一封电子邮件,再单击发送按钮,电子邮件不会发送出去,除非电子邮件集成已经正确配置和启用从 Customer Engagement (on-premises) 发送电子邮件。

请核实已经对电子邮件收件用户启用了电子邮件发送功能。

  1. 单击设置,然后单击电子邮件配置

  2. 单击邮箱,将视图更改为可用邮箱

  3. 选择发送电子邮件的用户的 Customer Engagement (on-premises) 邮箱记录,然后单击编辑按钮。

  4. 请核实已经对用户正确配置和启用电子邮件发送功能:

电子邮件地址需要经过 Office 365 管理员的审批

注意:由于邮箱 <用户名> 的电子邮件地址需取得 Office 365 管理员的审批,因此电子邮件无法发送/接收电子邮件。 已禁止您的邮箱发送/接收电子邮件,并且已通知电子邮件服务器配置文件 Exchange Online 的所有者。

原因:

若用户被配置为使用 Microsoft Exchange Online 电子邮件服务器,但是他们的电子邮件地址没有得到 Office 365 管理员的允许,则会出现此错误。 在 Office 365 使用全局管理员角色的用户需要审批使用 Microsoft Exchange Online 电子邮件服务器配置文件的每个用户的电子邮件地址。 Microsoft Exchange Online 配置文件在 Dynamics 365 for Customer Engagement 应用和 Exchange Online 之间使用服务器到服务器的身份验证。 该身份验证依赖于 for Customer Engagement 应用和 Exchange Online 之间的信任。 作为一个 Office 365 全局管理员通过在 Customer Engagement (on-premises) 中验证电子邮件地址,Customer Engagement 应用能够为用户发送和接收电子邮件,并且在 Customer Engagement (on-premises) 中无需提供任何电子邮件凭据。

解决方法:

审核一个或多个邮箱:

  1. 作为在 Office 365 中具有 Office 365 全局管理员角色或 Dynamics 365 服务管理员角色的用户登录 Customer Engagement 应用。

  2. 转到设置>电子邮件配置

  3. 单击邮箱

  4. 选择可用邮箱或者执行高级查找查询以确定要更新的邮箱列表。

  5. 选择您想要审核的邮箱列表,然后单击批准电子邮件

  6. 单击确定批准电子邮件地址。

  7. 单击测试和启用邮箱为启用的邮箱重新测试邮件处理。

电子邮件地址必须取得审批

注意:由于电子邮件地址未审批,一个或多个邮箱不能发送/接收电子邮件。 审批电子邮件地址,然后启用电子邮件以发送/接收电子邮件。”或“邮箱 <邮箱名称> 无法接收电子邮件,因为邮箱 <邮箱名称> 的电子邮件地址未取得审核,所以已禁用此邮箱。 已通知电子邮件服务器配置文件 <电子邮件服务器配置文件名称> 的所有者。

解决方法:

在电子邮件处理前,必须审核邮箱。 审核邮箱:

  1. 作为在 Office 365 中具有 Office 365 全局管理员角色或 Dynamics 365 服务管理员角色的用户登录 Customer Engagement 应用。

  2. 转到设置>电子邮件配置

  3. 单击邮箱

  4. 选择可用邮箱或者执行高级查找查询以确定要更新的邮箱列表。

  5. 选择您想要审核的邮箱列表,然后单击批准电子邮件

  6. 单击确定批准电子邮件地址。

  7. 单击测试和启用邮箱为启用的邮箱重新测试邮件处理。

备注

通过设置>管理>系统设置>电子邮件选项卡,可以移除邮箱的审核要求。取消选中仅处理已审核用户的电子邮件仅处理已审核队列的电子邮件,然后单击确定。 若您使用 Microsoft Exchange Online 配置文件,必须仍由 Office 365 全局管理员批准电子邮件地址。

无法确定邮箱位置

注意:当发送/接收电子邮件 <邮件主题> 时,邮箱位置无法确定。 已禁止邮箱 <邮箱名称> 发送/接收电子邮件并且已通知相关电子邮件服务器配置文件 <电子邮件服务器配置文件名称> 的所有者。

解决方案:若您的电子邮箱服务器配置文件(设置>电子邮件配置>电子邮件服务器配置文件)配置为使用自动发现服务器的位置选项,但是自动发现无法检测到您的邮箱的位置,您会看到此警告。 若出现此问题,请检您的 Exchange 管理员配置验证是否配置为自动搜索。 可以更新电子邮件服务器配置文件并对自动发现服务器的位置单击。 然后为您的 Exchange 部署提供 Exchange Web 服务 URL。 例如:https://ExchangeServerName/EWS/Exchange.asmx.

凭据不正确或权限不足

注意:由于在关联电子邮件服务器配置文件中指定的凭据不正确或发送/接收权限不足,因此无法发送/接收电子邮件。 已禁止邮箱 <邮箱名称> 发送/接收电子邮件并且已通知电子邮件服务器配置文件 <电子邮件服务器配置文件名称> 的所有者。

解决方法:

若提供凭据不正确或者指定的用户帐户没有访问邮箱具有的足够权限,会出现此错误。 检查邮箱的凭据和权限。 如您在一个邮件服务器配置文件内提供凭证,请确保用户有每个相关邮箱的模拟权限和邮箱访问权限。

有关配置 Exchange 模拟和授予邮箱访问的详细信息,请参阅:

无法同步约会

注意:由于“组织者”字段不存在,所以无法同步约会。

原因:组织者字段是同步约会记录所必需的。 默认情况下,约会窗体上不包括此字段。

解决方法:

添加“组织者”字段到约会窗体:

  1. 转到设置>自定义>自定义系统

  2. 组件下,展开实体>约会,然后单击窗体

  3. 单击约会,然后拖动组织者字段到窗体上。

  4. 单击保存>发布

无法同步约会、联系人和任务

注意:由于未使用另一个 Customer Engagement (on-premises) 组织配置邮箱 <Mailbox Name> 的电子邮件地址,因此无法同步约会、联系人和任务。 当您在主要组织中测试和启用邮箱时,最佳做法是替换配置。 此外,在非主要组织中更改您的邮箱的同步方法。

解决方法:

若要更改主要同步组织和替换 Exchange 中存储的设置,请单击:设置>电子邮件配置>邮箱> 打开邮箱 >测试和启用邮箱> 选择仅与此 Dynamics 365 for Customer Engagement 组织中的 Exchange 同步项目,即使 Exchanges 被设置为与其他组织同步。 这将允许服务器端同步为 Customer Engagement (on-premises) 实例工作,但是其他实例将不能通过服务器端同步同步该邮箱。 若要更改约会、联系人和任务的同步方法,请单击:设置>电子邮件配置>邮箱> 打开邮箱 > 为约会、联系人和任务选择

有关更过信息,请参阅:何时使用该复选框?

潜在问题和解决

使用 Gmail 配置服务器端同步时,无法发送或接收电子邮件

如果 Customer Engagement (on-premises) 配置为使用 Gmail 的服务器端同步,您可能遇到下列错误之一:

  • 邮箱 <邮箱名称> 无法接收电子邮件。 请确保在此邮箱中指定的凭据正确并且具有的权限足以接收电子邮件。 然后启用此邮箱的电子邮件处理功能。

  • 发送电子邮件“测试邮件”时出现未知错误。 邮箱 <邮箱名称> 无法同步。 已通知电子邮件服务器配置文件 <电子邮件服务器配置文件名称> 的所有者。

有关详细信息,请参阅这篇知识库文章

禁用邮箱定期发送

邮箱发送错误类别如下所示:

  1. 持久错误(例如,401 未授权)或临时错误(例如,网络问题)。

  2. 服务器错误(例如,无效配置文件凭据)或邮箱错误(例如,邮箱凭据无效)。

    Customer Engagement (on-premises) 对错误的响应如下所示:

  • 对于服务器或邮箱持久错误,在检测错误时立即禁用邮箱。

  • 对于服务器或邮箱临时错误,将每五分钟尝试重新发送,共 10 次。 若 10 尝试失败,错误为持久错误并禁用邮箱。

回顾本主题中的疑难解答步骤,如果成功解决,启用邮箱。

不受支持的电子邮件服务配置

服务器端同步将不支持以下方案:

  • Exchange/SMTP 和 POP3/Exchange 的组合。

  • 创建大量的电子邮件营销活动。

  • 可扩展性方案如 EWS/POP3/SMTP 扩展协议和创建自定义的电子邮件提供商。

  • Exchange Server 2003 和 Exchange Server 2007。

  • Customer Engagement 应用中的服务器端同步,或针对 FIPS 140-2 兼容性配置的 Customer Engagement (on-premises) (on premises) 部署中的服务器端同步,需要与 FIPS 140-2 也兼容的 POP3/SMTP 电子邮件服务器。 某些电子邮件服务器与 FIPS 140-2 不兼容,例如 MSN、Outlook.com 或 Windows Live Mail。

对于服务器端同步不支持的大多数情况,您可以使用 Microsoft Dynamics CRM 电子邮件路由器。 详细信息:集成电子邮件系统

备注

建议您不要在同一组织中使用约会、联系人和任务的 Outlook 同步和服务器端同步的混合配置,因为这可能导致更新后的 Customer Engagement (on-premises) 数据不与所有参与者同步。

当由被邀请者跟踪时,在 Customer Engagement (on-premises) 中不创建约会记录。

注意以下 Customer Engagement (on-premises) 中有关跟踪事件的情况:

  1. 事件组织者为同步方法使用 Outlook。

  2. 事件被邀请者使用服务器端同步的同步方法。

  3. 在 Dynamics 365 for Outlook 中,组织者创建约会并向被邀请者发送邀请。

  4. 在 Dynamics 365 for Outlook 中,被邀请者跟踪约会。

  5. 邀请者登录到 Customer Engagement (on-premises) 并导航到市场营销>活动>约会>我的约会

结果:在 Customer Engagement (on-premises) 中没有为被邀请者创建约会。

这是一个已知问题,并不支持。 若组织者是 Customer Engagement (on-premises) 组织外的人,作为被邀请者的 Customer Engagement (on-premises) 用户仍可以跟踪创建在 Customer Engagement (on-premises) 中的记录。

服务约会和活动不从 Outlook 同步到 Customer Engagement (on-premises)

当您同步但反向同步不是“true”时,Customer Engagement (on-premises) 中做出的服务约会和活动变更将在 Dynamics 365 for Outlook 中更新。 当您在 Dynamics 365 for Outlook 中对服务约会或活动做出更改时,更改内容将不会同步到 Customer Engagement (on-premises)。 服务约会是由代理安排并需要 Customer Engagement (on-premises) 所提供资源的闲/忙信息。

注意 Exchange Online 的接收和发送限制

对于邮件流巨大的企业客户,请确保不与 Exchange Online 的接收和发送限制冲突。 请参阅 Exchange Online 限制

另请参阅

服务器端同步关于服务器端同步的最佳做法和须知事项
{隐藏的宝石}了解服务器端同步性能仪表板