Compartilhar via


Solucionar problemas dos produtos

Siga as instruções neste artigo para solucionar os problemas que você pode enfrentar ao trabalhar com produtos no Dynamics 365 Sales.

Problema 1 - A reassociação não está funcionando ou o campo Pai não está visível

A associação de novos produtos permite que você altere o pai de um registro de produto existente para que os produtos filhos herdem as propriedades apropriadas do produto. Para obter mais informações, consulte Alterar o pai de um produto.

Causa

Se você não vir o campo Pai no formulário Produto, pode ser porque você personalizou o formulário Produto Principal usando a solução não gerenciada. Para mais informações, consulte Visão geral de soluções.

Em alguns casos, os formulários de produto não são mesclados corretamente e, por isso, o campo Pai obrigatório não é adicionado ao formulário.

Solução

Para resolver isso, você deve adicionar o campo Pai de volta ao formulário. Você pode fazer isso por meio da personalização ou usando o assistente de importação/exportação da solução. Para obter mais informações, consulte Exportar soluções e Importar soluções.

Para adicionar o campo Pai por meio da personalização

  1. Em seu aplicativo, selecione o ícone Configurações e depois Configurações Avançadas.

    Opção Configurações Avançadas no menu Configurações.

    A página Gerenciamento de Negócios é aberta.

  2. Na barra de navegação, selecione Configurações e em Personalização, selecione Personalizações.

  3. Selecione Personalizar o sistema.

  4. Em Componentes no Gerenciador de Soluções, expanda Entidades e, em seguida, expanda a tabela Produto.

  5. Selecione Formulários e abra o formulário Produto do tipo Principal que está no estado Ativo .

  6. No editor de formulários, selecione o campo Pai no Explorador de Campos e arraste-o para a seção Resumo no lado esquerdo do editor de formulários.

    Adicione o campo Pai ao formulário Produto.

  7. Selecione Salvar e, em seguida , Publicar.

Para adicionar o campo Pai por meio do assistente de importação/exportação da solução

Na solução não gerenciada, adicione a seguinte linha no formulário principal do produto:

<row>
    <cell id="{faaa2942-4737-4721-9a19-7dcbf4eb2911}" showlabel="true" locklevel="0" colspan="2" solutionaction="Added">
        <control id="editableParentControl" classid="{270BD3DB-D9AF-4782-9025-509E298DEC0A}" datafieldname="parentproductid" disabled="false">
            <parameters>
                <DefaultViewId>{19d7f2e0-e427-40fb-85e8-53e7cef2b166}</DefaultViewId>
                <IsInlineNewEnabled>false</IsInlineNewEnabled>
                <DisableMru>true</DisableMru>
            </parameters>
        </control>
    </cell>
</row>

Problema 2 - Os campos Preço de Lista, Custo Padrão ou Custo Atual não respeitam o valor de precisão do campo Decimal Suportado

Solução

Não há relação entre o campo Decimal suportado e o campo Preço de lista. O valor definido no campo Decimal Suportado não afeta o valor de precisão do campo Preço de Lista. O valor de precisão decimal no campo Preço de Lista, Custo Padrão ou Custo Atual é controlado pela configuração Precisão Decimal de Preços . Por padrão, "Precisão decimal de preços" é definido como 2. Para obter mais informações sobre essa configuração, consulte a guia Configurações do sistema Geral. Para obter mais informações sobre precisão decimal, consulte Precisão decimal em moeda e preços.

Problema 3 - Ocorre um erro ao definir o campo Quantidade como um valor decimal nos registros Produto do pedido, Produto de cotação, Produto da fatura

Solução

O campo Opção de Venda de Quantidade do registro de item da lista de preços decide se o produto ou serviço pode ser pedido em quantidades inteiras, parciais ou em ambos os tipos. Para poder inserir valores decimais no campo Quantidade , verifique se o campo Opção de Venda de Quantidade não está definido como Inteiro. Para obter mais informações, consulte Definir preços de produtos com listas de preços e itens de lista de preços.

Problema 4 - Ocorre um erro ao abrir ou salvar um registro de produto quando o campo Decimal suportado tem o valor > 2

Solução

Se o campo Quantidade Disponível for usado no formulário, o valor do campo Decimal Suportado não deverá ser maior que a precisão de Quantidade Disponível.

Para corrigir esse problema, vá para Configurações>Personalizações>Entidades>Campos>Quantidade disponível. Verifique se o valor de Precisão é o mesmo que o valor Decimal com suporte .