メールに関する問題のトラブルシューティング
この記事は、Dynamics 365 Sales のメールに関連する問題のトラブルシューティングと解決に役立ちます。
問題 1: 電子メール エディターのコンテキスト メール ポップアップ ウィンドウに正しくないタイトルが表示される
Dynamics 365 2020 リリースウェーブ 2 にアップグレードした後、電子メール エディターでコンテキスト電子メール ポップアップ ウィンドウに正しくないタイトルが表示されます。
原因
既定の電子メール フォームでは、 onload
イベントと onchange
イベントがトリガーされ、コンテキストに応じた電子メール ポップアップでメール タイトルやその他の属性を更新できます。 ユーザー設定の電子メール フォームまたはアンマネージド レイヤー フォームがある場合、 onload
イベントと onchange
イベントは使用できません。 そのため、メールのタイトルが正しく表示されません。
解決方法
この問題を解決するには、カスタム電子メール フォームに onload
イベントと onchange
イベントを追加する必要があります。
新しく作成したソリューションにカスタム電子メール フォームを追加します。
ソリューションをエクスポート します。
フォームの XML に次のコードを追加します。
<events> <event name="onload" application="true" active="true"> <InternalHandlers> <Handler functionName="Activities.Email.formOnload" libraryName="Activities/SystemLibraries/Email_main_system_library.js" handlerUniqueId="ecdfe4d8-d6d3-4d21-ab68-8ea75bb30a79" enabled="true" parameters="" passExecutionContext="true" /> <Handler functionName="Activities.Email.NotifyPanelSubjectChange" libraryName="Activities/SystemLibraries/Email_main_system_library.js" handlerUniqueId="{706607A8-4424-4C9A-847A-602FC8035B48}" enabled="true" parameters="" passExecutionContext="true" solutionaction="Added"/> </InternalHandlers> </event> <event name="onchange" application="true" active="true" attribute="subject" solutionaction="Added"> <Handlers> <Handler functionName="Activities.Email.NotifyPanelSubjectChange" libraryName="Activities/SystemLibraries/Email_main_system_library.js" handlerUniqueId="{706607A8-4424-4C9A-847A-602FC8035B48}" enabled="true" parameters="" passExecutionContext="true"/> </Handlers> </event> </events> <clientresources> <internalresources> <clientincludes> <internaljscriptfile src="$webresource:Activities/SystemLibraries/Email_main_system_library.js" /> </clientincludes> </internalresources> </clientresources>
問題 2: 追跡されていないメールや会議を自動キャプチャで表示できない
自動キャプチャ には、組織内の一部またはすべてのユーザーの追跡されていないメールや会議は表示されません。
原因
バージョン 9.2.24031.00102 以降、Dynamics 365 Sales は最小特権アクセスの に従います。これによりテナントの Conditional アクセス ポリシーを持つユーザーは 追跡されていないメールや会議にアクセスできなくなります。
追跡されていないメールや会議がユーザーに表示されない場合は、次の手順を実行して、条件付きアクセス ポリシーが原因で問題が発生しているかどうかを確認します。
Microsoft Entra 管理センター少なくとも条件付きアクセス管理者としてサインインします。
Identity>Monitoring & health>Sign-in ログに移動。
ユーザー サインイン (非対話型) タブに切り替え、次のフィルターを追加します。
- Application contains Dataverse
- Resource には Microsoft Graph が含まれています
- Status equals Failure
影響を受けるユーザーに対して一部の結果が返された場合、条件付きアクセス ポリシーが原因で問題が発生します。
回避策
この問題は想定される動作であるため、この問題に対する解決策はありません。 別の方法として、ユーザーは Outlook で Microsoft Copilot for Sales を使用して個々のアクティビティを記録したり、 サーバー側の同期 を使用してすべてのメールや会議を自動的に追跡したりできます。