Résoudre les erreurs dans les stratégies de rétention et d’étiquette de rétention Microsoft 365
Si vous rencontrez une erreur liée aux stratégies de rétention ou d’étiquette de rétention Microsoft 365, sélectionnez la description d’erreur applicable dans la liste suivante :
- Paramètres introuvables
- Un problème est survenu
- L’emplacement est ambigu
- L’emplacement est en dehors du stockage
- Le site est verrouillé
- Nous continuons à traiter votre politique
- Nous ne pouvons pas traiter votre politique
- Nous n’avons pas trouvé cet emplacement
- Nous avons rencontré un problème
- Vous ne pouvez pas appliquer une conservation ici
- Votre stratégie est bloquée dans PendingDeletion
Si aucune des solutions ne s’applique à votre problème, contactez Support Microsoft.
Pour plus d’informations sur la façon d’identifier les erreurs de stratégie de rétention, consultez Identifier les erreurs dans les stratégies de rétention et d’étiquette de rétention Microsoft 365.
Importante
Microsoft Purview ne prend pas en charge les stratégies qui contiennent des erreurs. Vous devez d’abord résoudre toutes les erreurs de stratégie. Sinon, les stratégies de rétention et d’étiquette de rétention risquent de ne pas fonctionner comme prévu.
Erreur : Paramètres introuvables
Symptômes
Lorsque vous case activée le volet d’informations d’une stratégie de rétention dans le portail de conformité Microsoft Purview, le message d’erreur « Paramètres introuvables » s’affiche.
Cause
Votre stratégie de rétention n’a pas de règles de rétention.
Résolution
Pour résoudre ce problème, utilisez l’une des méthodes suivantes.
Méthode 1 : Utiliser le portail de conformité Microsoft Purview
Dans la portail de conformité Microsoft Purview, recherchez la stratégie sous les onglets suivants :
- Gestion du cycle de vie des> donnéesMicrosoft 365>Stratégies de rétention
- Gestion du cycle de vie des> donnéesMicrosoft 365>Stratégies d’étiquette
- Gestion des> enregistrementsStratégies d’étiquette
Sélectionnez la stratégie, puis modifier.
Dans Paramètres de rétention, ajoutez des règles à votre stratégie de rétention.
Méthode 2 : Utiliser PowerShell
Utilisez l’applet de commande applicable pour votre charge de travail afin d’ajouter des règles à votre stratégie de rétention.
Utilisez l’applet de commande New-RetentionComplianceRule pour les stratégies qui ciblent :
- Microsoft Exchange Online e-mail
- Sites Microsoft SharePoint
- Comptes Microsoft OneDrive
- Groupes Microsoft 365
- Conversations microsoft Skype Entreprise
- Dossiers publics Exchange Online
- Messages de conversation Microsoft Teams
- Messages du canal Teams
Par exemple, pour ajouter une règle qui spécifie une période de rétention illimitée, exécutez la commande suivante :
New-RetentionComplianceRule -Name "<new rule name>" -Policy "<existing policy name>" -RetentionDuration Unlimited
Utilisez l’applet de commande New-AppRetentionComplianceRule pour les stratégies qui ciblent :
- Messages du canal privé Teams
- Microsoft Viva Engage messages utilisateur
- Viva Engage messages de la communauté
Par exemple, pour ajouter une règle qui spécifie une période de rétention illimitée, exécutez la commande suivante :
New-AppRetentionComplianceRule -Name "<new rule name>" -Policy "<existing policy name>" -RetentionDuration Unlimited
Erreur : Un problème s’est produit
Symptômes
Lorsque vous case activée le volet d’informations d’une stratégie dans le portail de conformité Microsoft Purview, le message d’erreur « Un problème s’est produit » s’affiche.
Si vous exécutez la commande suivante, vous voyez PolicyNotifyError
dans la valeur retournée par la DistributionResults
propriété :
Get-RetentionCompliancePolicy -Identity "<policy name>" -DistributionDetail | Select -ExpandProperty DistributionResults
Cause
Une erreur non spécifiée s’est produite dans le pipeline de notification du processus de synchronisation et de distribution de la stratégie.
Résolution
Pour résoudre ce problème, utilisez l’une des méthodes suivantes. Si vous utilisez la méthode 1, case activée pour obtenir des options de résolution supplémentaires dans le volet d’informations de stratégie.
Méthode 1 : Utiliser le portail de conformité Microsoft Purview
Dans la portail de conformité Microsoft Purview, recherchez la stratégie sous les onglets suivants :
- Gestion du cycle de vie des> donnéesMicrosoft 365>Stratégies de rétention
- Gestion du cycle de vie des> donnéesMicrosoft 365>Stratégies d’étiquette
- Gestion des> enregistrementsStratégies d’étiquette
Sélectionnez la stratégie pour ouvrir le volet détails de la stratégie. Veillez à sélectionner le nom de la stratégie et non la case correspondante. Sinon, le volet d’informations ne s’ouvre pas.
Dans le volet détails de la stratégie, sélectionnez Réessayer. La stratégie passe à l’état en attente jusqu’à la fin de la synchronisation et de la distribution de la stratégie.
Méthode 2 : Utiliser PowerShell
Nouvelle tentative de synchronisation et de distribution de la stratégie. Utilisez l’applet de commande Set-RetentionCompliancePolicy avec le
RetryDistribution
commutateur pour redéployer la stratégie :Set-RetentionCompliancePolicy -Identity "<policy name>" -RetryDistribution
Erreur : L’emplacement est ambigu
Symptômes
Lorsque vous case activée le volet d’informations d’une stratégie dans le portail de conformité Microsoft Purview, le message d’erreur « L’emplacement est ambigu » s’affiche.
Si vous exécutez la commande suivante, vous voyez MultipleInactiveRecipientsError
dans la valeur retournée par la DistributionResults
propriété :
Get-RetentionCompliancePolicy -Identity "<policy name>" -DistributionDetail | Select -ExpandProperty DistributionResults
Cause
Le système a retourné plusieurs résultats pour l’emplacement spécifié. Pour que le système applique une stratégie, chaque emplacement applicable doit avoir une correspondance.
Résolution
Pour résoudre ce problème, utilisez l’une des méthodes suivantes. Si vous utilisez la méthode 1, case activée d’options de résolution supplémentaires dans le volet d’informations de stratégie qui s’ouvre lorsque vous sélectionnez le nom de la stratégie.
Méthode 1 : Utiliser le portail de conformité Microsoft Purview
Dans la portail de conformité Microsoft Purview, recherchez la stratégie sous les onglets suivants :
- Gestion du cycle de vie des> donnéesMicrosoft 365>Stratégies de rétention
- Gestion du cycle de vie des> donnéesMicrosoft 365>Stratégies d’étiquette
- Gestion des> enregistrementsStratégies d’étiquette
Sélectionnez la stratégie, puis modifier.
Supprimez les emplacements dupliqués de la stratégie.
Méthode 2 : Utiliser PowerShell
Supprimez les emplacements en double de la stratégie à l’aide de l’applet de commande Set-RetentionCompliancePolicy . Par exemple, pour supprimer un emplacement Exchange, utilisez le
RemoveExchangeLocation
commutateur .Nouvelle tentative de synchronisation et de distribution de la stratégie. Utilisez l’applet de commande Set-RetentionCompliancePolicy avec le
RetryDistribution
commutateur pour redéployer la stratégie :Set-RetentionCompliancePolicy -Identity "<policy name>" -RetryDistribution
Erreur : L’emplacement est en dehors du stockage
Symptômes
Lorsque vous essayez de créer ou de mettre à jour une stratégie dans le portail de conformité Microsoft Purview, l’opération échoue. Dans le volet d’informations de la stratégie, vous voyez le message d’erreur « L’emplacement est hors stockage ».
Si vous exécutez la commande suivante, vous voyez SiteOutOfQuota
dans la valeur retournée par la DistributionResults
propriété :
Get-RetentionCompliancePolicy -Identity "<policy name>" -DistributionDetail | Select -ExpandProperty DistributionResults
Cause
L’emplacement n’a pas suffisamment de stockage disponible pour que le système applique votre stratégie ou votre mise à jour de stratégie.
Résolution
Pour résoudre ce problème, utilisez l’une des méthodes suivantes. Si vous utilisez la méthode 1, case activée pour obtenir des options de résolution supplémentaires dans le volet d’informations de stratégie.
Méthode 1 : Utiliser le portail de conformité Microsoft Purview
Augmentez le quota de stockage pour l’emplacement spécifié. Contactez l’administrateur de site ou l’administrateur SharePoint global pour gérer le quota pour l’emplacement. Vous pouvez également supprimer les éléments inutiles pour augmenter le stockage disponible.
Dans la portail de conformité Microsoft Purview, recherchez la stratégie sous les onglets suivants :
- Gestion du cycle de vie des> donnéesMicrosoft 365>Stratégies de rétention
- Gestion du cycle de vie des> donnéesMicrosoft 365>Stratégies d’étiquette
- Gestion des> enregistrementsStratégies d’étiquette
Sélectionnez la stratégie pour ouvrir le volet détails de la stratégie. Veillez à sélectionner le nom de la stratégie et non la case correspondante. Sinon, le volet d’informations ne s’ouvre pas.
Dans le volet détails de la stratégie, sélectionnez Réessayer. La stratégie passe à l’état en attente jusqu’à la fin de la synchronisation et de la distribution de la stratégie.
Méthode 2 : Utiliser PowerShell
Augmentez le quota de stockage. Contactez l’administrateur de site ou l’administrateur SharePoint global pour gérer le quota pour l’emplacement. Vous pouvez également supprimer les éléments inutiles pour augmenter le stockage disponible.
Après avoir augmenté le quota de stockage, connectez-vous à Sécurité & Conformité PowerShell.
Nouvelle tentative de synchronisation et de distribution de la stratégie. Pour redéployer la stratégie, utilisez l’applet de commande Set-RetentionCompliancePolicy avec le
RetryDistribution
commutateur :Set-RetentionCompliancePolicy -Identity "<policy name>" -RetryDistribution
Erreur : le site est verrouillé
Symptômes
Lorsque vous case activée le volet d’informations d’une stratégie dans le portail de conformité Microsoft Purview, le message d’erreur « Le site est verrouillé » s’affiche.
Si vous exécutez la commande suivante, vous voyez SiteInReadOnlyOrNotAccessible
dans la valeur retournée par la DistributionResults
propriété :
Get-RetentionCompliancePolicy -Identity "<policy name>" -DistributionDetail | Select -ExpandProperty DistributionResults
Cause
Un administrateur a verrouillé le site ou le système a temporairement verrouillé le site pendant un processus automatisé. Pendant un processus automatisé, les mises à jour ne sont pas autorisées.
Résolution
Pour résoudre ce problème, utilisez l’une des méthodes suivantes. Si vous utilisez la méthode 1, case activée pour obtenir des options de résolution supplémentaires dans le volet d’informations de stratégie.
Méthode 1 : Utiliser le portail de conformité Microsoft Purview
Contactez l’administrateur de site ou l’administrateur SharePoint global pour déverrouiller le site, puis redéployez cette stratégie.
Dans la portail de conformité Microsoft Purview, recherchez la stratégie sous les onglets suivants :
- Gestion du cycle de vie des> donnéesMicrosoft 365>Stratégies de rétention
- Gestion du cycle de vie des> donnéesMicrosoft 365>Stratégies d’étiquette
- Gestion des> enregistrementsStratégies d’étiquette
Sélectionnez la stratégie pour ouvrir le volet détails de la stratégie. Veillez à sélectionner le nom de la stratégie et non la case correspondante. Sinon, le volet d’informations ne s’ouvre pas.
Dans le volet détails de la stratégie, sélectionnez Réessayer. La stratégie passe à l’état en attente jusqu’à la fin de la synchronisation et de la distribution de la stratégie.
Méthode 2 : Utiliser PowerShell
Pour déverrouiller le site, contactez l’administrateur de site ou l’administrateur SharePoint général, puis redéployez cette stratégie
Lorsque le site est déverrouillé, réessayez la synchronisation et la distribution de la stratégie. Utilisez l’applet de commande Set-RetentionCompliancePolicy avec le
RetryDistribution
commutateur pour redéployer la stratégie :Set-RetentionCompliancePolicy -Identity "<policy name>" -RetryDistribution
Erreur : Nous continuons à traiter votre stratégie
Symptômes
Lorsque vous case activée le volet d’informations d’une stratégie dans le portail de conformité Microsoft Purview, le message d’erreur « Nous traitons toujours votre stratégie » s’affiche.
Si vous exécutez la commande suivante, vous voyez PolicySyncTimeout
dans la valeur retournée par la DistributionResults
propriété :
Get-RetentionCompliancePolicy -Identity "<policy name>" -DistributionDetail | Select -ExpandProperty DistributionResults
Cause
La synchronisation de la stratégie ne s’est pas terminée dans le délai prévu.
Résolution
Pour résoudre ce problème, utilisez l’une des méthodes suivantes. Si vous utilisez la méthode 1, case activée pour obtenir des options de résolution supplémentaires dans le volet d’informations de stratégie.
Méthode 1 : Utiliser le portail de conformité Microsoft Purview
Dans la portail de conformité Microsoft Purview, recherchez la stratégie sous les onglets suivants :
- Gestion du cycle de vie des> donnéesMicrosoft 365>Stratégies de rétention
- Gestion du cycle de vie des> donnéesMicrosoft 365>Stratégies d’étiquette
- Gestion des> enregistrementsStratégies d’étiquette
Sélectionnez la stratégie pour ouvrir le volet détails de la stratégie. Veillez à sélectionner le nom de la stratégie et non la case correspondante. Sinon, le volet d’informations ne s’ouvre pas.
Dans le volet détails de la stratégie, sélectionnez Réessayer. La stratégie passe à l’état en attente jusqu’à la fin de la synchronisation et de la distribution de la stratégie.
Méthode 2 : Utiliser PowerShell
Nouvelle tentative de synchronisation et de distribution de la stratégie. Utilisez l’applet de commande Set-RetentionCompliancePolicy avec le
RetryDistribution
commutateur pour redéployer la stratégie :Set-RetentionCompliancePolicy -Identity "<policy name>" -RetryDistribution
Erreur : Nous ne pouvons pas traiter votre stratégie
Symptômes
Lorsque vous case activée le volet d’informations d’une stratégie dans le portail de conformité Microsoft Purview, le message d’erreur « Nous ne pouvons pas traiter votre stratégie » s’affiche.
Si vous exécutez la commande suivante, vous voyez ActiveDirectorySyncError
dans la valeur retournée par la DistributionResults
propriété :
Get-RetentionCompliancePolicy -Identity "<policy name>" -DistributionDetail | Select -ExpandProperty DistributionResults
Cause
La stratégie n’a pas été synchronisée avec Microsoft Entra ID.
Résolution
Pour résoudre ce problème, utilisez l’une des méthodes suivantes. Si vous utilisez la méthode 1, case activée pour obtenir des options de résolution supplémentaires dans le volet d’informations de stratégie.
Méthode 1 : Utiliser le portail de conformité Microsoft Purview
Dans la portail de conformité Microsoft Purview, recherchez la stratégie sous les onglets suivants :
- Gestion du cycle de vie des> donnéesMicrosoft 365>Stratégies de rétention
- Gestion du cycle de vie des> donnéesMicrosoft 365>Stratégies d’étiquette
- Gestion des> enregistrementsStratégies d’étiquette
Sélectionnez la stratégie pour ouvrir le volet détails de la stratégie. Veillez à sélectionner le nom de la stratégie et non la case correspondante. Sinon, le volet d’informations ne s’ouvre pas.
Dans le volet détails de la stratégie, sélectionnez Réessayer. La stratégie passe à l’état en attente jusqu’à la fin de la synchronisation et de la distribution de la stratégie.
Méthode 2 : Utiliser PowerShell
Nouvelle tentative de synchronisation et de distribution de la stratégie. Utilisez l’applet de commande Set-RetentionCompliancePolicy avec le
RetryDistribution
commutateur pour redéployer la stratégie :Set-RetentionCompliancePolicy -Identity "<policy name>" -RetryDistribution
Erreur : Nous n’avons pas trouvé cet emplacement
Symptômes
Lorsque vous case activée le volet d’informations d’une stratégie dans le portail de conformité Microsoft Purview, le message d’erreur « Nous n’avons pas trouvé cet emplacement » s’affiche.
Si vous exécutez la commande suivante, vous voyez FailedToOpenContainer
dans la valeur retournée par la DistributionResults
propriété :
Get-RetentionCompliancePolicy -Identity "<policy name>" -DistributionDetail | Select -ExpandProperty DistributionResults
Cause
La stratégie ne peut pas se synchroniser avec un emplacement, car l’emplacement n’existe pas. L’emplacement a peut-être existé précédemment.
Remarque
Si cette erreur se produit, le système exige que vous supprimiez les emplacements problématiques dans le cadre de votre prochaine mise à jour de la stratégie.
Résolution
Pour résoudre ce problème, utilisez l’une des méthodes suivantes. Si vous utilisez la méthode 1, case activée pour obtenir des options de résolution supplémentaires dans le volet d’informations de stratégie.
Méthode 1 : Utiliser le portail de conformité Microsoft Purview
Dans la portail de conformité Microsoft Purview, recherchez la stratégie sous les onglets suivants :
- Gestion du cycle de vie des> donnéesMicrosoft 365>Stratégies de rétention
- Gestion du cycle de vie des> donnéesMicrosoft 365>Stratégies d’étiquette
- Gestion des> enregistrementsStratégies d’étiquette
Sélectionnez la stratégie pour ouvrir le volet détails de la stratégie. Veillez à sélectionner le nom de la stratégie et non la case correspondante. Sinon, le volet d’informations ne s’ouvre pas.
Supprimez les emplacements problématiques de la stratégie.
Méthode 2 : Utiliser PowerShell
Supprimez les emplacements problématiques de la stratégie à l’aide de l’applet de commande Set-RetentionCompliancePolicy . Par exemple, pour supprimer un emplacement Exchange, utilisez le
RemoveExchangeLocation
commutateur .Nouvelle tentative de synchronisation et de distribution de la stratégie. Utilisez l’applet de commande Set-RetentionCompliancePolicy avec le
RetryDistribution
commutateur pour redéployer la stratégie :Set-RetentionCompliancePolicy -Identity "<policy name>" -RetryDistribution
Erreur : Nous avons rencontré un problème
Symptômes
Lorsque vous case activée le volet d’informations d’une stratégie dans le portail de conformité Microsoft Purview, le message d’erreur « Nous avons rencontré un problème » s’affiche.
Si vous exécutez la commande suivante, vous voyez InternalError
dans la valeur retournée par la DistributionResults
propriété :
Get-RetentionCompliancePolicy -Identity "<policy name>" -DistributionDetail | Select -ExpandProperty DistributionResults
Cause
Une erreur non spécifiée s’est produite dans le processus de synchronisation et de distribution de la stratégie.
Résolution
Pour résoudre ce problème, utilisez l’une des méthodes suivantes. Si vous utilisez la méthode 1, case activée pour obtenir des options de résolution supplémentaires dans le volet d’informations de stratégie.
Méthode 1 : Utiliser le portail de conformité Microsoft Purview
Dans la portail de conformité Microsoft Purview, recherchez la stratégie sous les onglets suivants :
- Gestion du cycle de vie des> donnéesMicrosoft 365>Stratégies de rétention
- Gestion du cycle de vie des> donnéesMicrosoft 365>Stratégies d’étiquette
- Gestion des> enregistrementsStratégies d’étiquette
Sélectionnez la stratégie pour ouvrir le volet détails de la stratégie. Veillez à sélectionner le nom de la stratégie et non la case correspondante. Sinon, le volet d’informations ne s’ouvre pas.
Dans le volet détails de la stratégie, sélectionnez Réessayer. La stratégie passe à l’état en attente jusqu’à la fin de la synchronisation et de la distribution de la stratégie.
Méthode 2 : Utiliser PowerShell
Nouvelle tentative de synchronisation et de distribution de la stratégie. Utilisez l’applet de commande Set-RetentionCompliancePolicy avec le
RetryDistribution
commutateur pour redéployer la stratégie :Set-RetentionCompliancePolicy -Identity "<policy name>" -RetryDistribution
Erreur : Vous ne pouvez pas appliquer de conservation ici
Symptômes
Lorsque vous essayez d’ajouter un emplacement à une stratégie dans le portail de conformité Microsoft Purview, l’opération échoue et le message d’erreur « Vous ne pouvez pas appliquer de conservation ici » s’affiche.
Si vous essayez d’ajouter un emplacement à une stratégie à l’aide de PowerShell, le RecipientTypeNotAllowed
message d’erreur s’affiche.
Cause
Vous avez essayé d’ajouter un emplacement de boîte aux lettres à une stratégie, mais la stratégie ne prend pas en charge le type de boîte aux lettres. Cette erreur se produit uniquement lorsqu’un emplacement est ajouté à une stratégie.
Résolution
Pour résoudre ce problème, utilisez l’une des méthodes suivantes.
Méthode 1 : Utiliser le portail de conformité Microsoft Purview
Retour à l’étape dans laquelle vous avez spécifié les emplacements de stratégie, puis supprimez les emplacements problématiques de la stratégie.
Réessayez votre mise à jour.
Méthode 2 : Utiliser PowerShell
Dans le script ou la commande que vous avez utilisé pour ajouter des emplacements, supprimez les emplacements problématiques. Les applets de commande PowerShell applicables sont les suivantes :
Réessayez votre mise à jour.
Erreur : Votre stratégie est bloquée dans PendingDeletion
Symptômes
Lorsque vous essayez de supprimer une stratégie, l’opération échoue.
Cause
Une erreur non spécifiée s’est produite lorsque vous avez essayé de supprimer la stratégie.
Résolution
Supprimez la stratégie. Utilisez l’applet de commande Remove-RetentionCompliancePolicy avec le
ForceDeletion
commutateur :Remove-RetentionCompliancePolicy -Identity "<policy name>" -ForceDeletion
Informations supplémentaires
Pour plus d’informations sur la résolution des problèmes eDiscovery, consultez Résoudre les problèmes courants d’eDiscovery.