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Résoudre les erreurs de recherche dans eDiscovery (Standard)

Si vous rencontrez un problème ou une erreur lié aux recherches dans Microsoft Purview eDiscovery (Standard), réessayez l’opération pour exclure les problèmes temporaires. Pour les problèmes qui persistent, sélectionnez la description applicable dans la liste suivante :

Si aucune de ces solutions ne s’applique à votre problème de recherche, contactez Support Microsoft. Selon votre problème, rassemblez la sortie à l’aide de l’applet de commande PowerShell Get-ComplianceSearch ou Get-ComplianceSearchAction avant de créer un cas de support. Pour plus d’informations sur les autres informations de diagnostic dont Support Microsoft pourriez avoir besoin, consultez Collecter les informations de diagnostic eDiscovery.

Pour les problèmes de conservation eDiscovery, consultez Résoudre les erreurs de conservation dans eDiscovery (Standard) .

Problème de recherche : différence entre les résultats de recherche estimés et téléchargés

Symptômes

Lorsque vous affichez les statistiques des résultats de la recherche dans le fichier d’horodatage> Résumé d’exportation <.csv dans le dossier des résultats de la recherche eDiscovery téléchargé, vous remarquez que les statistiques de résultats de recherche estimées et téléchargées diffèrent. Les statistiques des résultats de recherche estimés sont également affichées dans le volet d’informations de la recherche dans le portail de conformité Microsoft Purview et dans l’outil d’exportation eDiscovery.

Cause

Une estimation des résultats de la recherche est simplement celle-ci : il s’agit d’une estimation et non d’un nombre réel d’éléments qui répondent aux critères de la requête de recherche. Pour plus d’informations sur les raisons pour lesquelles les résultats de recherche estimés et téléchargés peuvent différer, consultez Différences entre les résultats de recherche eDiscovery estimés et réels.

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Erreur de recherche : « L’emplacement est ambigu »

Symptômes

Lorsque vous exécutez une recherche eDiscovery, la recherche échoue et retourne le message d’erreur suivant :

La recherche de conformité contient le ou les emplacements non valides suivants : <identificateur> de boîte aux lettres. L’identificateur> de boîte aux lettres d’emplacement <est ambigu.

Cause

Les emplacements spécifiés dans le message d’erreur ne sont pas valides. L’identificateur de boîte aux lettres pour chaque emplacement non valide est utilisé par des objets en double ou en conflit dans Exchange Online Protection (EOP).

Résolution

Pour chaque emplacement non valide, procédez comme suit :

  1. Se connecter à Security & Compliance PowerShell.

  2. Recherchez les objets en double ou en conflit qui utilisent un identificateur de boîte aux lettres. Pour ce faire, exécutez la commande Get-Recipient suivante :

    Get-Recipient -Identity "<mailbox identifier from error message>"
    
  3. Supprimez l’objet en double ou en conflit.

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Erreur de recherche : « Destinataire introuvable »

Symptômes

Votre recherche eDiscovery échoue et retourne le message d’erreur « Destinataire introuvable ».

Cause

Le système ne peut pas trouver l’un des destinataires dans votre recherche eDiscovery en raison de retards de synchronisation dans Exchange Online Protection (EOP).

Résolution

  1. Se connecter à Security & Compliance PowerShell.

  2. Vérifiez si les destinataires de la requête de recherche sont synchronisés dans EOP à l’aide de l’applet de commande Get-Recipient . Exécutez la commande suivante :

    Get-Recipient -Identity "<user identifier>" | FL
    
  3. Si la commande ne retourne pas d’objet utilisateur pour un destinataire, attendez 30 minutes que la synchronisation se termine, puis revérifier.

  4. Après avoir vérifié que le destinataire est synchronisé dans EOP, réessayez votre recherche.

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Erreur de recherche : CS007

Symptômes

Votre recherche eDiscovery échoue et retourne un CS007 code d’erreur.

Cause

L’un des problèmes suivants peut provoquer cette erreur :

  • Problème temporaire

  • Requête de recherche qui retourne trop de résultats pour que le système soit traité. Par exemple, une requête qui utilise plusieurs caractères génériques peut retourner un jeu de résultats volumineux.

Résolution

Réessayez votre recherche. Si votre recherche échoue toujours, divisez votre recherche en recherches plus petites. Par exemple, utilisez des plages de dates ou limitez le nombre d’emplacements de recherche pour retourner des jeux de résultats plus petits.

Erreur de recherche : « Erreur de serveur interne (500) qui s’est produite »

Symptômes

Votre recherche eDiscovery échoue et retourne le message d’erreur « Une erreur interne du serveur (500) s’est produite ».

Cause

Les problèmes qui peuvent provoquer cette erreur sont les suivants :

  • Requête de recherche qui retourne trop de résultats pour que le système soit traité. Par exemple, une requête qui utilise plusieurs caractères génériques peut retourner un jeu de résultats volumineux.

  • Autres erreurs de recherche. Pour case activée de ces erreurs, exécutez la commande suivante pour obtenir des informations sur la recherche, puis recherchez les messages d’erreur dans la sortie :

    Get-ComplianceSearch -Identity <search name> | FL ResultDetails
    

Résolution

Réessayez votre recherche. Si votre recherche échoue toujours, divisez votre recherche en recherches plus petites. Par exemple, utilisez des plages de dates ou limitez le nombre d’emplacements de recherche pour retourner des jeux de résultats plus petits.

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Erreur de recherche ou d’exportation : « Nombre maximal de travaux pour votre organization sont en cours d’exécution »

Symptômes

Lorsque vous essayez de rechercher ou d’exporter les résultats de la recherche eDiscovery, l’opération échoue et vous recevez le message d’erreur suivant :

Votre demande ne peut pas être démarrée, car le nombre maximal de travaux pour votre organization sont en cours d’exécution.

Cause

Votre organization a atteint la limite maximale de 50 travaux simultanés. Étant donné que les travaux d’exportation prennent généralement plus de temps que les travaux de recherche, les travaux d’exportation sont plus susceptibles de remplir le quota.

Résolution

Utilisez la procédure suivante pour voir les travaux d’exportation en cours d’exécution :

Remarque

Pour utiliser la procédure suivante, vous devez être membre du groupe de rôles Gestionnaire eDiscovery et être administrateur eDiscovery dans ce groupe. Pour plus d’informations sur la façon d’afficher ou d’affecter des administrateurs eDiscovery dans votre organization, consultez Attribuer des autorisations eDiscovery, Get-eDiscoveryCaseAdmin et Add-eDiscoveryCaseAdmin.

  1. Se connecter à Security & Compliance PowerShell.

  2. Exécutez le script suivant :

    $date = Get-Date
    $exports = @(Get-ComplianceSearchAction -Export -ResultSize Unlimited)
    $cases = Get-ComplianceCase | ?{$_.status -like "Active"}
    $i = 1
    foreach ($case in $cases) {
      $exports += Get-ComplianceSearchAction -Export -Case $case.Name
      Write-Host "Processing case $($i) of $($cases.Count)"
      $i++
    }
    $inProgressExports = $exports | ?{$_.Results -eq $null -or (!$_.Results.Contains("Export status: Completed") -and !$_.Results.Contains("Export status: none"))}
    $inProgressExportsSince = $inProgressExports | ?{$_.JobStartTime -ge $date.AddDays(-7)} | Sort-Object JobStartTime -Descending
    Write-Host "In-progress export jobs:"
    $inProgressExports | Format-Table Name,JobStartTime,JobEndTime,Status | More
    Write-Host "In-progress export jobs started in the last 7 days:"
    $inProgressExportsSince | Format-Table Name,JobStartTime,JobEndTime,Status | More
    

Pour résoudre l’erreur, procédez comme suit :

  1. Réduisez le nombre de travaux en cours d’exécution. Utilisez l’une des approches suivantes ou les deux :

    • Attendez qu’un ou plusieurs travaux en cours d’exécution se terminent.

    • Supprimez un ou plusieurs travaux en cours d’exécution dont vous n’avez plus besoin à l’aide de l’applet de commande PowerShell Remove-ComplianceSearchAction .

  2. Réessayez votre opération de recherche ou d’exportation.

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Problème d’exportation : l’exportation semble bloquée

Symptômes

Vous essayez d’exporter les résultats de la recherche eDiscovery, mais l’exportation ne se termine pas et elle semble bloquée.

Cause

Des problèmes temporaires peuvent bloquer le processus d’exportation.

Résolution

Redémarrez l’exportation.

Remarque

Vous ne pouvez pas redémarrer une exportation de résultats de recherche qui ont été générés plus de sept jours plus tôt. Au lieu de cela, réexécutez la recherche, puis démarrez l’exportation.

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Erreur d’exportation : « L’élément a été déplacé ou supprimé » ou « Impossible de récupérer l’élément en raison d’un délai d’expiration »

Symptômes

Après avoir téléchargé les résultats de la recherche eDiscovery, vous voyez les erreurs suivantes dans le fichier Avertissements d’exportation et Errors.csv dans le dossier d’exportation téléchargé :

  • FailedToExportItem_Microsoft.Exchange.EDiscovery.Export.ExportException : l’exportation a échoué avec le type d’erreur « FailedToExportItem ». Message : l’élément a été déplacé ou supprimé.

  • FailedToExportItem_Microsoft.Exchange.EDiscovery.Export.ExportException : l’exportation a échoué avec le type d’erreur « FailedToExportItem ». Message : Impossible de récupérer l’élément en raison d’un délai d’expiration après plusieurs nouvelles tentatives.

Cause

Ces messages d’erreur « FailedToExportItem » indiquent que le système n’a pas exporté tous les éléments des résultats de recherche. Les éléments non exportés sont des sauvegardes temporaires créées par le système lors de l’archivage de boîtes aux lettres. Bien qu’eDiscovery puisse rechercher des éléments de sauvegarde temporaires, ces éléments ne sont pas exportables.

Résolution

Attendez que le système récupère et exporte les éléments de boîte aux lettres d’origine associés aux sauvegardes temporaires.

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Erreur d’exportation : « La demande a échoué avec le code status 500 » ou « Erreur du serveur interne 500 »

Symptômes

Lorsque vous essayez d’exporter ou de télécharger les résultats de la recherche eDiscovery, vous recevez l’un des messages d’erreur suivants :

  • Échec de la demande avec le code status 500

  • Erreur de serveur interne 500

Cause

Le problème peut se produire pour l’une des raisons suivantes.

Cause 1

Vous n’avez pas le rôle Exporter. Le rôle Exporter est automatiquement attribué aux membres du groupe de rôles Gestionnaire eDiscovery. Le rôle Exporter n’est pas automatiquement attribué aux membres du groupe de rôles Gestion de l’organisation.

Cause 2

L’erreur se produit lorsque vous essayez de télécharger les résultats de recherche exportés si vous n’êtes pas l’administrateur qui a exporté les résultats de la recherche.

Cause 3

Les filtres d’autorisations pour votre compte d’utilisateur limitent les boîtes aux lettres, les emplacements de stockage ou le contenu que vous pouvez rechercher et exporter.

Cause 4

La quantité de données exportables pour votre recherche dépasse 2 To. La quantité maximale de données exportables pour une seule recherche est de 2 To. Pour déterminer la taille des données exportables, exécutez la commande suivante :

Get-ComplianceSearch -Identity <search name> | FL Size,SuccessResults,SearchStatistics

Résolution

Choisissez la résolution qui correspond à la cause applicable.

Résolution 1

Si vous êtes membre du groupe de rôles Gestion de l’organisation, ajoutez-vous au groupe de rôles Gestionnaire eDiscovery. Vous pouvez le faire dans la page Autorisations du portail de conformité Microsoft Purview ou en utilisant l’applet de commande PowerShell Add-eDiscoveryCaseAdmin.

Résolution 2

Demandez à l’administrateur qui a créé l’exportation de terminer le téléchargement. Pour trouver cet administrateur, exécutez la commande suivante :

Get-ComplianceSearchAction -Export -Case <case name> | FL Name,CreatedBy

Résolution 3

Pour les boîtes aux lettres et les emplacements de stockage que vous souhaitez rechercher et exporter, case activée si des filtres d’autorisations empêchent ces actions. Si nécessaire, demandez à un administrateur de configurer des filtres d’autorisations.

Résolution 4

Réduisez la taille de téléchargement en divisant votre recherche en recherches plus petites. Par exemple, utilisez des plages de dates ou limitez le nombre d’emplacements de recherche pour retourner des jeux de résultats plus petits.

Pour case activée si les rôles Recherche, Exportation ou Aperçu sont attribués au compte d’administrateur désigné, exécutez le test suivant dans le Centre d'administration Microsoft 365. Vous devez disposer des autorisations d’administrateur général ou d’administrateur de conformité pour effectuer les étapes suivantes.

Remarque

Ce diagnostic n’est pas disponible pour les environnements GCC High ou DoD, ni pour Microsoft 365 géré par 21Vianet.

  1. Dans le Centre d'administration Microsoft 365, sélectionnez le bouton Exécuter les tests : eDiscovery RBAC case activée pour remplir le test associé :

  2. Dans la section Exécuter diagnostics, entrez l’UPN ou l’adresse e-mail de l’utilisateur qui tente d’exécuter la tâche de recherche, d’exportation ou d’aperçu.

  3. Sélectionnez Exécuter les tests.

  4. Si l’utilisateur n’a pas les rôles eDiscovery nécessaires attribués, attribuez ces rôles afin que l’utilisateur puisse exécuter la tâche souhaitée.

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Erreur d’exportation : « Le fichier n’a pas été exporté car il n’existe pas » ou « Fichier introuvable »

Symptômes

Après avoir téléchargé les résultats de la recherche eDiscovery, vous voyez l’un des messages d’erreur suivants dans les fichiers Avertissements d’exportation et Errors.csv, Items.csvignorés ou trace.log dans le dossier d’exportation téléchargé :

  • Ce fichier n’a pas été exporté, car il n’existe plus. Le fichier a été inclus dans le nombre de résultats de recherche estimés, car il est toujours répertorié dans l’index. Le fichier sera finalement supprimé de l’index et ne provoquera pas d’erreur à l’avenir.

  • FailedToExportItem_Failed télécharger du contenu. Informations de diagnostic supplémentaires : Microsoft.Office.Compliance.EDiscovery.ExportWorker.Exceptions.ContentDownloadTemporaryFailure : Échec du téléchargement à partir de l’ID> de document de contenu <de type Document. ID de corrélation : <ID de> corrélation. ServerErrorCode : -2147024894 ---> Microsoft.SharePoint.Client.ServerException : Fichier introuvable. sur Microsoft.SharePoint.Client.ClientRequest.ProcessResponseStream(Stream responseStream) à l’adresse Microsoft.SharePoint.Client.ClientRequest.ProcessResponse() --- Fin de la trace de pile d’exceptions interne ---

Cause

Ce message d’erreur peut s’afficher si la recherche eDiscovery inclut des emplacements Microsoft Office SharePoint Online ou Microsoft OneDrive Entreprise. eDiscovery s’appuie sur l’index SharePoint Online pour identifier les fichiers dans ces deux emplacements. L’erreur se produit si un utilisateur renomme, déplace ou supprime un fichier dans les résultats de la recherche une fois la recherche terminée, mais avant que le système ne met à jour l’index SharePoint Online. Vous pouvez case activée si un fichier a été renommé, déplacé ou supprimé en recherchant le fichier dans l’emplacement SharePoint Online ou OneDrive Entreprise applicable.

Résolution

Pour résoudre le problème, réindexez l’emplacement SharePoint Online ou OneDrive Entreprise à l’aide de l’une des procédures fournies dans Demander manuellement l’analyse et la réindexation d’un site, d’une bibliothèque ou d’une liste. Si vous souhaitez que les résultats de la recherche incluent les fichiers renommés ou déplacés, réexécutez la recherche eDiscovery.

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Problème de téléchargement d’exportation : téléchargement lent des résultats de recherche exportés

Symptômes

Lorsque vous téléchargez les résultats de la recherche eDiscovery, le téléchargement prend plus de temps que prévu.

Cause

Les problèmes qui peuvent entraîner un téléchargement lent sont les suivants :

  • Une grande quantité de données d’exportation. Pour déterminer la taille du téléchargement, exécutez la commande suivante :

    Get-ComplianceSearch -Identity <search name> | FL Size,SuccessResults,SearchStatistics
    
  • Une charge plus élevée que d’habitude sur les serveurs de boîtes aux lettres.

  • Autres erreurs de téléchargement. Pour case activée ces erreurs :

    • Exécutez la commande suivante pour obtenir des informations sur une exportation en cours. Recherchez les messages d’erreur dans la sortie de la commande.

      Get-ComplianceSearchAction | FL Results
      
    • Recherchez les messages d’erreur dans le fichier trace.log dans le dossier d’exportation téléchargé.

Résolution

Pour réduire la taille du téléchargement, divisez votre recherche en recherches plus petites. Par exemple, utilisez des plages de dates ou limitez le nombre d’emplacements de recherche pour retourner des jeux de résultats plus petits.

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Problème de téléchargement d’exportation : l’outil d’exportation eDiscovery ne télécharge aucun fichier

Symptômes

Vous exécutez l’outil d’exportation eDiscovery pour télécharger les résultats de la recherche eDiscovery. Toutefois, une fois l’opération terminée, le champ Total estimé dans la fenêtre outil indique qu’aucun fichier n’a été téléchargé.

Cause

Le problème peut se produire pour l’une des raisons suivantes :

  • Un logiciel antivirus sur l’ordinateur de destination bloque le téléchargement.

  • Vous sélectionnez un lecteur de téléchargement qui n’est pas un lecteur local.

  • Vous sélectionnez un dossier de destination :

    • Dossier de téléchargement d’une autre exportation eDiscovery.

    • Dossier parent du dossier de téléchargement d’une autre exportation eDiscovery. Étant donné que l’outil d’exportation enregistre les fichiers de métadonnées dans le dossier parent, les fichiers de métadonnées pour différents téléchargements peuvent entrer en conflit les uns avec les autres.

Résolution

Essayez chacune des méthodes suivantes dans l’ordre donné jusqu’à ce que le problème soit résolu :

  1. Suspendez le scanneur antivirus sur l’ordinateur de destination, puis réessayez le téléchargement.

  2. Télécharger sur un lecteur local. Si nécessaire, téléchargez sur un autre ordinateur client.

  3. Sélectionnez un dossier de destination qui n’est pas en conflit avec une exportation eDiscovery simultanée.

  4. Désactivez l’exportation vers un dossier compressé et désactivez la déduplication du contenu Exchange. Si cette étape résout le problème, la cause est probablement un logiciel antivirus bloquant le téléchargement ou que vous avez essayé de télécharger sur un lecteur distant.

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Erreur de téléchargement d’exportation : « Le résultat de la recherche n’a pas été téléchargé, car il s’agit d’un dossier »

Symptômes

Après avoir téléchargé les résultats de la recherche eDiscovery, le message d’erreur suivant s’affiche dans le fichier Items.csvignoré dans le dossier d’exportation téléchargé :

Ce résultat de recherche n’a pas été téléchargé, car il s’agit d’un dossier ou d’un autre artefact qui ne peut pas être téléchargé par lui-même. Tous les éléments du dossier ou de la bibliothèque seront téléchargés.

Cause

Ce message d’erreur peut s’afficher si votre recherche inclut des emplacements Microsoft Office SharePoint Online ou Microsoft OneDrive Entreprise. Le fichier Items.csvignoré répertorie tous les dossiers et autres éléments ignorés dans les résultats de la recherche. Le message d’erreur apparaît généralement en regard des chemins d’accès aux dossiers, car il ne s’agit pas d’éléments téléchargeables.

Résolution

Aucune résolution n’est requise. Vous pouvez ignorer le message d’erreur en toute sécurité.

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Erreur de téléchargement d’exportation : « Impossible d’accéder au fichier 'ExportData.db' »

Symptômes

Vous exécutez l’outil d’exportation eDiscovery pour télécharger les résultats de recherche eDiscovery, mais le téléchargement est bloqué ou produit des fichiers sans octet. Le message d’erreur suivant s’affiche dans le fichier trace.log dans le dossier d’exportation téléchargé :

Erreur tolérable, réessaye : le processus ne peut pas accéder au fichier « ExportData.db », car il est utilisé par un autre processus.

Cause

Le problème peut se produire si :

  • Un logiciel antivirus sur l’ordinateur de destination bloque le téléchargement.

  • Vous sélectionnez un lecteur de téléchargement qui n’est pas un lecteur local.

  • Vous sélectionnez un dossier de destination :

    • Dossier de téléchargement d’une autre exportation eDiscovery.

    • Dossier parent du dossier de téléchargement d’une autre exportation eDiscovery. Étant donné que l’outil d’exportation enregistre les fichiers de métadonnées dans le dossier parent, les fichiers de métadonnées pour différents téléchargements peuvent entrer en conflit.

Résolution

Essayez chacune des méthodes suivantes dans l’ordre donné jusqu’à ce que l’erreur soit résolue :

  1. Suspendez le scanneur antivirus sur l’ordinateur de destination, puis réessayez le téléchargement.

  2. Télécharger sur un lecteur local. Si nécessaire, téléchargez sur un autre ordinateur client.

  3. Sélectionnez un dossier de destination qui n’est pas en conflit avec une exportation eDiscovery simultanée.

  4. Désactivez l’exportation vers un dossier compressé et désactivez la déduplication du contenu Exchange. Si cette étape résout le problème, la cause est probablement un logiciel antivirus bloquant le téléchargement ou que vous avez essayé de télécharger sur un lecteur distant.

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