當您連線到 RDS 時,「您的工作階段將在 60 分鐘內中斷連線」訊息
本文可協助您針對使用 RDS 授權軟式強制執行時發生的遠端桌面服務 (RDS) 授權錯誤進行疑難解答。
適用於: Windows Server 2022、Windows Server 2019、Windows Server 2016
徵兆
當您使用遠端桌面入口網站 (RD Web 入口網站) 或直接遠端桌面通訊協定 (RDP) 連線來連線到遠端桌面服務 (RDS) 伺服器陣列時,您會收到類似下列的訊息:
遠端桌面授權發生問題,而您的會話會在 60 分鐘內中斷連線。 請連絡系統管理員以修正此問題。
原因
此訊息是由 Windows Server 2016 針對個別裝置授權引進的軟式強制授權功能所造成,而 Windows Server 2019 則是針對每個使用者授權所引進。 它表示 RD 授權伺服器發生問題,或導致 RD 授權伺服器與遠端桌面會話主機 (RD 工作階段主機) 伺服器之間的通訊發生問題。
在一般授權強制執行防止用戶連線到 RD 工作階段主機的情況下,軟強制可讓使用者一次連線 60 分鐘。 用戶連線時會收到訊息。 60 分鐘之後,使用者會中斷連線。 不過,用戶可以重新連線到相同的會話。
本文將分別討論每個使用者和個別裝置授權案例。
個別使用者授權的軟式強制執行 (Windows Server 2019)
在個別用戶授權案例中(僅限 Windows Server 2019),授權軟式強制執行行為與個別裝置案例不同。 如果使用者在每個使用者案例中看到此訊息,請確定所有遠端桌面伺服器都已安裝最新的更新。 如果問題持續發生,請連絡 Microsoft 技術支援。
重要
Windows Server 2022 已移除遠端桌面授權 (RD 授權) 軟式強制執行功能。
個別裝置授權的軟式強制執行
在個別裝置授權案例中,此訊息最常見的原因包括:
- 遠端桌面授權服務未執行。
- 未正確設定授權屬性。
- RD 工作階段主機伺服器無法連線到 RD 授權伺服器。
- RD 工作階段主機伺服器、RD 授權伺服器和使用者不在單一網域中,且網域之間的信任未針對 RDS 正確設定。
解決方法
開始進行疑難解答之前,請先檢查下列幾點:
- 請確定您使用的用戶端存取授權版本與 RD 工作階段主機版本和 RD 授權伺服器版本相容。 如需詳細資訊,請參閱 使用用戶端存取授權來授權 RDS 部署(CAL):RDS CAL 版本相容性。
- 如果您有使用 RD 連線代理人伺服器的 RDS 伺服器陣列,請嘗試使用 RD Web 連線應用程式來重新產生問題,以連線到 RD 工作階段主機伺服器。
- 如果您有不使用 RD 連線代理人伺服器的 RDS 伺服器陣列,請嘗試使用 Microsoft 終端機服務用戶端 (MSTSC) 來重現問題,以連線到 RD 工作階段主機伺服器。
下列各節提供如何檢查和補救常見授權問題的相關信息。
檢查 RD 授權服務
如果遠端桌面授權服務未執行,RD 授權伺服器就無法擷取客戶端授權。
您可以使用 Services MMC 嵌入式管理單元 (Services.msc,也可以在 [工具] 功能表上 伺服器管理員 取得,以在本機或遠端管理服務。 您也可以在本機或遠端使用 PowerShell 來管理服務 (如果遠端電腦設定為可接受遠端的 PowerShell Cmdlet)。
檢查遠端桌面授權服務的狀態。 如果服務未執行,請加以啟動。
檢查 RD 授權角色
使用 伺服器管理員 檢查伺服器角色是否已正確指派。
在 伺服器管理員 中,選取 [遠端桌面服務],找出 [概觀] 窗格,然後檢查 [部署伺服器] 清單。 請確定所有伺服器角色都與正確的伺服器相關聯。
檢查 RD 授權設定
您可以使用下列任一方法來檢查 RD 授權設定,視您管理伺服器的方式而定。
- 使用 伺服器管理員 中的遠端桌面服務控制台。
- 使用網域或本地組原則。
重要
您使用組策略覆寫您在 伺服器管理員 中使用遠端桌面服務控制台所設定的任何設定。
您也可以使用 註冊表編輯器 來檢查授權設定。
- 在 RD 連線代理人伺服器或 RD 作業階段主機伺服器上,開啟 伺服器管理員。
- 選取 [遠端桌面服務>概觀],找出 [部署概觀] 區段,然後選取 [工作>編輯部署內容]。
- 選取 [ RD 授權],然後檢查授權模式和授權伺服器清單。
- 如有必要,請修正組態,然後選取 [ 確定]。
- 根據您要從網域集中設定組策略,還是在每個會話主機上本機設定組策略,請執行下列其中一項:
- 如果您要在網域層級管理組策略,請開啟組策略管理控制台 (GPMC),以滑鼠右鍵按兩下以 RD 工作階段主機為目標的組策略物件 (GPO),然後選取 [ 編輯]。 此作業會開啟組策略編輯器。
- 如果您要在伺服器層級管理組策略,請在 RD 工作階段主機上開啟本地組原則編輯器。
- 選取 [計算機設定>系統管理範本>][Windows 元件>遠端桌面服務>遠端桌面會話主機>授權]。
- 檢查授權模式和授權伺服器清單。
- 如有必要,請修正組態。
如需授權設定的詳細資訊,請參閱 授權遠端桌面會話主機。
您可以使用註冊表編輯器來檢查授權設定。 開啟 RD 工作階段主機上的註冊表編輯器(或連線到登錄)。 保留此資訊的子機碼會根據您管理伺服器的方式而有所不同。
如果您使用群組策略來管理 RDS,請檢查下列子機碼和專案:
HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows NT\Terminal Services
LicenseServers
(字串值)LicensingMode
(DWORD 值)
如果您在 伺服器管理員 中使用遠端桌面服務控制台,請檢查下列子機碼和專案:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Terminal Server\RCM\Licensing Core
LicensingMode
(DWORD 值)
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\TermService\Parameters\LicenseServers\SpecifiedLicenseServers
SpecifiedLicenseServers
(多字串值)
注意
只有當您使用遠端桌面服務控制台來設定授權時,才會存在這個專案。
如需 的詳細資訊 LicensingMode
,請參閱 LicensingMode。
檢查遠端桌面服務伺服器之間的封鎖埠
確定 RD 工作階段主機與 RD 授權伺服器之間的防火牆上已開啟必要的埠。
如需必須在不同 RDS 元件之間開啟的埠清單,請參閱下列文章:
- RDS 2012:部署期間會使用哪些埠?
- Windows 的服務概觀和網路埠需求。
檢查工作組或網域設定
如果您跨多個網域部署 RDS,請檢閱如何跨網域、樹系或工作組設定 RD 授權的最佳做法和支援性。 如需詳細資訊,請參閱 跨 Active Directory 網域/樹系或工作組設定 RDS 授權的最佳做法。
連絡 Microsoft 支援服務
如果上述步驟無法解決問題,請連絡 Microsoft 支援服務 以取得更多協助。 在連絡 Microsoft 支援服務 之前,請先使用 TSS 收集相關信息,以取得使用者體驗相關問題。