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「要求CRM系統管理員許可權以使用 API 存取 Salesforce」錯誤

本文可協助您在連線並登入 Salesforce CRM Microsoft Copilot for Sales 之後顯示錯誤訊息時,針對問題進行疑難解答和解決。

注意

Microsoft Sales Copilot 在 2024 年 1 月重新命名為 sales Microsoft Copilot。 本文中的螢幕快照即將以新名稱更新。

誰會受到影響?

需求類型 Description
用戶端應用程式 Copilot for Sales Outlook 載入巨集
平台 網頁和桌面用戶端
OS Windows 和 Mac
部署 使用者管理的與管理員管理的
CRM Salesforce
使用者 嘗試搭配 Salesforce CRM 使用 Copilot for Sales 的使用者

徵兆

透過適用於 Outlook 的 Copilot for Sales 載入巨集登入 Salesforce CRM 之後,會顯示下列錯誤訊息:

使用 API 要求 CRM 系統管理員許可權以存取 Salesforce

顯示 API 許可權錯誤的螢幕快照。

原因

當您在 Salesforce 中沒有 API 許可權時,就會發生此問題。 如果您在記錄檔中看到下列錯誤,則可以確認這是否為問題的根本原因:

Exception thrown in VivaSalesContacts/GetContactsByEmailAddress - 
Microsoft.SalesProductivity.Common.Base.SPServiceException: Salesforce failed to complete task: Message: entity is deleted clientRequestId: {CLIENT REQUEST ID HERE}-self ---> 
System.Exception: { 
    "error": { 
        "code": 502, 
        "source": "{APIM SOURCE}", 
        "message": "BadGateway", 
        "innerError": { 
            "status": 502, 
            "message": "Salesforce failed to complete task: Message: **API is disabled for this User**\r\nclientRequestId: {CLIENT REQUEST ID HERE}", 
            "error": null, 
            "source": "Salesforce.Common", 
            "errors": [] 
        } 
    } 
} 

解決方法

系統管理員可以遵循下列步驟,將已啟用 API 的許可權授與使用者或受影響的使用者配置檔:

  1. 以系統管理員的身分登入 Salesforce。

  2. 在搜尋方塊中輸入使用者

  3. 在左側瀏覽窗格中,選取 [配置檔],然後選取受影響的使用者配置檔。

  4. 管理權限區段中,選取 API 已啟用

  5. 選取儲存

    顯示 [配置檔] 頁面上 [API 已啟用] 選項的螢幕快照。

其他相關資訊

如果您的問題仍然無法解決,請前往 Copilot for Sales - Microsoft Community Hub 與我們的專家互動。

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