「要求CRM系統管理員許可權以使用 API 存取 Salesforce」錯誤
本文可協助您在連線並登入 Salesforce CRM Microsoft Copilot for Sales 之後顯示錯誤訊息時,針對問題進行疑難解答和解決。
注意
Microsoft Sales Copilot 在 2024 年 1 月重新命名為 sales Microsoft Copilot。 本文中的螢幕快照即將以新名稱更新。
誰會受到影響?
需求類型 | Description |
---|---|
用戶端應用程式 | Copilot for Sales Outlook 載入巨集 |
平台 | 網頁和桌面用戶端 |
OS | Windows 和 Mac |
部署 | 使用者管理的與管理員管理的 |
CRM | Salesforce |
使用者 | 嘗試搭配 Salesforce CRM 使用 Copilot for Sales 的使用者 |
徵兆
透過適用於 Outlook 的 Copilot for Sales 載入巨集登入 Salesforce CRM 之後,會顯示下列錯誤訊息:
使用 API 要求 CRM 系統管理員許可權以存取 Salesforce
原因
當您在 Salesforce 中沒有 API 許可權時,就會發生此問題。 如果您在記錄檔中看到下列錯誤,則可以確認這是否為問題的根本原因:
Exception thrown in VivaSalesContacts/GetContactsByEmailAddress -
Microsoft.SalesProductivity.Common.Base.SPServiceException: Salesforce failed to complete task: Message: entity is deleted clientRequestId: {CLIENT REQUEST ID HERE}-self --->
System.Exception: {
"error": {
"code": 502,
"source": "{APIM SOURCE}",
"message": "BadGateway",
"innerError": {
"status": 502,
"message": "Salesforce failed to complete task: Message: **API is disabled for this User**\r\nclientRequestId: {CLIENT REQUEST ID HERE}",
"error": null,
"source": "Salesforce.Common",
"errors": []
}
}
}
解決方法
系統管理員可以遵循下列步驟,將已啟用 API 的許可權授與使用者或受影響的使用者配置檔:
其他相關資訊
如果您的問題仍然無法解決,請前往 Copilot for Sales - Microsoft Community Hub 與我們的專家互動。
協力廠商資訊免責聲明
本文提及的協力廠商產品是由與 Microsoft 無關的獨立廠商所製造。 Microsoft 不以默示或其他方式,提供與這些產品的效能或可靠性有關的擔保。