“请求 CRM 管理员权限以使用 API 访问 Salesforce”错误
本文可帮助你排查和解决在 Microsoft Copilot for Sales 中连接到 Salesforce CRM 并登录到 Salesforce CRM 后显示错误消息时出现的问题。
注意
Microsoft Sales Copilot 在 2024 年 1 月被改名为 Microsoft Copilot for Sales。 本文中的屏幕截图将很快更新为新名称。
谁受影响?
要求类型 | Description |
---|---|
客户端应用 | Copilot for Sales Outlook 加载项 |
平台 | Web 和桌面客户端 |
操作系统 | Windows 和 Mac |
部署 | 用户管理和管理员管理 |
CRM | Salesforce |
用户 | 尝试将 Copilot for Sales 与 Salesforce CRM 配合使用的用户 |
现象
通过 适用于 Outlook 的 Copilot for Sales 外接程序登录到 Salesforce CRM 后,将显示以下错误消息:
请求 CRM 管理员权限以使用 API 访问 Salesforce
原因
在 Salesforce 中没有 API 权限时,会出现此问题。 如果您在日志中看到以下错误,您可以确认这是否是问题的根本原因:
Exception thrown in VivaSalesContacts/GetContactsByEmailAddress -
Microsoft.SalesProductivity.Common.Base.SPServiceException: Salesforce failed to complete task: Message: entity is deleted clientRequestId: {CLIENT REQUEST ID HERE}-self --->
System.Exception: {
"error": {
"code": 502,
"source": "{APIM SOURCE}",
"message": "BadGateway",
"innerError": {
"status": 502,
"message": "Salesforce failed to complete task: Message: **API is disabled for this User**\r\nclientRequestId: {CLIENT REQUEST ID HERE}",
"error": null,
"source": "Salesforce.Common",
"errors": []
}
}
}
解决方法
管理员可按照以下步骤授予 对用户或受影响用户配置文件的 API 启用 权限:
详细信息
如果你的问题仍未解决,请转到 Copilot for Sales - Microsoft社区中心 与我们的专家联系。
第三方信息免责声明
本文中提到的第三方产品由 Microsoft 以外的其他公司提供。 Microsoft 不对这些产品的性能或可靠性提供任何明示或暗示性担保。