由于 Salesforce CRM 中缺少对象访问,无法更新记录

本文可帮助排查和解决用户因 Salesforce CRM 中缺少对象访问而无法在 Microsoft Copilot for Sales 中更新 CRM 记录的问题。

谁受影响?

要求类型 Description
客户端应用 Copilot for Sales Outlook 加载项
平台 Web 和桌面客户端
操作系统 Windows 和 Mac
部署 用户管理和管理员管理
CRM Salesforce
用户 尝试从 Copilot for Sales 更新 CRM 记录的用户

现象

当用户尝试从适用于 OutlookCopilot for Sales 外接程序更新 CRM 记录时,将显示以下错误消息:

若要更新 Salesforce,请请求对此对象进行编辑访问。

有关由于 Salesforce CRM 中缺少对象访问权限无法更新记录的错误。

原因

用户对 Salesforce 中的对象没有编辑访问权限。

当用户尝试编辑对象时,Copilot for Sales 会检查用户是否对 Salesforce 中的对象具有 写入 访问权限。 如果用户没有对象的写入访问权限,会显示错误消息。

如果在日志中看到以下错误,则可以确认用户是否对实体没有 写入 访问权限是问题的根本原因:

Exception thrown in VivaSalesContacts/UpdateContact -  
Microsoft.SalesProductivity.Common.Base.SPServiceException: Salesforce failed to complete task: Message: entity is deleted clientRequestId:<CLIENT REQUEST ID>-self --->  
System.Exception: {  
    "status": 400,  
    "message": "Object type contact is not supported. If you are attempting to use a custom object, be sure to append the '__c' after the entity name.  
                Please reference your WSDL or the describe call for the appropriate names\r\nclientRequestId: <CLIENT REQUEST ID>-self",  
    "error": null,  
    "source": "Salesforce.Common",  
    "errors": []  
} 

在上述错误消息中, Object type contact is not supported 指示用户对对象没有 写入 访问权限 Contact

解决方法

要解决此问题,请确保用户具有:

  • 读取或写入用户尝试在 Salesforce 中编辑的对象的权限。
  • 对配置为编辑的所有字段的读取或写入权限。

有关 Salesforce 中对象级安全性、字段级安全性和记录级安全性的信息,请参阅控制查看者。 您也可以联系 Salesforce 管理员,获得有关如何在配置文件中设置对象权限的帮助。

详细信息

如果你的问题仍未解决,请转到 Copilot for Sales - Microsoft社区中心 与我们的专家联系。

第三方信息免责声明

本文中提到的第三方产品由 Microsoft 以外的其他公司提供。 Microsoft 对这些产品的性能和可靠性不作任何明示或默示担保。

第三方联系人免责声明

Microsoft 会提供第三方联系信息来帮助你查找有关本主题的其他信息。 此联系信息可能会更改,恕不另行通知。 Microsoft 不保证第三方联系信息的准确性。