由于 Salesforce CRM 中缺少对象访问,无法更新记录
本文可帮助你排查和解决由于 Salesforce CRM 中缺少对象访问而无法更新 Microsoft Copilot for Sales 中的 CRM 记录的问题。
注意
Microsoft Sales Copilot 于 2024 年 1 月更名为 Microsoft Copilot for Sales。 本文中的屏幕截图将很快更新为新名称。
谁受到影响?
要求类型 | 说明 |
---|---|
客户端应用 | Copilot for Sales Outlook 加载项 |
平台 | Web 和桌面客户端 |
操作系统 | Windows 和 Mac |
部署 | 用户托管和管理员托管 |
CRM | Salesforce |
用户 | 尝试从 Copilot for Sales 更新 CRM 记录的用户 |
症状
当用户尝试从 适用于 Outlook 的 Copilot for Sales 外接程序更新 CRM 记录时,将显示以下错误消息:
若要更新 Salesforce,请请求对此对象的编辑访问权限。
原因
用户对 Salesforce 中的对象没有编辑访问权限。
当用户尝试编辑对象时,Copilot for Sales 会检查用户是否对 Salesforce 中的对象具有 写入 访问权限。 如果用户对对象没有 写入 权限,则会显示错误消息。
如果日志中出现以下错误,可以确认用户对实体没有 写入 访问权限是否是问题的根本原因:
Exception thrown in VivaSalesContacts/UpdateContact -
Microsoft.SalesProductivity.Common.Base.SPServiceException: Salesforce failed to complete task: Message: entity is deleted clientRequestId:<CLIENT REQUEST ID>-self --->
System.Exception: {
"status": 400,
"message": "Object type contact is not supported. If you are attempting to use a custom object, be sure to append the '__c' after the entity name.
Please reference your WSDL or the describe call for the appropriate names\r\nclientRequestId: <CLIENT REQUEST ID>-self",
"error": null,
"source": "Salesforce.Common",
"errors": []
}
在上述错误消息中, Object type contact is not supported
指示用户对 对象没有 写入 权限 Contact
。
解决方案
若要解决此问题,请确保用户具有:
- 用户尝试在 Salesforce 中编辑的对象读取或写入级别权限。
- 对配置为进行编辑的所有字段的读取或写入权限。
有关 Salesforce 中对象级安全性、字段级安全性和记录级安全性的信息,请参阅 控制谁看到内容。 还可以联系 Salesforce 管理员,获取有关 在配置文件中设置对象权限的帮助。
更多信息
如果问题仍未解决,请转到 Copilot for Sales - Microsoft 社区中心 与我们的专家联系。
第三方信息免责声明
本文中提到的第三方产品由 Microsoft 以外的其他公司提供。 Microsoft 不对这些产品的性能或可靠性提供任何明示或暗示性担保。
第三方联系人免责声明
Microsoft 提供第三方联系信息,帮助你查找有关本主题的其他信息。 该联系信息如有更改,恕不另行通知。 Microsoft 不保证第三方联系信息的准确性。