排查Power Automate 桌面版中的安装问题
本文提供了解决安装Power Automate 桌面版时可能出现的问题的故障排除步骤。
适用于: Power Automate
原始 KB 数: 5001534
常规步骤
若要确保安装成功,请确保:
使用最新的安装程序进行Power Automate 桌面版。
备注
需要本地计算机上的管理员权限才能使用 MSI 安装程序安装Power Automate 桌面版。
重启计算机。
某些 Windows 更改需要重启才能生效,或者可能会阻止安装。
运行受支持的 Windows 操作系统的最新版本。
有关先决条件的完整列表,请参阅 先决条件和限制。
收集诊断信息
安装日志可以提供有关安装和修复问题的有用详细信息。 有关在何处查找日志的详细信息,请参阅Power Automate 桌面版安装日志。
已知问题和解决方法
Power Automate 服务无法启动:无法加载 DLL“uiflowsclient.dll”
如果 Power Automate Windows 服务无法启动,则安装失败,并出现此错误。 Windows 事件查看器显示无法启动的原因为“System.DllNotFound 异常:无法加载 DLL'uiflowsclient.dll'”。
解决方法
若要解决此问题,请卸载“Microsoft Visual C++ 2015-2022 Redistributable”,然后按照以下步骤重新安装Power Automate 桌面版:
转到“设置>应用已安装”应用>。
找到“Microsoft Visual C++ 2015-2022 Redistributable”并将其卸载。
重新安装Power Automate 桌面版。 Power Automate 桌面版安装程序在安装过程中重新安装C++可再发行组件。
Power Automate 服务在启动时崩溃:无法枚举会话
如果 Power Automate 服务在启动时崩溃,则安装失败,并出现此错误。 Windows 事件查看器显示“FailedToEnumerateSessions”错误。
UIFlowService
服务启动期间捕获的异常:
Microsoft.Flow.RPA.Service.Core.UIFlowServiceException:错误代码:FailedToEnumerateSessions
原因
安装程序授予 Power Automate 服务的权限,以枚举计算机上的用户会话。 可能需要重新创建计算机才能使这些权限生效。
解决方法
若要解决此问题,可以通过从命令行运行安装程序并传递 /SKIPSTARTINGPOWERAUTOMATESERVICE
参数来防止 Power Automate 服务在安装过程中自动启动。
然后,在安装后立即手动重启计算机。 如果重启成功,Power Automate Windows 服务将在重启后成功运行,并且不应再崩溃或在事件日志中生成“FailedToEnumerateSessions”错误。
Power Automate 服务无法启动:服务帐户错误
安装失败,因为 Power Automate 服务在启动时崩溃,Windows 事件查看器显示以下错误:
UIFlowService
服务启动期间捕获的异常:
Microsoft.Flow.RPA.Common.DataRepository.KeyValueStoreException: ReliableKeyValueStore 'UIFlowServiceSecretStore' 支持存储不正常。
Windows 无法登录,因为无法加载配置文件。 检查是否已连接到网络,并且网络是否正常运行。
原因
你的计算机可能存在问题,该问题不允许在安装期间创建 Power Automate 服务的 Windows 帐户。NT Service\UIFlowService
可以通过再次运行安装并检查安装程序尝试启动 Power Automate 服务时帐户是否存在来确认这一点。 可以在注册表中找到帐户的配置文件:
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\ProfileList\S-1-5-80-3017052307-2994996872-1615411526-3164924635-3391446484
如果此注册表项不存在,则表示计算机不允许创建服务用户帐户。
备注
如果未安装Power Automate 桌面版,则不存在注册表项。
解决方法
你可以提供一个 Windows 用户帐户来运行该服务,而不是默认帐户(NT SERVICE\UIFlowService
)。 此帐户需要是远程桌面用户组的成员,并且需要具有“登录即服务”权限。
首先从命令行运行安装程序,并传递 /SKIPSTARTINGPOWERAUTOMATESERVICE
参数以防止 Power Automate 服务在安装过程中自动启动。
安装完成后,运行 Power Automate Machine 运行时应用程序,并使用 “故障排除 ”菜单更改服务帐户。 有关更改服务帐户的详细信息,请参阅 更改本地服务帐户。
Power Automate 服务无法启动:验证是否有足够的权限启动系统服务
Windows 事件查看器中记录了以下事件:
产品:Power Automate 桌面版 -- 错误 1920。 服务“Power Automate 服务”(UIFlowService)无法启动。 验证是否有足够的权限来启动系统服务。
原因
用于启动 Power Automate 服务的帐户无法启动服务,因为 拒绝作为服务 安全策略登录会阻止该服务。
在安装过程中,运行 UIFlowService
方式为 NT SERVICE\UIFlowService
. 以后可以使用的 UIFlowService
帐户进行更改,但出于安装目的,不得阻止其登录。
备注
如果发现服务崩溃日志(类似于以下屏幕截图所示的日志)表示服务具有足够的启动权限,并且服务在启动时崩溃会阻止安装。 若要解决此问题,请参阅本文的其他部分。
“UIFlowService
服务启动期间捕获的异常:”
解决方法
更新“拒绝登录”作为服务策略设置,以删除阻止NT SERVICE\UIFlowService
以服务身份登录的帐户或组。 有关详细信息,请参阅 更改本地服务帐户。
无法启动 LanmanServer 服务
安装日志中会显示以下错误消息:
启动 LanmanServer 服务时引发的异常:System.InvalidOperationException: 无法在计算机上启动服务 LanmanServer
原因
Power Automate 安装程序依赖于 LanmanServer 服务,如果尚未运行,则尝试启动它。 如果无法启动该服务,则依赖于该服务的安装步骤会失败。
解决方法
若要解决此问题,请执行以下操作:
- 选择 Windows 徽标键+R 并在“运行”窗口中键入 services.msc 或服务以打开服务管理器。 找到名为“Server”的服务,右键单击它并选择“ 属性”。
- 在 “常规 ”选项卡中,确保 其启动类型 未禁用(默认为 “自动 ”。)
- 选择“应用”以更新启动类型。
- 然后,可以通过在服务管理器工具中右键单击该服务并选择“启动”来手动启动服务。
- 服务运行后,可以再次尝试安装。