由于 Salesforce 连接器被阻止,无法登录到 Salesforce

本文可帮助你排查和解决 Microsoft Copilot for Sales 中由于 Salesforce 连接器被阻止而无法登录 Salesforce 时发生的错误。

注意

Microsoft Sales Copilot 于 2024 年 1 月更名为 Microsoft Copilot for Sales。 本文中的屏幕截图将很快更新为新名称。

谁受到影响?

要求类型 说明
客户端应用 Copilot for Sales Outlook 加载项
平台 Web 和桌面客户端
操作系统 Windows 和 Mac
部署 用户托管和管理员托管
CRM Salesforce
用户 所有用户

症状

尝试从 Copilot for Sales 登录到 Salesforce 时,将显示以下错误消息,错误代码 ConnectionApiPolicyViolation为 :

发生了错误

显示阻止 Salesforce 连接器时发生的错误的屏幕截图。

原因

Salesforce 连接器在 msdyn_viva环境中被阻止。

数据丢失防护 (DLP) 策略在租户的msdyn_viva环境中启用,从而阻止 Salesforce 连接器。

解决方案

若要解决此问题,必须在 DLP 策略中取消阻止 Salesforce 连接器。

  1. 使用管理员凭据登录到 Power Platform 管理中心
  2. 在左侧导航窗格中,选择“ 策略>”“数据策略”。
  3. 选择阻止 Salesforce 连接器的数据策略,然后选择 “编辑策略”。
  4. 预生成连接器 步骤中,将 Salesforce 连接器移动到 BusinessNon-business
  5. 完成其余步骤,然后选择“ 更新策略”。

有关详细信息,请参阅 管理数据丢失防护 (DLP) 策略

更多信息

如果问题仍未解决,请转到 Copilot for Sales - Microsoft 社区中心 与我们的专家联系。

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