Felsöka vanliga problem i AKS Edge Essentials
I den här artikeln beskrivs hur du hittar lösningar på problem som uppstår när du använder AKS Edge Essentials. Kända problem och fel ordnas efter funktionsområde. Du kan använda länkarna i den här artikeln för att hitta lösningar och lösningar för att lösa dem.
Öppna en supportbegäran
Se artikeln Hämta support för information om hur du använder Azure Portal för att få support eller öppna en supportbegäran för AKS Edge Essentials.
Distributionsproblem
Problem med ej betrodd utgivare
Felmeddelande: "Vill du köra programvara från den här utgivaren som inte är betrodd? ....."
Lösning: Uppdatera din PowerShell-körningsprincip till RemoteSigned:
# Get the execution policy on the system
Get-ExecutionPolicy
# Set the execution policy for this process only
if ((Get-ExecutionPolicy) -ne "RemoteSigned") { Set-ExecutionPolicy -ExecutionPolicy RemoteSigned -Scope Process -Force }
Lågt diskutrymme gör att tidigare cachelagrade containeravbildningar tas bort
När noden får slut på diskutrymme är vissa av de förinstallerade avbildningarna skräp som samlas in av körningen containerd
. I det här fallet frigör du först lite diskutrymme och kör sedan följande kommando för att hämta de cachelagrade avbildningarna igen:
Invoke-AksEdgeNodeCommand -NodeType Linux -command "sudo /path/to/script/reimport-ci.sh
Det här skriptet söker efter saknade avbildningar och importerar dem igen efter behov.
Azure Arc-anslutning
Problem:
Disconnect-AksEdgeArc
tar inte bort poddarna från klustret.Lösning: Om poddarna inte rensas kör du följande kommandon för att manuellt rensa befintliga Azure Arc-relaterade resurser innan du försöker återansluta igen:
kubectl delete ns azure-arc kubectl delete clusterrolebinding azure-arc-operator kubectl delete secret sh.helm.release.v1.azure-arc.v1
Problem: Azure Arc-anslutningen fungerar inte i en proxymiljö.
Lösning: Du kan aktivera systemomfattande proxyinställningar genom att följa InternetalternativEns >> LAN-inställningar för anslutningar.
Det går inte att ta bort AKS Arc-kluster helt med PodDisruptionBudget-resurser (PDB)
Information om det här kända problemet finns i Det går inte att ta bort AKS Arc-kluster helt med PDB-resurser i AKS Arc-dokumentationen.
Offlinedistributioner
Det gick inte att hämta nodeagent-certifikatet: Hittades inte
Kontrollera nätverkskortkonfigurationen. Under distributionen behöver AKS Edge Essentials ett nätverkskort som är aktiverat och har rätt IP-adress, undernät och standardgateway. Dessa värden fylls automatiskt i i en DHCP-miljö. Om du ställer in manuellt kontrollerar du att alla tre är inställda. I många fall har standardgatewayen inte angetts, vilket resulterar i det här felet.
Kubernetes
Kube-vip-podden startas om kontinuerligt
I vissa scenarier loopar och startar kube-vip-podden kontinuerligt.
Validering
Kontrollera att det scenario som du stöter på är samma problem som beskrivs i den här artikeln genom att kontrollera att kube-vip-podden i kube-system-namnområdet har ett stort antal omstarter genom att köra följande kommando:
kubectl get pods –n kube-system
Orsak
Det finns några olika orsaker till varför kube-vip-podden kan startas om hela tiden. Dessa orsaker är:
- Använda en OS-disk som inte backas upp med en SSD-disk eller en Premium SSD-disk när du använder en virtuell Azure-dator. Du kan granska maskinvarukraven här.
- Diskfördröjningen är för hög. Om diskfördröjningen är större än 10 ms kan det resultera i tidsgränser för begäranden, förlust av ledare och potentiell instabilitet i klustret. Du kan granska maskinvarukraven för etcd här.
Åtgärd
Du kan åtgärda problemet genom att granska din underliggande lagringsinfrastruktur för att säkerställa att den uppfyller prestandakraven för etcd och AKS Edge Essentials. Överväg också att använda premium SSD-säkerhetskopierad lagring eller optimera lagringskonfigurationen för prestanda.