Мобильное приложение "Служба полей" не запускается из-за отсутствующих файлов
В этой статье приводится решение проблемы, из-за которой мобильное приложение Dynamics 365 Field Service не запускается.
Симптомы
При запуске использования нового пользовательского интерфейса в мобильном приложении Dynamics 365 Field Service вы получите сообщение об ошибке о том, что некоторые файлы отсутствуют.
Причина
Отсутствуют некоторые необходимые исходные записи. Эти записи следует создавать при установке приложения службы полей, но в редких случаях они не создаются успешно или повреждены. Также возможно, что пользователь удалил записи.
Решение
Шаг 1. Проверка того, содержит ли таблица MobileSource данные
Перейдите в Power Apps и откройте среду, которую вы хотите проверить.
Выберите таблицы, выберите фильтр "Все" и найдите таблицу
MobileSource
(msdyn_mobilesource
).Выберите таблицу и убедитесь, что она содержит следующие данные в столбце Name :
- /card/bookingListViewItem.yml
- /card/defaultViewItem.yml
- /card/serviceTaskGridItem.yml
- /sitemaps/mobile.yml
Если в таблице нет данных, что-то пошло не так с обновлением решения.
Шаг 2. Повторное обновление решения службы полей
В Power Apps откройте среду и перейдите в раздел "Решения".
fieldservice_anchor
Найдите и удалитеFieldService_Anchor
решение.Перейдите в Центр администрирования Power Platform и выберите среду, в которой вы удалили решение.
В разделе "Ресурсы" в разделе "Ресурсы" выберите приложения Dynamics 365.
Выберите "Установить приложение>Dynamics 365" для службы>полей далее.
Примите условия обслуживания и нажмите кнопку "Установить".
После установки решения убедитесь, что таблица содержит необходимые данные с помощью шага 1.