Отображение ошибки "синий экран" при загрузке виртуальной машины Azure под управлением Windows
Область применения: ✔️ Виртуальные машины Windows
В этой статье описываются ошибки синего экрана, которые могут возникнуть при загрузке виртуальной машины Windows в Microsoft Azure. Представляем шаги, которые помогут вам при сборе данных для запроса в службу поддержки.
Симптомы
Виртуальная машина Windows не запускается. При проверке снимка экрана загрузки в диагностика загрузки вы увидите одно из следующих сообщений об ошибках на синем экране:
"На вашем ПК возникла проблема, и его необходимо перезагрузить". Мы лишь собираем некоторые сведения об ошибке, а затем вы сможете выполнить перезагрузку".
"На вашем ПК возникла проблема, и его необходимо перезагрузить".
Причина
Существует множество причин, по которым возникает ошибка остановки. Наиболее распространенными причинами являются следующие проблемы:
- Проблема в драйвере
- Поврежденный системный файл или память.
- Приложение, обращающееся к запрещенном сектору памяти
Решение
Совет
Если у вас есть последняя резервная копия виртуальной машины, попробуйте восстановить виртуальную машину из резервной копии , чтобы устранить проблему загрузки.
Чтобы устранить эту проблему, сначала необходимо собрать файл дампа для сбоя перед обращением в службу поддержки. Чтобы собрать файл дампа, выполните следующие действия.
Шаг 1. Поиск файла дампа и отправка запроса в службу поддержки
Часть 1. Подключение диска ОС к виртуальной машине восстановления
Создайте моментальный снимок диска ОС затронутой виртуальной машины, чтобы создать резервную копию. Дополнительные сведения см. в статье "Создание моментального снимка виртуального жесткого диска".
Используйте протокол удаленного рабочего стола (RDP) для удаленного подключения к виртуальной машине восстановления.
Если диск ОС затронутой виртуальной машины зашифрован, отключите шифрование перед переходом к следующему шагу. Дополнительные сведения см. в разделе "Расшифровка зашифрованного диска ОС".
Часть 2. Поиск файла дампа и отправка запроса в службу поддержки
На виртуальной машине восстановления перейдите в папку Windows на подключенном диске ОС. Например, если буква диска, назначенная подключенному диску ОС, — F, перейдите к F:\Windows.
Найдите файл Memory.dmp, а затем отправьте запрос в службу поддержки и вложите файл дампа.
Если файл дампа не удается найти, перейдите к следующим шагам, чтобы включить журнал дампа и последовательную консоль, а затем воспроизвести проблему.
Шаг 2. Включение журнала дампа и последовательной консоли
Важно!
В этот раздел, описание метода или задачи включены действия, содержащие указания по изменению параметров реестра. Однако неправильное изменение параметров реестра может привести к возникновению серьезных проблем. Поэтому убедитесь, что вы внимательно выполните следующие действия. Для защиты создайте резервную копию реестра перед его изменением, чтобы в случае возникновения проблем можно было восстановить его. Для получения дополнительной информации о том, как создать резервную копию и восстановить реестр, см. статью Сведения о резервном копировании и восстановлении реестра Windows.
Чтобы включить журнал дампа и последовательную консоль, выполните следующие действия.
Откройте сеанс командной строки с повышенными привилегиями от имени администратора.
Выполните следующие команды BCDEdit с помощью параметров /ems и /emssettings :
Включите последовательную консоль:
bcdedit /store <volume-letter-containing-the-bcd-folder>:\boot\bcd /ems {<boot-loader-identifier>} ON bcdedit /store <volume-letter-containing-the-bcd-folder>:\boot\bcd /emssettings EMSPORT:1 EMSBAUDRATE:115200
Убедитесь, что размер свободного места на диске ОС превышает объем памяти (ОЗУ) этой виртуальной машины.
Если на диске ОС недостаточно места, измените расположение, в котором создается файл дампа памяти, и обратитесь к нему на любой диск данных, подключенный к виртуальной машине с достаточным объемом свободного места. Чтобы изменить расположение, замените
%SystemRoot%
букву диска данных, напримерF:
в следующих командах.Чтобы включить файл дампа ОС, выполните следующие команды загрузки, добавьте и выгрузите команды для реализации предлагаемой конфигурации с помощью средства reg :
Загрузите hive реестра с сломанного диска ОС:
reg load HKLM\<broken-system> <volume-letter-of-broken-os-disk>:\windows\system32\config\SYSTEM
Включите сбор для ControlSet001.
reg add "HKLM\<broken-system>\ControlSet001\Control\CrashControl" /v CrashDumpEnabled /t REG_DWORD /d 1 /f reg add "HKLM\<broken-system>\ControlSet001\Control\CrashControl" /v DumpFile /t REG_EXPAND_SZ /d "%SystemRoot%\MEMORY.DMP" /f reg add "HKLM\<broken-system>\ControlSet001\Control\CrashControl" /v NMICrashDump /t REG_DWORD /d 1 /f
Включите сбор для ControlSet002.
reg add "HKLM\<broken-system>\ControlSet002\Control\CrashControl" /v CrashDumpEnabled /t REG_DWORD /d 1 /f reg add "HKLM\<broken-system>\ControlSet002\Control\CrashControl" /v DumpFile /t REG_EXPAND_SZ /d "%SystemRoot%\MEMORY.DMP" /f reg add "HKLM\<broken-system>\ControlSet002\Control\CrashControl" /v NMICrashDump /t REG_DWORD /d 1 /f
Выгрузите сломанный диск ОС:
reg unload HKLM\<broken-system>
Шаг 3. Воспроизведение проблемы
Отсоедините диск ОС, а затем повторно закачивание диска ОС на затронутую виртуальную машину.
Запустите виртуальную машину для воспроизведения проблемы, чтобы создать файл дампа.
Повторите инструкции на шаге 1. Найдите файл дампа и отправьте раздел запроса в службу поддержки.
Свяжитесь с нами для получения помощи
Если у вас есть вопросы или вам нужна помощь, создайте запрос в службу поддержки или обратитесь за поддержкой сообщества Azure. Вы также можете отправить отзыв о продукте в сообщество отзывов Azure.