Поделиться через


Код ошибки 0x80090016: Keyset не существует в средстве просмотра событий или журналах агента

Примечание.

Агент Log Analytics, также известный как Microsoft Monitoring Agent (MMA), будет прекращен в августе 2024 года. В результате будут обновлены планы Defender для серверов и Defender для SQL на компьютерах в Microsoft Defender для облака, а функции, использующие агент Log Analytics, будут изменены. Дополнительные сведения см. в разделе "Подготовка к выходу" агента Log Analytics.

В этой статье объясняется, как устранить код ошибки 0x80090016 — "Набор ключей не существует" при попытке подключиться к средству просмотра событий или журналам агента.

Симптомы

При попытке подключиться к рабочей области Log Analytics с помощью Microsoft Monitoring Agent (MMA), подключение завершается ошибкой, и одна из следующих записей ошибок регистрируется в журнале просмотра событий Operations Manager:

Event ID:      7022 
Description:   The Health Service has downloaded secure configuration for management
               group AOI-00000000-0000-0000-0000-000000000000, and processing the 
               configuration failed with error code Keyset does not exist(0x80090016). 
Event ID:      3009  
Description:   Loading the private key for the client authentication certificate for
               service "Log Analytics - ed4Customer-WorkspaceID" failed with error 
               "Keyset does not exist" (0x80090016). Connections to the service may
               be made without authentication. This can cause failures if the service
               requires the agent to be authenticated. The agent will continue to 
               periodically retry loading the authentication configuration.

Причина

Сервер был клонирован из золотого образа (также известного как главный образ), который уже установлен и настроен агентОм Windows Log Analytics. Подключение завершается ошибкой, так как сертификаты включают имя исходного сервера, клонированного вместо имени, используемого в настоящее время Windows. (Примечание. Клонирование компьютера с уже настроенным агентом Log Analytics не поддерживается.)

Решение

Чтобы устранить эти ошибки, очистите и обновите сертификаты MMA следующим образом:

  1. Чтобы открыть оснастку "Службы", нажмите кнопку "Пуск", введите services.msc и нажмите клавишу ВВОД.

  2. Чтобы остановить службу, выберите Microsoft Monitoring Agent и щелкните значок "Остановить службу ".

  3. Чтобы открыть консоль управления Майкрософт (MMC), нажмите кнопку "Пуск", введите mmc.exe и нажмите клавишу ВВОД.

  4. Чтобы добавить оснастку "Сертификаты", нажмите кнопку >"Добавить или удалить сертификаты оснастки>>", чтобы>добавить учетную запись>компьютера next>Local computer>Finish>OK.

  5. Чтобы просмотреть существующие сертификаты MMA в MMC, перейдите к сертификатам Microsoft Monitoring Agent>Certificates>.

  6. Мы рекомендуем экспортировать каждый сертификат таким образом, чтобы у вас была резервная копия для обеспечения безопасности и аудита. Для этого выполните следующие шаги.

    1. Выберите и щелкните правой кнопкой мыши каждый указанный сертификат по отдельности, а затем выберите пункт "Все задачи>экспорта далее>нет", не экспортируйте>закрытый ключ.

    2. На странице форматирования файла экспорта выберите в кодировке Base-64 X.509 (). CER)>Далее.

    3. На странице "Файл для экспорта" в поле имени файла введите имя файла сертификата, а затем перейдите к расположению, в котором нужно экспортировать сертификат. Затем нажмите кнопку "Сохранить>далее".>

  7. После экспорта резервных копий сертификатов, перечисленных в средней области, как описано на шаге 6, удалите сертификаты из MMC. Оставьте консоль открытой.

  8. В оснастке "Службы" выберите Microsoft Monitoring Agent и щелкните значок "Пуск службы ", чтобы перезапустить его.

  9. Подождите одну минуту. Затем в MMC выберите оснастку "Сертификаты" и щелкните значок "Обновить " или "F5" для обновления. Вы должны увидеть новые сертификаты.

Просмотрите агент, журналы событий и рабочую область Log Analytics, чтобы определить, устранена ли эта проблема.

Дополнительная информация

Настройка Агента мониторинга Майкрософт

Общие сведения об агенте Log Analytics: параметры установки

Свяжитесь с нами для получения помощи

Если у вас есть вопросы или вам нужна помощь, создайте запрос в службу поддержки или обратитесь за поддержкой сообщества Azure. Вы также можете отправить отзыв о продукте в сообщество отзывов Azure.