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Erro de credenciais inválidas ao executar fluxos da área de trabalho no Power Automate para área de trabalho

Este artigo fornece uma solução para o erro de credenciais inválidas que ocorre quando você executa um fluxo da área de trabalho de um fluxo da nuvem no Microsoft Power Automate para área de trabalho.

Aplica-se a: Power Automate
Número original do KB: 5021155

Sintomas

  • Ao criar uma conexão de fluxo da área de trabalho, você recebe a seguinte mensagem de erro:

    Detalhes: Falha na conexão: [ID da máquina<].> Há um problema com suas credenciais. Verifique suas credenciais ou use credenciais diferentes para se conectar à máquina. ID de correlação: <ID de> correlação.

    Captura de tela do erro de credenciais inválidas que você pode receber ao criar uma conexão de fluxos da área de trabalho.

  • Ao executar um fluxo da área de trabalho, você recebe o código de WindowsIdentityIncorrect erro. A mensagem associada a esse código de erro pode ser "As credenciais fornecidas com a solicitação são inválidas" ou algo mais específico.

    {
        "error":{
            "code": "WindowsIdentityIncorrect",
            "message": "The credentials provided with the request are invalid."
        }    
    }
    

Observação

Em caso de erro de conexão, o melhor teste é conectar-se à mesma máquina com a Área de Trabalho Remota e usar as mesmas credenciais que você usou ao criar o fluxo da área de trabalho.

Causa

As mensagens de erro ocorrem porque as credenciais na conexão não podem ser autenticadas no computador de destino.

Quando você cria uma conexão, o Power Automate verifica se as credenciais são válidas. Se as credenciais não forem autenticadas no computador de destino, a conexão não poderá ser feita e você receberá um erro descrevendo o problema.

Se você criou sua conexão com êxito anteriormente, mas agora encontra um erro ao executar o fluxo, isso indica que algo foi alterado em sua conta de usuário ou computador (por exemplo, sua senha pode ter expirado).

Solução

Para ver uma mensagem de erro com detalhes específicos sobre o que deu errado, verifique se você tem o Power Automate versão 2.24 ou superior instalado. Muitas vezes, esse método fornece informações suficientes para resolver o problema. A tabela a seguir mostra alguns códigos de erro específicos e as resoluções.

Código de erro Mensagem de erro Causa Solução
-1073741477 Um usuário solicitou um tipo de logon (por exemplo, interativo ou de rede) que não foi concedido. Um administrador tem controle sobre quem pode fazer logon interativamente e por meio da rede. A conta de usuário não tem direitos de logon no computador ou o administrador alterou as políticas do computador (verifique as configurações de Atribuição de Direitos de Usuário ). Para resolver esse problema, consulte o erro "O tipo de logon não foi concedido" ao executar um fluxo da área de trabalho ou criar uma conexão.
-1073445812 O UPN do usuário não está no formato esperado O usuário entrou usando DOMAIN\user , mas deve usar o user@domain.com formato (ou vice-versa). Tente entrar usando os user@domain.com formatos e DOMAIN\user .
-1073741062 O logon do cartão inteligente é necessário e não foi usado Não há suporte para conexões com computadores que exigem logons de cartão inteligente. Use uma máquina sem esse requisito.
-1073741715 Nome de usuário incorreto ou informações de autenticação O "nome da conta em execução" ou o formato do seu nome de usuário está incorreto. Execute o comando dsregcmd /status no contexto da conta de conexão de fluxo da área de trabalho. Verifique a Executing Account Name seção na saída e verifique se ela corresponde ao nome de usuário que foi usado. Os dispositivos ingressados ou híbridos do Microsoft Entra sempre preferem o formato UPN user@domain.com . Se o seu computador estiver ingressado no Microsoft Entra, use o user@domain.com formato do seu nome de usuário. Você só deve usar o formato se o seu dispositivo estiver ingressado DOMAIN\user somente no domínio.

Se você não tiver um erro mais específico associado ao problema, a maneira mais fácil de solucionar o problema é entrar no computador com as credenciais exatas inseridas em sua conexão. Você pode tentar esse método entrando no computador localmente ou por meio de uma conexão de Área de Trabalho Remota. Você deve receber a mesma mensagem de erro que o Power Automate recebe ao tentar autenticar suas credenciais, o que deve ajudá-lo a solucionar o problema.

Outros motivos que podem impedir que você entre na máquina de destino (além de usar um nome de usuário ou senha incorretos):

  • Não há suporte para PINs. Certifique-se de usar uma senha em vez de um PIN do Windows Hello.
  • O computador não pode se conectar ao seu domínio ou à ID do Microsoft Entra (antigo Azure Active Directory) porque não está ingressado corretamente. Para resolver esse problema, consulte Erro de credenciais inválidas de fluxo da área de trabalho ao usar uma conta do Microsoft Entra.
  • O computador não pode chamar o ponto de extremidade de autenticação devido a um problema de rede. Certifique-se de verificar sua conexão de rede.

Aqui estão alguns motivos comuns pelos quais a conta de usuário está configurada incorretamente:

  • O administrador alterou as credenciais da conta.
  • A conta de usuário do domínio não foi propagada para o computador.
  • A conta de usuário perdeu privilégios ou foi desabilitada.
  • A senha da conta de usuário expirou.

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