Erro de credenciais inválidas de fluxo da área de trabalho ao usar uma conta do Microsoft Entra
Este artigo fornece uma resolução para o InvalidConnectionCredentials
código de erro ou WindowsIdentityIncorrect
que ocorre quando você executa um fluxo da área de trabalho usando uma conta do Microsoft Entra.
Aplica-se a: Power Automate
Número original do KB: 4555623
Sintomas
Quando você executa um fluxo da área de trabalho usando uma conta do Microsoft Entra, ele falha com o InvalidConnectionCredentials
código de erro ou WindowsIdentityIncorrect
.
{
"error":{
"code": "InvalidConnectionCredentials",
"message": "Could not connect to the Power Automate UI flows Agent. Please make sure that the UI flows connection credentials are valid."
}
}
{
"error":{
"code": "WindowsIdentityIncorrect",
"message": "The credentials provided with the request are invalid."
}
}
Motivo
Você pode encontrar o erro ao usar uma conta do Microsoft Entra por vários motivos:
- As credenciais da conta inseridas na conexão podem não corresponder às da máquina.
- O dispositivo pode não ser ingressado no Microsoft Entra ou ingressado no Microsoft Entra híbrido para dar suporte à autenticação do Microsoft Entra.
- A conta do Microsoft Entra pode não estar sincronizada com o computador.
Resolução
Verifique se o dispositivo está ingressado no Microsoft Entra ou ingressado no domínio:
Abra um prompt de comando.
Execute o comando
dsregcmd /status
.Verifique a
Device State
seção.Certifique-se de que um dos
DomainJoined
valores ouAzureAdJoined
sejaYES
.Se esse não for o caso, uma conta do Microsoft Entra não poderá ser usada, a menos que o dispositivo esteja ingressado. Para obter mais informações, consulte Como ingressar em um dispositivo.
Identifique a conta do Microsoft Entra a ser usada na configuração do computador:
Abra Configurações e selecione Contas.
Selecione Acessar trabalho ou escola.
Certifique-se de ver um texto como "Conectado ao <your_organization> ID do Microsoft Entra". A conta à qual ele está conectado pode ser usada na conexão.
Sincronize a conta do Microsoft Entra no dispositivo:
Selecione o botão Informações ao selecionar sua conexão do Microsoft Entra na página corporativa ou de estudante do Access.
Isso abrirá uma página que descreve suas informações de conexão e o status de sincronização do dispositivo. Selecione o botão Sincronizar no final da página e aguarde a conclusão desse processo.
Verifique se a conta configurada do Microsoft Entra pode entrar no dispositivo:
- Tente entrar no computador usando a conta do Microsoft Entra identificada na etapa 2.
- O login do dispositivo deve ser bem-sucedido para ser usado em uma conexão.
Certifique-se de que o fluxo esteja configurado corretamente com o nome de usuário e a senha corretos. Isso deve corresponder à conta em seu computador.