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Solucionar problemas de previsão

Este artigo ajuda você a solucionar problemas relacionados à previsão no Microsoft Dynamics 365 Sales.

Problema 1 - Um erro é exibido quando você tenta criar uma previsão baseada em território

Sintomas

Quando você tenta criar uma previsão baseada em território, um erro é exibido. Além disso, os dados em uma previsão baseada em território podem não ser atualizados.

Causa

Quando as atualizações do sistema são executadas, a hierarquia da entidade de território é desativada (embora você a tenha habilitado anteriormente), o que causa esse erro.

Solução

Para resolver esse problema, você deve habilitar a hierarquia na definição de relacionamento territory_parent_territory em Relacionamentos. Siga estas etapas:

  1. Vá para Configurações avançadas.

    A página de configurações avançadas é aberta em uma guia.

  2. Selecione Configurações>Personalização>Personalizações.

    A página de configurações do Power Apps é aberta.

  3. Selecione Entidades de Dados> e, em seguida, selecione Território.

    Selecione a entidade de território no Power Apps.

  4. Na página Território , selecione a guia Relações e, em seguida, selecione Pai.

    Selecione o pai para a entidade de território.

  5. Na caixa de diálogo Muitos para um, marque a caixa de seleção Hierárquico e selecione Concluído.

    Ative a opção Hierarquia na caixa de diálogo Muitos para um.

  6. Salve e feche a entidade.

Problema 2 – Não é possível ocultar o campo de categoria de previsão em formulários de oportunidade

Causa

Às vezes, o aplicativo exibe o campo Categoria de previsão em formulários de oportunidade, mesmo depois de ter sido configurado como invisível por padrão por meio de personalizações de formulário.

Solução

Para resolver esse erro, você deve excluir o campo Categoria de previsão do formulário. Siga estas etapas:

  1. Em seu aplicativo, na barra de navegação, selecione o ícone Configurações e depois Configurações Avançadas.

    Configurações avançadas no menu Configurações.

    A página Configurações de gerenciamento de negócios abre em uma nova janela do navegador.

  2. Na barra de navegação, selecione Configurações e, em Personalização, selecione Personalizações.

  3. Selecione Personalizar o sistema.

  4. Em Componentes no gerenciador de soluções, expanda Entidades, expanda Oportunidade e selecione Formulários.

  5. Abra o formulário Oportunidade do tipo de formulário Principal.

    O formulário de oportunidade é aberto em uma nova janela.

  6. Na seção Resumo, selecione o campo Categoria de previsão e, em seguida, selecione Remover.

    Remova o campo de categoria de previsão.

  7. Salve e publique a configuração.

Problema 3 - Não é possível visualizar previsões

Causa

Se você estava usando a versão anterior da previsão e atualizou para a mais recente, o mapa do site de previsão pode não ser atualizado. Isso pode ser causado pela presença de uma camada não gerenciada do aplicativo Hub de Vendas, o que permitiria que o mapa do site de previsão abrisse a versão anterior da previsão.

A imagem a seguir é um exemplo da versão anterior da home page de previsão.

Página inicial da versão anterior da previsão.

Solução

Para resolver esse problema, atualize a entrada do mapa do site de previsão para a grade de entrada de previsão mais recente. Para obter mais informações, consulte Adicionar opções de configuração e grade de previsão no mapa do site.

Problema 4 - Não é possível carregar a grade de previsão e um erro é exibido

Causa

O processo ForecastInstanceActions está desativado. O motivo pode ser que o proprietário de uma organização tenha mudado, o que está causando a falha ao carregar a grade de previsão. O erro mostrado na imagem a seguir é exibido.

A ação (ForecastInstanceActions) para buscar previsões foi desabilitada.

A mensagem de erro Action (ForecastInstanceAction) para buscar previsões foi desativada.

Solução

Para resolver esse erro, ative o processo ForecastInstanceActions . Siga estas etapas:

  1. Vá para Configurações avançadas e selecione Configurações>Processos do Process Center>.

  2. Na caixa de pesquisa, insira ForecastInstanceActions. Você pode ver que o processo está no estado Rascunho .

    ForecastInstanceActions no estado de rascunho.

  3. Selecione o processo e, em seguida, selecione Ativar.

    Ative o processo ForecastInstanceActions.

  4. Na mensagem de confirmação, selecione Ativar.

    Processo de ações de instância de previsão ativado.

  5. Verifique se o estado do processo é Ativado e feche Configurações.

Problema 5 – Não é possível exibir dados de detalhamento em uma grade de previsão

Causa

Você não tem privilégios suficientes para a entidade Configuração de Previsão exibir dados de detalhamento na grade de previsão. O erro mostrado na imagem a seguir é exibido.

Algo deu errado.
Houve um erro na recuperação dos registros de previsão.
Por favor, recarregue a página do navegador novamente.

A mensagem de erro algo deu errado que ocorre quando você tenta exibir dados detalhados em uma grade de previsão.

Solução

Para resolver esse erro, o administrador deve fornecer privilégios de leitura na entidade Configuração de Previsão para sua função de segurança. Siga estas etapas:

  1. Vá para Configurações avançadas e selecione Configurações>Segurança>Direitos de acesso.

  2. Selecione o direito de acesso ao qual você deseja aplicar os privilégios.

  3. Na página de direito de acesso, selecione a guia Entidades Personalizadas e vá para a linha Configuração de Previsão.

  4. Selecione e forneça os privilégios de leitura.

    Forneça privilégios de leitura para a entidade Configuração de Previsão.

  5. Feche as configurações.

Problema 6 – Os campos de categoria de previsão não são atualizados

Causa

Em uma previsão, depois de atualizar o campo de categoria de previsão para Ganho ou Perdido, as oportunidades ainda aparecem no bucket de pipeline anterior. Esse erro ocorre porque o fluxo de trabalho Processo de mapeamento de categoria de previsão de oportunidade está desabilitado em sua organização.

Solução

Para resolver o erro, ative o fluxo de trabalho Processo de mapeamento de categoria de previsão de oportunidade. Siga estas etapas:

  1. Vá para Configurações avançadas e selecione Configurações>Personalizações>Personalizar o sistema.

  2. No mapa do site, selecione Processos.

  3. Selecione o fluxo de trabalho Processo de Mapeamento de Categoria de Previsão de Oportunidade e, em seguida, selecione Ativar.

    Ative o fluxo de trabalho Processo de mapeamento de categoria de previsão de oportunidade.

    As categorias de previsão nas oportunidades serão atualizadas corretamente. As oportunidades que foram alteradas antes de ativar o fluxo de trabalho devem ser alteradas manualmente. Além disso, abra o fluxo de trabalho Processo de mapeamento de categoria de previsão de oportunidade e verifique se as condições estão definidas corretamente para cada categoria de previsão.

    As condições do fluxo de trabalho do Processo de mapeamento de categoria de previsão de oportunidade.

  4. Salve e feche as configurações.

Causa

Esse problema ocorre porque o usuário "Dynamics 365 Sales Forecasting" não tem permissão de leitura para a entidade de pesquisa relacionada à hierarquia.

Solução

Para resolver o problema, siga as etapas:

  1. Vá para Configurações avançadas e selecione Configurações>Segurança>do sistema>Funções de segurança.

  2. Abra a função Forecast AppUser e selecione a guia em que o tipo de entidade está presente.

    Captura de tela que mostra a função Usuário do Aplicativo de Previsão.

  3. Ative a permissão Ler no nível da organização para o tipo de entidade do campo de pesquisa.

  4. Salve as alterações.

Problema 8 - Não é possível ativar uma previsão

Causa

A ativação da previsão falha devido a vários motivos.

Solução

Para resolver o problema, siga as etapas:

  1. Certifique-se de ter feito todas as configurações obrigatórias para seu modelo de previsão.
  2. Certifique-se de que os filtros de hierarquia na configuração de previsão não filtrem toda a hierarquia. Vá para a seção Visualizar na etapa Geral para garantir que a hierarquia exista. Para obter mais informações, consulte Adicionar filtros adicionais a uma previsão.

Problema 9 - Não é possível encontrar a opção de configuração de previsão nas configurações do aplicativo

Causa

A opção de configuração de previsão pode não estar visível nas Configurações do aplicativo do aplicativo Hub de Vendas devido aos seguintes motivos:

  • Você não tem a permissão de leitura para a entidade de configuração de previsão.
  • O administrador não adicionou manualmente a grade de previsão e a configuração na seção Gerenciamento de desempenho.

Solução

Para resolver o problema, siga estas etapas:

  1. Atribua o direito de acesso Forecast Manager ao usuário que deve ser capaz de criar e gerenciar configurações de previsão.
  2. Na configuração de previsão, os itens do painel de navegação de previsão devem ser adicionados em um aplicativo personalizado.

Problema 10 – Não é possível visualizar previsões para hierarquia de usuários

Causa

Esse problema ocorre devido a permissões insuficientes para exibir a previsão.

Solução

Para resolver o problema, certifique-se de que:

  1. Uma destas condições é satisfeita:

    • Você é o dono da previsão. O campo de pesquisa Proprietário na etapa Permissões da configuração de previsão mostra quem é o proprietário.

      Captura de tela que mostra a etapa Permissões da configuração de previsão.

    • Você faz parte dos direitos de acesso que têm a permissão de leitura, conforme configurado na etapa Permissões da configuração de previsão.

    • Alguém compartilhou a previsão com você. Para obter mais informações, consulte Habilitar ou desabilitar o compartilhamento de previsões.

  2. O campo de pesquisa Proprietário na etapa Permissões da configuração de previsão não está definido como Nenhum. Se estiver definido como Nenhum, ninguém poderá ver a previsão.

Problema 11 - Os valores de campo de previsão mostram zero ou em branco na grade de previsão

Causa

As colunas associadas ao campo Seletor, Valor e Data podem ter a segurança em nível de campo habilitada.

Solução

Para resolver o problema, você precisa conceder a permissão de Leitura ao usuário # Dynamics 365 Sales Forecasting nos perfis de segurança de campo. Caso contrário, a coluna mostrará 0 para todos os usuários. Siga estas etapas para configurar os perfis de segurança de campo:

  1. Vá para Configurações>Configurações>avançadas Campo de segurança>Perfis de segurança.
  2. Selecione o perfil de segurança do campo associado ao campo que mostra 0.
  3. Selecione Usuários>Adicionar.
  4. Pesquise o usuário # Dynamics 365 Sales Forecasting, marque a caixa de seleção ao lado do nome de usuário e selecione Selecionar>Adicionar.
  5. Selecione Permissões de campo e conceda permissão de leitura ao campo.
  6. Salve e feche o perfil.

Recalcule a previsão e verifique se a coluna mostra os valores apropriados.

Problema 12 - Não é possível recalcular manualmente a coluna de previsão na página Previsões

Causa

A coluna de previsão na página Previsões não pode ser recalculada manualmente.

Solução

A coluna de previsão na Previsão é recalculada automaticamente a cada sete dias e não é compatível com o recálculo manual. Isso ocorre porque as previsões são baseadas em modelos orientados por IA que analisam dados históricos e o pipeline de vendas aberto para prever o resultado da receita futura. A coluna de previsão mostra a receita prevista para cada vendedor e gerente com base no campo Status de uma oportunidade. Para otimizar a precisão das previsões, certifique-se de que os valores de Categoria de Previsão sejam mantidos em sincronia com o campo Status. Para a categoria de previsão pronta para uso, um fluxo de trabalho garante que quando uma oportunidade é fechada como Vencida ou Perdida, a categoria de previsão será atualizada com o valor correto.

Problema 13 - A exibição de grade subjacente da previsão é desativada (somente leitura) quando a página está sendo carregada

Causa

Um JavaScript personalizado configurado na configuração de previsão impede que a grade seja editável.

Solução

Para resolver o problema, revise o código JavaScript personalizado e verifique se ele desabilita a exibição de grade de registros subjacentes.