Udostępnij za pośrednictwem


Błąd "Żądanie uprawnień administratora crm w celu uzyskania dostępu do usługi Salesforce przy użyciu interfejsów API"

Ten artykuł ułatwia rozwiązywanie problemów z wyświetlaniem komunikatu o błędzie po nawiązaniu połączenia i zalogowaniu się do usługi Salesforce CRM w aplikacji Microsoft Copilot for Sales.

Uwaga 16.

Microsoft Sales Copilot jest przemianowany na Microsoft Copilot for Sales w styczniu 2024 roku. Zrzuty ekranu w tym artykule zostaną wkrótce zaktualizowane o nową nazwę.

Na kogo ma to wpływ?

Typ wymagania Popis
Aplikacja kliencka Dodatek Copilot for Sales Outlook
Platforma Klient internetowy i klasyczny
System operacyjny Windows i Mac
Wdrażanie Zarządzane przez użytkownika i administratora
CRM Salesforce
Użytkownicy Użytkownicy próbujący użyć narzędzia Copilot for Sales z usługą Salesforce CRM

Symptomy

Po zalogowaniu się do usługi Salesforce CRM za pośrednictwem dodatku Copilot for Sales dla programu Outlook zostanie wyświetlony następujący komunikat o błędzie:

Żądanie uprawnień administratora crm w celu uzyskania dostępu do usługi Salesforce przy użyciu interfejsów API

Zrzut ekranu przedstawiający błąd uprawnień interfejsu API.

Przyczyna

Problem występuje, gdy nie masz uprawnień interfejsu API w usłudze Salesforce. Jeśli w dziennikach jest wyświetlany następujący błąd, można potwierdzić, że jest to główna przyczyna problemu:

Exception thrown in VivaSalesContacts/GetContactsByEmailAddress - 
Microsoft.SalesProductivity.Common.Base.SPServiceException: Salesforce failed to complete task: Message: entity is deleted clientRequestId: {CLIENT REQUEST ID HERE}-self ---> 
System.Exception: { 
    "error": { 
        "code": 502, 
        "source": "{APIM SOURCE}", 
        "message": "BadGateway", 
        "innerError": { 
            "status": 502, 
            "message": "Salesforce failed to complete task: Message: **API is disabled for this User**\r\nclientRequestId: {CLIENT REQUEST ID HERE}", 
            "error": null, 
            "source": "Salesforce.Common", 
            "errors": [] 
        } 
    } 
} 

Rozwiązanie

Administrator może udzielić użytkownikowi lub profilowi użytkownika włączonego interfejsu API, wykonując następujące czynności:

  1. Zaloguj się w Salesforce jako administrator.

  2. Wprowadź wartość Użytkownik w polu Wyszukaj.

  3. W okienku nawigacji po lewej stronie wybierz pozycję Profile, a następnie wybierz profil użytkownika, którego dotyczy problem.

  4. W sekcji Uprawnienia administracyjne wybierz pozycję Włączono interfejs API.

  5. Wybierz pozycję Zapisz.

    Zrzut ekranu przedstawiający opcję Włączone interfejsu API na stronie Profile.

Więcej informacji

Jeśli problem jest nadal nierozwiązany, przejdź do witryny Copilot for Sales — Microsoft Community Hub , aby współpracować z naszymi ekspertami.

Zastrzeżenie dotyczące innych firm

Produkty innych firm omówione w tym artykule są wytwarzane przez producentów niezależnych od firmy Microsoft. Firma Microsoft nie udziela żadnych gwarancji, dorozumianych ani żadnego innego rodzaju, w odniesieniu do wydajności lub niezawodności tych produktów.