Udostępnij za pośrednictwem


Nie można uruchomić aplikacji mobilnej usługi Field Service z powodu problemów z uprawnieniami lub uprawnieniami

Ten artykuł zawiera rozwiązanie błędu "Brak uprawnień głównego użytkownika", który występuje, gdy nie można uruchomić aplikacji mobilnej usługi Field Service.

Symptomy

Nie można uruchomić aplikacji mobilnej usługi Dynamics 365 Field Service z powodu następującego błędu:

W jednostce<> OTC=INT dla jednostki "msdyn_mobilesource" brakuje uprawnień "prvReadmsdyn_Mobile" (Identyfikator=<GUID>) w jednostce OTC=<INT> ...

Przyczyna

Nowe środowisko użytkownika w aplikacji mobilnej Usługi Dynamics 365 Field Service wymaga pewnych uprawnień w rolach zabezpieczeń użytkowników.

Rozwiązanie

System automatycznie dodaje niezbędne uprawnienia do wszystkich domyślnych ról zabezpieczeń. Jeśli jednak organizacja używa niestandardowych ról zabezpieczeń, musisz edytować role zabezpieczeń, aby dodać następujące uprawnienia tabeli:

  • Nazwa="msdyn_richtextfile" Uprawienie="Utwórz" Wartość="Użytkownik"
  • Nazwa="msdyn_richtextfile" Uprawienie="Usuń" Wartość="Użytkownik"
  • Nazwa="msdyn_richtextfile" Uprawienie="Odczytaj" Wartość="Użytkownik"
  • Nazwa="msdyn_richtextfile" Uprawienie="Zapisz" Wartość="Użytkownik"
  • Nazwa="msdyn_MobileSource" Uprawienie="Odczytaj" Wartość="Organizacja"
  • Nazwa="msdyn_solutioncomponentsummary" Uprawienie="Odczytaj" Wartość="Organizacja"
  • Nazwa="SettingDefinition" Uprawienie="Odczytaj" Wartość="Organizacja"
  • Nazwa="Solution" Uprawienie="Odczytaj" Wartość="Organizacja"
  • Nazwa="SettingDefinition" Uprawienie="Odczytaj" Wartość="Organizacja"

Napiwek

Jeśli nie znasz nazwy niestandardowej roli zabezpieczeń, rozwiń węzeł Użytkownicy i uprawnienia, wybierz pozycję Użytkownicy i poszukaj użytkownika, który otrzymuje komunikat o błędzie. Zwróć uwagę na rolę zabezpieczeń użytkownika i przejrzyj uprawnienia tabeli dla tej roli zabezpieczeń.