Udostępnij za pośrednictwem


System Windows wyświetla komunikat „sprawdzanie systemu plików” podczas rozruchu maszyny wirtualnej platformy Azure

Dotyczy: ✔️ maszyny wirtualne z systemem Windows

W tym artykule opisano błąd "Sprawdzanie systemu plików", który może wystąpić podczas rozruchu maszyny wirtualnej z systemem Windows na platformie Microsoft Azure.

Objaw

Maszyna wirtualna z systemem Windows nie uruchamia się. Po sprawdzeniu zrzutów ekranu rozruchu w diagnostyce rozruchu zobaczysz, że proces sprawdzania dysku (chkdsk.exe) jest uruchomiony z jednym z następujących komunikatów:

  • Skanowanie i naprawianie dysku (C:)
  • Sprawdzanie systemu plików w języku C:

Przyczyna

Jeśli w systemie plików zostanie znaleziony błąd NTFS, system Windows sprawdzi i naprawi spójność dysku podczas następnego ponownego uruchomienia. Zwykle dzieje się tak, jeśli maszyna wirtualna miała nieoczekiwane ponowne uruchomienie lub czy proces zamykania maszyny wirtualnej został nagle przerwany.

Rozwiązanie

Napiwek

Jeśli masz najnowszą kopię zapasową maszyny wirtualnej, możesz spróbować przywrócić maszynę wirtualną z kopii zapasowej , aby rozwiązać problem z rozruchem.

System Windows uruchomi się normalnie po zakończeniu procesu sprawdzania dysku. Jeśli maszyna wirtualna jest zablokowana w procesie Sprawdzania dysku, spróbuj uruchomić polecenie Sprawdź dysk na maszynie wirtualnej w trybie offline:

  1. Utwórz migawkę dysku systemu operacyjnego maszyny wirtualnej, której dotyczy problem, jako kopię zapasową. Aby uzyskać więcej informacji, zobacz Migawka dysku.

  2. Dołącz dysk systemu operacyjnego do maszyny wirtualnej naprawy.

  3. Na maszynie wirtualnej naprawy uruchom polecenie Sprawdź dysk na dołączonym dysku systemu operacyjnego. W poniższym przykładzie litera sterownika dołączonego dysku systemu operacyjnego to E:

    chkdsk E: /f
    
  4. Po zakończeniu sprawdzania dysku odłącz dysk od maszyny wirtualnej naprawy, a następnie ponownie dołącz dysk do maszyny wirtualnej, której dotyczy problem, jako dysk systemu operacyjnego. Aby uzyskać więcej informacji, zobacz Rozwiązywanie problemów z maszyną wirtualną z systemem Windows przez dołączenie dysku systemu operacyjnego do maszyny wirtualnej naprawy za pośrednictwem witryny Azure Portal.

Skontaktuj się z nami, aby uzyskać pomoc

Jeśli masz pytania lub potrzebujesz pomocy, utwórz wniosek o pomoc techniczną lub zadaj pytanie w społeczności wsparcia dla platformy Azure. Możesz również przesłać opinię o produkcie do społeczności opinii na temat platformy Azure.