Botgesprekken van Power Virtual Agents worden weergegeven als actief op het dashboard nadat een gebruiker een chat heeft beëindigd
Dit artikel biedt een oplossing voor het probleem waarbij botgesprekken van Power Virtual Agents worden weergegeven als actief op het Omnichannel for Customer Service-dashboard, zelfs als een gebruiker een chat heeft beëindigd.
Belangrijk
Power Virtual Agents-mogelijkheden en -functies maken nu deel uit van Microsoft Copilot Studio na aanzienlijke investeringen in generatieve AI en verbeterde integraties binnen Microsoft Copilot.
Sommige artikelen en schermopnamen verwijzen mogelijk naar Power Virtual Agents terwijl we de documentatie en trainingsinhoud bijwerken.
Symptomen
Nadat een gesprek is beëindigd, worden de botgesprekken van Power Virtual Agents nog steeds weergegeven als actief op het dashboard.
Oorzaak
Gesprekken voor de Power Virtual Agents-bot kunnen niet worden beëindigd in Omnichannel for Customer Service. Daarom worden ze gezien als actief op het supervisordashboard, zelfs nadat ze zijn gesloten.
Oplossing
U kunt een contextvariabele configureren waarmee het botgesprek expliciet wordt beëindigd in Omnichannel for Customer Service nadat gebruikers het chatvenster hebben gesloten. Maak in Power Virtual Agents een zelfstandig onderwerp voor de CloseOmnichannelConversation
contextvariabele met de variabeleeigenschap ingesteld op global
. Roep het onderwerp aan in een ander onderwerp dat u voor de bot hebt geconfigureerd.
Hoewel het gesprek wordt gesloten in Omnichannel for Customer Service, wordt het niet gesloten in Power Virtual Agents en wordt het weergegeven in de KPI voor escalatiefrequentiestuurprogramma's in het dashboard van Power Virtual Agents Analytics .
Belangrijk
Zorg ervoor dat u toegang hebt tot Power Automate om een stroom zo te configureren dat het botgesprek in Omnichannel for Customer Service kan worden beëindigd.
Voer de volgende stappen uit om het beëindigen van een botgesprek te configureren:
Configureer in Power Virtual Agents een nieuw onderwerp voor de geselecteerde bot.
Selecteer Naar ontwerpcanvas gaan en selecteer in Knooppunt toevoegen de optie Een actie aanroepen en selecteer vervolgens Een stroom maken.
Voer in het Power Automate-venster dat wordt geopend op een nieuw tabblad de volgende stappen uit:
- Selecteer in het vak Waarden retourneren naar Power Virtual Agents de optie Een invoer toevoegen en selecteer vervolgens Ja/nee.
- Voer in het vak Titel invoeren CloseOmnichannelConversation in. Dit is de naam van de contextvariabele Omnichannel for Customer Service.
- Selecteer in het vak Een waarde invoeren om te reageren het tabblad Expressie en voer vervolgens in bool(true) in om de uitdrukking samen te stellen en selecteer OK.
- Sla de wijzigingen op en sluit vervolgens Power Automate af.
Selecteer in het onderwerp dat u bewerkt een actie opnieuw aanroepen en selecteer vervolgens in de lijst de stroom die u hebt gemaakt.
Selecteer in Knooppunt Toevoegen de gespreksoverdracht>naar agent beëindigen.
Ga naar het onderwerp waarin u het onderwerp moet aanroepen om het botgesprek in Omnichannel for Customer Service te beëindigen, en gebruik de optie Naar ander onderwerp gaan in Een knooppunt toevoegen.
Selecteer het onderwerp dat u hebt gemaakt om het botgesprek te beëindigen.
Sla de wijzigingen op en publiceer deze.
Daarnaast kunt u geautomatiseerde berichten configureren in Omnichannel for Customer Service die worden weergegeven aan de gebruiker nadat het gesprek is beëindigd.