데스크톱용 Power Automate 데스크톱 흐름을 실행할 때 잘못된 자격 증명 오류
이 문서에서는 Microsoft 데스크톱용 Power Automate 클라우드 흐름에서 데스크톱 흐름을 실행할 때 발생하는 잘못된 자격 증명 오류에 대한 솔루션을 제공합니다.
적용 대상: Power Automate
원래 KB 번호: 5021155
증상
데스크톱 흐름 연결을 만들 때 다음과 같은 오류 메시지가 표시됩니다.
세부 정보: 연결 실패: [컴퓨터 <ID>]. 자격 증명에 문제가 있습니다. 자격 증명을 확인하거나 다른 자격 증명을 사용하여 컴퓨터에 연결합니다. 상관 관계 ID: <상관 관계 ID>입니다.
데스크톱 흐름을 실행하면 오류 코드가
WindowsIdentityIncorrect
표시됩니다. 이 오류 코드와 연결된 메시지는 "요청과 함께 제공된 자격 증명이 잘못되었습니다." 또는 더 구체적인 것일 수 있습니다.{ "error":{ "code": "WindowsIdentityIncorrect", "message": "The credentials provided with the request are invalid." } }
참고 항목
연결 오류가 발생하는 경우 가장 좋은 테스트는 원격 데스크톱을 사용하여 동일한 컴퓨터에 연결하고 데스크톱 흐름을 만들 때 사용한 것과 동일한 자격 증명을 사용하는 것입니다.
원인
연결의 자격 증명이 대상 컴퓨터에서 인증할 수 없기 때문에 오류 메시지가 발생합니다.
연결을 만들 때 Power Automate는 자격 증명이 유효한지 확인합니다. 자격 증명이 대상 컴퓨터에서 인증되지 않으면 연결을 만들 수 없으며 문제를 설명하는 오류가 표시됩니다.
이전에 연결을 성공적으로 만들었으나 흐름을 실행할 때 오류가 발생하면 사용자 계정 또는 컴퓨터에서 변경된 내용이 있음을 나타냅니다(예: 암호가 만료되었을 수 있습니다.)
해결
무엇이 잘못되었는지에 대한 구체적인 세부 정보가 포함된 오류 메시지를 보려면 Power Automate 버전 2.24 이상이 설치되어 있는지 확인합니다. 종종 이 메서드는 문제를 해결하기에 충분한 정보를 제공합니다. 다음 표에서는 몇 가지 특정 오류 코드 및 해결 방법을 보여 줍니다.
오류 코드 | 오류 메시지 | 원인 | 해결 방법 |
---|---|---|---|
-1073741477 | 사용자가 부여되지 않은 로그온 유형(예: 대화형 또는 네트워크)을 요청했습니다. 관리자는 네트워크를 통해 대화형으로 로그온할 수 있는 사용자를 제어할 수 있습니다. | 사용자 계정에 컴퓨터에 대한 로그온 권한이 없거나 관리자가 컴퓨터의 정책을 변경했습니다(사용자 권한 할당 설정 확인). | 이 문제를 해결하려면 데스크톱 흐름을 실행하거나 연결을 만들 때 "로그온 형식이 부여되지 않았습니다." 오류를 참조하세요. |
-1073445812 | 사용자의 UPN이 예상 형식이 아닙니다. | 사용자가 로그인 DOMAIN\user 했지만 대신 형식을 user@domain.com 사용해야 합니다(또는 그 반대의 경우도 마찬가지). |
형식과 DOMAIN\user 형식을 user@domain.com 모두 사용하여 로그인해 봅니다. |
-1073741062 | 스마트 카드 로그온이 필요하고 사용되지 않았습니다. | 스마트 카드 로그온이 필요한 컴퓨터에 대한 연결은 지원되지 않습니다. 이 요구 사항 없이 컴퓨터를 사용합니다. | |
-1073741715 | 잘못된 사용자 이름 또는 인증 정보 | "실행 중인 계정 이름" 또는 사용자 이름의 형식이 잘못되었습니다. | 데스크톱 흐름 연결 계정의 컨텍스트에서 dsregcmd /status 명령을 실행합니다. 출력의 Executing Account Name 섹션을 확인하고 사용된 사용자 이름과 일치하는지 확인합니다. Microsoft Entra 조인 또는 하이브리드 디바이스는 항상 UPN user@domain.com 형식을 선호합니다. 컴퓨터가 Microsoft Entra에 조인된 경우 사용자 이름 형식을 사용합니다 user@domain.com . 디바이스가 DOMAIN\user 도메인 전용 조인인 경우에만 형식을 사용해야 합니다. |
문제와 관련된 더 구체적인 오류가 없는 경우 문제를 해결하는 가장 쉬운 방법은 연결에 입력한 정확한 자격 증명으로 컴퓨터에 로그인하는 것입니다. 로컬로 또는 원격 데스크톱 연결을 통해 컴퓨터에 로그인하여 이 메서드를 시도할 수 있습니다. 자격 증명을 인증하려고 할 때 Power Automate에서 받는 것과 동일한 오류 메시지가 표시되어야 하며, 이는 문제를 해결하는 데 도움이 됩니다.
잘못된 사용자 이름 또는 암호를 사용하는 것 외에 대상 컴퓨터에 로그인하지 못할 수 있는 기타 이유:
- PIN은 지원되지 않습니다. Windows Hello PIN 대신 암호를 사용해야 합니다.
- 컴퓨터가 도메인 또는 Microsoft Entra ID(이전의 Azure Active Directory)에 연결할 수 없습니다. 제대로 조인되지 않았기 때문입니다. 이 문제를 해결하려면 Microsoft Entra 계정을 사용할 때 데스크톱 흐름의 잘못된 자격 증명 오류를 참조 하세요.
- 컴퓨터는 네트워크 문제로 인해 인증 엔드포인트를 호출할 수 없습니다. 네트워크 연결을 확인해야 합니다.
다음은 사용자 계정이 잘못 구성된 몇 가지 일반적인 이유입니다.
- 관리자가 계정 자격 증명을 변경했습니다.
- 도메인 사용자 계정이 컴퓨터에 전파되지 않았습니다.
- 사용자 계정이 권한을 잃었거나 사용하지 않도록 설정되었습니다.
- 사용자 계정 암호가 만료되었습니다.