Microsoft Entra 계정을 사용하는 경우 데스크톱 흐름의 잘못된 자격 증명 오류
이 문서에서는 Microsoft Entra 계정을 사용하여 데스크톱 흐름을 실행할 때 발생하는 오류 코드에 WindowsIdentityIncorrect
대한 InvalidConnectionCredentials
해결 방법을 제공합니다.
적용 대상: Power Automate
원래 KB 번호: 4555623
증상
Microsoft Entra 계정을 사용하여 데스크톱 흐름을 실행하면 오류 코드와 함께 InvalidConnectionCredentials
WindowsIdentityIncorrect
실패합니다.
{
"error":{
"code": "InvalidConnectionCredentials",
"message": "Could not connect to the Power Automate UI flows Agent. Please make sure that the UI flows connection credentials are valid."
}
}
{
"error":{
"code": "WindowsIdentityIncorrect",
"message": "The credentials provided with the request are invalid."
}
}
원인
다음과 같은 몇 가지 이유로 Microsoft Entra 계정을 사용할 때 오류가 발생할 수 있습니다.
- 연결에 입력한 계정 자격 증명이 컴퓨터의 자격 증명과 일치하지 않을 수 있습니다.
- 디바이스가 Microsoft Entra에 가입되지 않았거나 Microsoft Entra 하이브리드에 가입되어 Microsoft Entra 인증을 지원하지 않을 수 있습니다.
- Microsoft Entra 계정이 컴퓨터에 동기화되지 않을 수 있습니다.
해결
디바이스가 Microsoft Entra에 가입되어 있는지 또는 도메인에 가입되어 있는지 확인합니다.
명령 프롬프트가 엽니다.
dsregcmd /status
명령을 실행합니다.섹션을 확인합니다
Device State
.또는 값 중
DomainJoined
하나가 .인지 확인합니다YES
.AzureAdJoined
그렇지 않은 경우 디바이스가 조인되지 않는 한 Microsoft Entra 계정을 사용할 수 없습니다. 자세한 내용은 디바이스를 조인하는 방법을 참조 하세요.
컴퓨터 구성에서 사용할 Microsoft Entra 계정을 식별합니다.
설정을 열고 계정을 선택합니다.
회사 또는 학교 액세스 선택
"Your_organization Microsoft Entra ID에 <> 연결됨"이라는 텍스트가 표시되는지 확인합니다. 연결된 계정을 연결에서 사용할 수 있습니다.
디바이스에서 Microsoft Entra 계정을 동기화합니다.
회사 또는 학교 액세스 페이지에서 Microsoft Entra 연결을 선택할 때 정보 단추를 선택합니다.
그러면 연결 정보 및 디바이스 동기화 상태를 설명하는 페이지가 열립니다. 페이지 끝에서 동기화 단추를 선택하고 이 프로세스가 완료되기를 기다립니다.
구성된 Microsoft Entra 계정이 디바이스에 로그인할 수 있는지 확인합니다.
- 2단계에서 식별된 Microsoft Entra 계정을 사용하여 컴퓨터에 로그인해 봅니다.
- 연결에서 사용하려면 디바이스 로그인이 성공해야 합니다.
흐름이 올바른 사용자 이름과 암호로 올바르게 구성되었는지 확인합니다. 컴퓨터의 계정과 일치해야 합니다.