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eDiscovery에서 검색 오류 해결(표준)

Microsoft Purview eDiscovery(표준)에서 검색과 관련된 문제 또는 오류가 발생하는 경우 작업을 다시 시도하여 일시적인 문제를 배제합니다. 문제가 지속되면 다음 목록에서 해당 설명을 선택합니다.

이러한 해결 방법이 검색 문제에 적용되지 않는 경우 Microsoft 지원 문의하세요. 문제에 따라 지원 사례를 만들기 전에 Get-ComplianceSearch 또는 Get-ComplianceSearchAction PowerShell cmdlet을 사용하여 출력을 수집합니다. Microsoft 지원 필요할 수 있는 다른 진단 정보에 대한 자세한 내용은 eDiscovery 진단 정보 수집을 참조하세요.

eDiscovery 보류 문제는 eDiscovery(표준)의 보류 오류 해결을 참조하세요.

검색 문제: 예상 검색 결과와 다운로드한 검색 결과의 차이

증상

다운로드한 eDiscovery 검색 결과 폴더의 내보내기 요약 <타임스탬프>.csv 파일에서 검색 결과 통계를 보면 예상 및 다운로드한 검색 결과 통계가 다릅니다. 예상 검색 결과 통계는 Microsoft Purview 규정 준수 포털 검색에 대한 세부 정보 창과 eDiscovery 내보내기 도구에도 표시됩니다.

원인

검색 결과의 추정치는 검색 쿼리 조건을 충족하는 실제 항목 수가 아니라 예측값입니다. 예상 검색 결과와 다운로드한 검색 결과가 다를 수 있는 이유에 대한 자세한 내용은 예상 검색 결과와 실제 eDiscovery 검색 결과의 차이점을 참조하세요.

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검색 오류: "위치가 모호함"

증상

eDiscovery 검색실행하면 검색이 실패하고 다음 오류 메시지가 반환됩니다.

준수 검색에는 다음과 같은 잘못된 위치( <사서함 식별자)가 포함됩니다>. 위치 <사서함 식별자가> 모호합니다.

원인

오류 메시지에 지정된 위치가 잘못되었습니다. 잘못된 각 위치에 대한 사서함 식별자는 EOP(Exchange Online Protection)의 중복되거나 충돌하는 개체에서 사용됩니다.

해결

잘못된 각 위치에 대해 다음 단계를 수행합니다.

  1. 보안 및 규정 준수 PowerShell에 연결합니다.

  2. 사서함 식별자를 사용하는 중복되거나 충돌하는 개체를 찾습니다. 이렇게 하려면 다음 Get-Recipient 명령을 실행합니다.

    Get-Recipient -Identity "<mailbox identifier from error message>"
    
  3. 중복되거나 충돌하는 개체를 제거합니다.

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검색 오류: "받는 사람을 찾을 수 없음"

증상

eDiscovery 검색이 실패하고 "받는 사람을 찾을 수 없습니다."라는 오류 메시지가 반환됩니다.

원인

EOP(Exchange Online Protection)의 동기화 지연으로 인해 시스템에서 eDiscovery 검색에서 받는 사람 중 하나를 찾을 수 없습니다.

해결

  1. 보안 및 규정 준수 PowerShell에 연결합니다.

  2. Get-Recipient cmdlet을 사용하여 검색 쿼리의 받는 사람이 EOP에서 동기화되는지 확인합니다. 다음 명령을 실행합니다.

    Get-Recipient -Identity "<user identifier>" | FL
    
  3. 명령이 받는 사람에 대한 사용자 개체를 반환하지 않는 경우 동기화가 완료되기까지 30분 동안 기다린 다음 다시 확인합니다.

  4. 받는 사람이 EOP에서 동기화되었는지 확인한 후 검색을 다시 시도합니다.

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검색 오류: CS007

증상

eDiscovery 검색이 실패하고 오류 코드를 반환 CS007 합니다.

원인

다음 문제 중 하나에서 이 오류가 발생할 수 있습니다.

  • 일시적인 문제

  • 시스템이 처리하기에 너무 많은 결과를 반환하는 검색 쿼리입니다. 예를 들어 여러 와일드카드를 사용하는 쿼리는 큰 결과 집합을 반환할 수 있습니다.

해결

검색을 다시 시도합니다. 검색이 여전히 실패하는 경우 검색을 더 작은 검색으로 분할합니다. 예를 들어 날짜 범위를 사용하거나 검색 위치 수를 제한하여 더 작은 결과 집합을 반환합니다.

검색 오류: "내부 서버 오류(500)가 발생했습니다."

증상

eDiscovery 검색이 실패하고 "내부 서버 오류(500)가 발생했습니다."라는 오류 메시지가 반환됩니다.

원인

이 오류를 일으킬 수 있는 문제는 다음과 같습니다.

  • 시스템이 처리하기에 너무 많은 결과를 반환하는 검색 쿼리입니다. 예를 들어 여러 와일드카드를 사용하는 쿼리는 큰 결과 집합을 반환할 수 있습니다.

  • 기타 검색 오류입니다. 이러한 오류를 확인하려면 다음 명령을 실행하여 검색에 대한 정보를 확인한 다음 출력에서 오류 메시지를 찾습니다.

    Get-ComplianceSearch -Identity <search name> | FL ResultDetails
    

해결

검색을 다시 시도합니다. 검색이 여전히 실패하는 경우 검색을 더 작은 검색으로 분할합니다. 예를 들어 날짜 범위를 사용하거나 검색 위치 수를 제한하여 더 작은 결과 집합을 반환합니다.

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검색 또는 내보내기 오류: "현재 실행 중인 조직의 최대 작업 수"

증상

eDiscovery 검색 결과를 검색하거나 내보내려고 하면 작업이 실패하고 다음 오류 메시지가 표시됩니다.

조직의 최대 작업 수가 현재 실행 중이므로 요청을 시작할 수 없습니다.

원인

조직에서 최대 50개의 동시 작업 제한에 도달했습니다. 내보내기 작업은 일반적으로 검색 작업보다 완료하는 데 시간이 오래 걸리므로 내보내기 작업은 할당량을 채울 가능성이 높습니다.

해결

다음 절차를 사용하여 현재 실행 중인 내보내기 작업을 확인합니다.

참고 항목

다음 절차를 사용하려면 eDiscovery 관리자 역할 그룹의 구성원이어야 하며 해당 그룹의 eDiscovery 관리자여야 합니다. 조직에서 eDiscovery 관리자를 보거나 할당하는 방법에 대한 자세한 내용은 eDiscovery 권한 할당, Get-eDiscoveryCaseAdminAdd-eDiscoveryCaseAdmin을 참조하세요.

  1. 보안 및 규정 준수 PowerShell에 연결합니다.

  2. 다음 스크립트를 실행합니다.

    $date = Get-Date
    $exports = @(Get-ComplianceSearchAction -Export -ResultSize Unlimited)
    $cases = Get-ComplianceCase | ?{$_.status -like "Active"}
    $i = 1
    foreach ($case in $cases) {
      $exports += Get-ComplianceSearchAction -Export -Case $case.Name
      Write-Host "Processing case $($i) of $($cases.Count)"
      $i++
    }
    $inProgressExports = $exports | ?{$_.Results -eq $null -or (!$_.Results.Contains("Export status: Completed") -and !$_.Results.Contains("Export status: none"))}
    $inProgressExportsSince = $inProgressExports | ?{$_.JobStartTime -ge $date.AddDays(-7)} | Sort-Object JobStartTime -Descending
    Write-Host "In-progress export jobs:"
    $inProgressExports | Format-Table Name,JobStartTime,JobEndTime,Status | More
    Write-Host "In-progress export jobs started in the last 7 days:"
    $inProgressExportsSince | Format-Table Name,JobStartTime,JobEndTime,Status | More
    

오류를 해결하려면 다음 절차를 사용합니다.

  1. 실행 중인 작업 수를 줄입니다. 다음 방법 중 하나 또는 둘 다를 사용합니다.

    • 실행 중인 작업이 하나 이상 완료되기를 기다립니다.

    • Remove-ComplianceSearchAction PowerShell cmdlet을 사용하여 더 이상 필요하지 않은 실행 중인 작업을 하나 이상 제거합니다.

  2. 검색 또는 내보내기 작업을 다시 시도합니다.

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내보내기 문제: 내보내기가 중단된 것 같습니다.

증상

eDiscovery 검색 결과를 내보내려고 하지만 내보내기가 완료되지 않아 중단된 것으로 보입니다.

원인

일시적인 문제는 내보내기 프로세스를 중단시킬 수 있습니다.

해결

내보내기를 다시 시작합니다.

참고 항목

7일 전에 생성된 검색 결과 내보내기를 다시 시작할 수 없습니다. 대신 검색을 다시 실행한 다음 내보내기를 시작합니다.

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내보내기 오류: "항목이 이동 또는 삭제되었습니다" 또는 "시간 제한으로 인해 항목을 검색할 수 없음"

증상

eDiscovery 검색 결과를 다운로드한 후 다운로드한 내보내기 폴더의 내보내기 경고 및 Errors.csv 파일에 다음 오류가 표시됩니다.

  • FailedToExportItem_Microsoft.Exchange.EDiscovery.Export.ExportException: 'FailedToExportItem' 오류 유형으로 내보내기가 실패했습니다. 메시지: 항목이 이동 또는 삭제되었습니다.

  • FailedToExportItem_Microsoft.Exchange.EDiscovery.Export.ExportException: 'FailedToExportItem' 오류 유형으로 내보내기가 실패했습니다. 메시지: 여러 번 다시 시도한 후 시간 제한으로 인해 항목을 검색할 수 없습니다.

원인

이러한 "FailedToExportItem" 오류 메시지는 시스템에서 모든 검색 결과 항목을 내보내지 않았음을 나타냅니다. 보고되지 않은 항목은 사서함 보관 중에 시스템에서 만든 임시 백업입니다. eDiscovery는 임시 백업 항목을 검색할 수 있지만 이러한 항목은 내보낼 수 없습니다.

해결

시스템이 임시 백업과 연결된 원래 사서함 항목을 검색하고 내보낼 때까지 기다립니다.

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내보내기 오류: "상태 코드 500으로 요청 실패" 또는 "500 내부 서버 오류"

증상

eDiscovery 검색 결과를 내보내거나 다운로드하려고 하면 다음 오류 메시지 중 하나가 표시됩니다.

  • 상태 코드 500으로 요청 실패

  • 500 내부 서버 오류

원인

이 문제는 다음과 같은 이유로 발생할 수 있습니다.

원인 1

내보내기 역할이 없습니다. 내보내기 역할은 eDiscovery Manager 역할 그룹의 멤버에게 자동으로 할당됩니다. 내보내기 역할은 조직 관리 역할 그룹의 구성원에게 자동으로 할당되지 않습니다.

원인 2

이 오류는 검색 결과를 내보낸 관리자가 아닌 경우 내보낸 검색 결과를 다운로드하려고 할 때 발생합니다.

원인 3

사용자 계정에 대한 권한 필터는 검색하고 내보낼 수 있는 사서함, 스토리지 위치 또는 콘텐츠를 제한합니다.

원인 4

검색에 대한 내보낼 수 있는 데이터의 양이 2TB를 초과합니다. 단일 검색에 대해 내보낼 수 있는 데이터의 최대 크기는 2TB입니다. 내보낼 수 있는 데이터 크기를 확인하려면 다음 명령을 실행합니다.

Get-ComplianceSearch -Identity <search name> | FL Size,SuccessResults,SearchStatistics

해결

해당하는 원인에 해당하는 해결 방법을 선택합니다.

해결 방법 1

조직 관리 역할 그룹의 구성원인 경우 eDiscovery Manager 역할 그룹에 자신을 추가합니다. Microsoft Purview 규정 준수 포털 사용 권한 페이지에서 또는 Add-eDiscoveryCaseAdmin PowerShell cmdlet을 사용하여 이 작업을 수행할 수 있습니다.

해결 방법 2

내보내기를 만든 관리자에게 다운로드를 완료하도록 요청합니다. 해당 관리자를 찾으려면 다음 명령을 실행합니다.

Get-ComplianceSearchAction -Export -Case <case name> | FL Name,CreatedBy

해결 방법 3

검색 및 내보내려는 사서함 및 스토리지 위치의 경우 사용 권한 필터가 이러한 작업을 방지하는지 확인 합니다 . 필요한 경우 관리자에게 권한 필터를 구성하도록 요청합니다.

해결 방법 4

검색을 더 작은 검색으로 분할하여 다운로드 크기를 줄입니다. 예를 들어 날짜 범위를 사용하거나 검색 위치 수를 제한하여 더 작은 결과 집합을 반환합니다.

검색, 내보내기 또는 미리 보기 역할이 지정된 관리자 계정에 할당되었는지 확인하려면 Microsoft 365 관리 센터 다음 테스트를 실행합니다. 다음 단계를 사용하려면 전역 또는 규정 준수 관리자 권한이 있어야 합니다.

참고 항목

이 진단은 GCC High 또는 DoD 환경 또는 21Vianet에서 운영하는 Microsoft 365에서 사용할 수 없습니다.

  1. Microsoft 365 관리 센터 테스트 실행: eDiscovery RBAC 확인 단추를 선택하여 연결된 테스트를 채웁니다.

  2. 진단 실행 섹션에서 검색, 내보내기 또는 미리 보기 작업을 실행하려는 사용자의 UPN 또는 전자 메일 주소를 입력합니다.

  3. 테스트 실행을 선택합니다.

  4. 사용자에게 필요한 eDiscovery 역할이 할당되지 않은 경우 사용자가 원하는 작업을 실행할 수 있도록 해당 역할을 할당합니다.

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내보내기 오류: "파일이 존재하지 않아 내보낼 수 없습니다" 또는 "파일을 찾을 수 없음"

증상

eDiscovery 검색 결과를 다운로드한 후 다운로드한 내보내기 폴더에 경고 내보내기 및 Errors.csv, 건너뛴 Items.csv 또는 trace.log 파일에 다음 오류 메시지가 표시됩니다.

  • 이 파일은 더 이상 존재하지 않으므로 내보내지 않았습니다. 이 파일은 인덱스에도 계속 나열되어 있으므로 예상 검색 결과 수에 포함되었습니다. 파일은 결국 인덱스에서 제거되며 나중에 오류가 발생하지 않습니다.

  • 콘텐츠를 다운로드할 FailedToExportItem_Failed. 추가 진단 정보: Microsoft.Office.Compliance.EDiscovery.ExportWorker.Exceptions.ContentDownloadTemporaryFailure: 문서 형식의 콘텐츠 <문서 ID> 에서 다운로드하지 못했습니다. 상관 관계 ID: <상관 관계 ID>입니다. ServerErrorCode: -2147024894 ---> Microsoft.SharePoint.Client.ServerException: 파일을 찾을 수 없습니다. microsoft.SharePoint.Client.ClientRequest.ProcessResponseStream(Stream responseStream)의 Microsoft.SharePoint.Client.ClientRequest.ProcessResponse() --- 내부 예외 스택 추적의 끝 ---

원인

eDiscovery 검색에 Microsoft Office SharePoint Online 또는 Microsoft 비즈니스용 OneDrive 위치가 포함된 경우 이 오류 메시지가 표시될 수 있습니다. eDiscovery는 SharePoint Online 인덱스를 사용하여 두 위치의 파일을 식별합니다. 사용자가 검색이 완료된 후와 시스템에서 SharePoint Online 인덱스를 업데이트하기 전에 검색 결과에서 파일의 이름을 바꾸거나 이동하거나 삭제하면 오류가 발생합니다. 해당 SharePoint Online 또는 비즈니스용 OneDrive 위치에서 파일을 찾아 파일의 이름을 바꾸거나, 이동했는지, 삭제되었는지 확인할 수 있습니다.

해결

이 문제를 해결하려면 사이트, 라이브러리 또는 목록의 크롤링 및 다시 인덱싱을 수동으로 요청하는 절차 중 하나를 사용하여 SharePoint Online 또는 비즈니스용 OneDrive 위치를 다시 인덱싱합니다. 검색 결과에 이름이 변경되거나 이동된 파일이 포함되도록 하려면 eDiscovery 검색을 다시 실행합니다.

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다운로드 내보내기 문제: 내보낸 검색 결과의 느린 다운로드

증상

eDiscovery 검색 결과를 다운로드하면 다운로드 시간이 예상보다 오래 걸립니다.

원인

다운로드 속도가 느려질 수 있는 문제는 다음과 같습니다.

  • 많은 양의 내보내기 데이터입니다. 다운로드 크기를 확인하려면 다음 명령을 실행합니다.

    Get-ComplianceSearch -Identity <search name> | FL Size,SuccessResults,SearchStatistics
    
  • 사서함 서버에서 평소보다 높은 부하.

  • 기타 다운로드 오류입니다. 이러한 오류를 확인하려면 다음을 수행합니다.

    • 다음 명령을 실행하여 진행 중인 내보내기 정보를 가져옵니다. 명령 출력에서 오류 메시지를 찾습니다.

      Get-ComplianceSearchAction | FL Results
      
    • 다운로드한 내보내기 폴더의 trace.log 파일에서 오류 메시지를 찾습니다.

해결

다운로드 크기를 줄이려면 검색을 더 작은 검색으로 분할합니다. 예를 들어 날짜 범위를 사용하거나 검색 위치 수를 제한하여 더 작은 결과 집합을 반환합니다.

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다운로드 내보내기 문제: eDiscovery 내보내기 도구에서 파일을 다운로드하지 않음

증상

eDiscovery 내보내기 도구를 실행하여 eDiscovery 검색 결과를 다운로드합니다. 그러나 작업이 완료되면 도구 창의 예상 합계 필드에는 파일이 다운로드되지 않은 것으로 표시됩니다.

원인

이 문제는 다음과 같은 이유로 발생할 수 있습니다.

  • 대상 컴퓨터의 바이러스 백신 소프트웨어는 다운로드를 차단합니다.

  • 로컬 드라이브가 아닌 다운로드 드라이브를 선택합니다.

  • 다음 중 하나의 대상 폴더를 선택합니다.

    • 다른 eDiscovery 내보내기의 다운로드 폴더입니다.

    • 다른 eDiscovery 내보내기의 다운로드 폴더의 부모 폴더입니다. 내보내기 도구는 메타데이터 파일을 부모 폴더에 저장하기 때문에 다른 다운로드에 대한 메타데이터 파일이 서로 충돌할 수 있습니다.

해결

문제가 해결될 때까지 지정된 순서로 다음 메서드를 각각 시도합니다.

  1. 대상 컴퓨터에서 바이러스 백신 스캐너를 일시 중지한 다음 다운로드를 다시 시도합니다.

  2. 로컬 드라이브에 다운로드합니다. 필요한 경우 다른 클라이언트 컴퓨터에 다운로드합니다.

  3. 동시 eDiscovery 내보내기와 충돌하지 않는 대상 폴더를 선택합니다.

  4. 압축된 폴더로 내보내기를 사용하지 않도록 설정하고 Exchange 콘텐츠 중복 제거를 사용하지 않도록 설정합니다. 이 단계에서 문제를 해결하는 경우 원인은 아마도 바이러스 백신 소프트웨어가 다운로드를 차단하거나 원격 드라이브에 다운로드하려고 했다는 것입니다.

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다운로드 내보내기 오류: "검색 결과가 폴더이므로 다운로드되지 않았습니다."

증상

eDiscovery 검색 결과를 다운로드한 후 다운로드한 내보내기 폴더의 건너뛴 Items.csv 파일에 다음 오류 메시지가 표시됩니다.

이 검색 결과는 폴더 또는 그 자체로 다운로드할 수 없는 다른 아티팩트이므로 다운로드되지 않았습니다. 폴더 또는 라이브러리 내의 모든 항목이 다운로드됩니다.

원인

검색에 Microsoft Office SharePoint Online 또는 Microsoft 비즈니스용 OneDrive 위치가 포함된 경우 이 오류 메시지가 표시될 수 있습니다. 건너뛴 Items.csv 파일은 검색 결과의 모든 폴더 및 기타 건너뛴 항목을 나열합니다. 일반적으로 오류 메시지는 다운로드할 수 있는 항목이 아니기 때문에 폴더 경로 옆에 표시됩니다.

해결

해결이 필요하지 않습니다. 오류 메시지를 무시해도 됩니다.

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다운로드 내보내기 오류: "'ExportData.db' 파일에 액세스할 수 없습니다."

증상

eDiscovery 내보내기 도구를 실행하여 eDiscovery 검색 결과를 다운로드하지만 다운로드가 중단되거나 0-바이트 파일이 생성됩니다. 다운로드한 내보내기 폴더의 trace.log 파일에 다음 오류 메시지가 표시됩니다.

허용되는 적중 오류, 다시 시도합니다. 프로세스는 다른 프로세스에서 사용 중이므로 'ExportData.db' 파일에 액세스할 수 없습니다.

원인

이 문제는 다음과 같은 경우에 발생할 수 있습니다.

  • 대상 컴퓨터의 바이러스 백신 소프트웨어는 다운로드를 차단합니다.

  • 로컬 드라이브가 아닌 다운로드 드라이브를 선택합니다.

  • 다음 중 하나의 대상 폴더를 선택합니다.

    • 다른 eDiscovery 내보내기의 다운로드 폴더입니다.

    • 다른 eDiscovery 내보내기의 다운로드 폴더의 부모 폴더입니다. 내보내기 도구는 메타데이터 파일을 부모 폴더에 저장하기 때문에 다른 다운로드에 대한 메타데이터 파일이 충돌할 수 있습니다.

해결

오류가 해결될 때까지 지정된 순서로 다음 메서드를 각각 시도합니다.

  1. 대상 컴퓨터에서 바이러스 백신 스캐너를 일시 중지한 다음 다운로드를 다시 시도합니다.

  2. 로컬 드라이브에 다운로드합니다. 필요한 경우 다른 클라이언트 컴퓨터에 다운로드합니다.

  3. 동시 eDiscovery 내보내기와 충돌하지 않는 대상 폴더를 선택합니다.

  4. 압축된 폴더로 내보내기를 사용하지 않도록 설정하고 Exchange 콘텐츠 중복 제거를 사용하지 않도록 설정합니다. 이 단계에서 문제를 해결하는 경우 원인은 아마도 바이러스 백신 소프트웨어가 다운로드를 차단하거나 원격 드라이브에 다운로드하려고 했다는 것입니다.

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