RD ライセンス サーバーがないため、RDS に接続できない
この記事は、リモート デスクトップ セッション ホスト (RDSH) サーバーとリモート デスクトップ ライセンス サーバーを含む展開での "ライセンスがありません" エラーのトラブルシューティングに役立ちます。
現象
クライアントはリモート デスクトップ サービスに接続できず、次のようなメッセージが表示されます。
ライセンスを提供するためのリモート デスクトップ ライセンス サーバーがないため、リモート セッションは切断されました。
セキュリティ エラーのため、アクセスが拒否された。
ドメイン管理者として RD セッション ホストにサインインし、RD ライセンス診断機能を開きます。 次のようなメッセージを探します。
リモート デスクトップ セッション ホスト サーバーの猶予期間が過ぎましたが、RD セッション ホスト サーバーでライセンス サーバーが 1 台も構成されていません。 RD セッション ホスト サーバーにライセンス サーバーが構成されていないと、RD セッション ホスト サーバーへの接続は拒否されます。
ライセンス サーバー <コンピューター名> は使用できません。 This could be caused by network connectivity problems, the Remote Desktop Licensing service is stopped on the license server, or RD Licensing isn't available. (原因としては、ネットワーク接続に問題がある、ライセンス サーバー上でリモート デスクトップ ライセンス サービスが停止している、または RD ライセンスが使用できない、の 3 つが考えられます。)
クライアントはリモート デスクトップ サービスに接続できますが、次のような吹き出しメッセージが表示されます。
リモート デスクトップ ライセンス モードが構成されていません。
リモート デスクトップ サービスは、このコンピューターがライセンスの猶予期間を過ぎているため、動作を停止します。 RD 接続ブローカー サーバーで、サーバー マネージャーを使用してリモート デスクトップ ライセンス モードを指定します。
原因
これらの問題は、次のユーザー メッセージによって発生する可能性があります。
- このコンピューターで利用できるリモート デスクトップ クライアント アクセス ライセンスがないため、リモート セッションは切断されました。
- ライセンスを提供するためのリモート デスクトップ ライセンス サーバーがないため、リモート セッションは切断されました。
この場合は、 RD ライセンス構成を確認します。
RD ライセンス診断ツールに、"RDP プロトコル コンポーネント X.224 がプロトコル ストリームでエラーを検出し、クライアントを切断しました" などの他の問題が一覧表示されている場合は、ライセンス証明書に影響する問題がある可能性があります。 このような問題は、次のようなユーザー メッセージに関連付けられる傾向があります。
Because of a security error, the client could not connect to the Terminal server. After making sure that you are signed in to the network, try connecting to the server again. (セキュリティのエラーのため、クライアントはターミナル サーバーに接続できません。ネットワークにサインインしていることを確認した後、もう一度サーバーに接続してみてください。)
この場合は、X509 証明書レジストリ キーを更新します。
RD ライセンス構成を確認する
サーバー マネージャーと RD ライセンス マネージャーを使用して、RD ライセンス構成を確認できます。 次のことを確認します。
RD ライセンスの役割がインストールされ、ライセンス サーバーがアクティブ化されます。
注:
この構成の詳細については、「 リモート デスクトップ サービス ライセンス サーバーをアクティブ化する」を参照してください。
ライセンス サーバーには、RDS に接続できるユーザーとデバイスごとにクライアント アクセス ライセンス (CAL) があります。
注:
この構成の詳細については、「 リモート デスクトップ ライセンス サーバーに RDS クライアント アクセス ライセンスをインストールする」を参照してください。
ライセンスの構成は、次のスクリーンショットのようになります。 ライセンス サーバー名の横に緑色のチェック マークが表示され、列の番号には、ライセンスの合計数と使用可能なライセンスの数が反映されている必要があります。
RDS デプロイでは、正しいライセンス サーバー、ライセンス モード、ポリシー設定が使用されます。 構成の詳細は、使用しているデプロイの種類によって異なります。
RD 接続ブローカーの役割を含む RDS 展開のライセンスを構成する
RD 接続ブローカー コンピューターで、サーバー マネージャーを開きます。
サーバー マネージャーで、[リモート デスクトップ サービス>の概要>]、[展開プロパティの編集]、>[RD ライセンス] を選択します。
リモート デスクトップ ライセンス モード (展開に応じてユーザーごとまたはデバイスごと) を選択します。
Note
RDS 展開にドメイン参加済みサーバーを使用する場合は、ユーザーごととデバイスごとの両方の CAL を使用できます。 RDS 展開にワークグループ サーバーを使用する場合は、デバイスごとの CAL を使用する必要があります。その場合、ユーザーごとの CAL は許可されません。
ライセンス サーバーを指定し、[追加] を選択します。
RD セッション ホスト ロールと RD ライセンス ロールのみを含む RDS 展開のライセンスを構成する
RD セッション ホスト コンピューターで [スタート] を選択し、「gpedit.msc」と入力してローカル グループ ポリシー エディターを開きます。
[コンピューターの構成]、>[管理テンプレート]、>[Windows コンポーネント]、>[リモート デスクトップ サービス]、>[リモート デスクトップ セッション ホスト]、>[ライセンス] に移動します。
ポリシーの一覧で、[ 指定したリモート デスクトップ ライセンス サーバーを使用する] を右クリックし、[ プロパティ] を選択します。
[有効] を選択し、[使用するライセンス サーバー] にライセンス サーバーの名前を入力します。 複数のライセンス サーバーがある場合は、コンマを使用して名前を区切ります。
[OK] を選択します。
ポリシーの一覧で、[リモート デスクトップ ライセンス モードの設定] を右クリックし、[プロパティ] を選択します。
[Enabled] を選択します。
[リモート デスクトップ セッション ホスト サーバーのライセンス モードを指定する] で、展開に応じて [デバイスごと] または [ユーザーごと] を選択します。
リモート デスクトップ サービス サーバー間でブロックされているポートを確認する
RD セッション ホストと RD ライセンス サーバーの間のファイアウォールで、必要なポートが開いていることを確認します。
さまざまな RDS コンポーネント間で開く必要があるポートの一覧については、次を参照してください。
詳細については、「RDS に接続するときに、 セッションが 60 分以内に切断される」メッセージを参照してください。
セキュリティ ポリシー設定を確認する - ネットワークからこのコンピューターにアクセスする
ローカル グループ ポリシー エディターの Computer Configuration\Windows Settings\Security Settings\Local Policies\User Rights Assignment で、このコンピューターをネットワークからアクセスするセキュリティ ポリシー設定を確認します。
Everyoneが割り当てられていない場合は、この権限を Authenticated Users、Domain Computers、またはセッション ホスト コンピューター アカウントに割り当てます。
詳細については、「 ネットワークからこのコンピューターにアクセスする - セキュリティ ポリシー設定を参照してください。
X509 証明書レジストリ キーを更新する
重要
このセクションの手順には、慎重に従ってください。 レジストリが誤って変更された場合、深刻な問題が発生する可能性があります。 レジストリの変更を開始する前に、問題が発生した場合に復元できるようにレジストリをバックアップします。
この問題を解決するには、[X509 証明書] レジストリ キーをバックアップして削除し、コンピューターを再起動してから、リモート デスクトップ サービス ライセンス サーバーを再アクティブ化します。 次の手順に従います。
注意
RDSH サーバーごとに、次の手順を実行します。
RD ライセンス サーバーを再アクティブ化する方法は次のとおりです。
- レジストリ エディターを開き、 HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Terminal Server\RCM に移動します。
- [レジストリ] メニューの [レジストリ ファイルのエクスポート] をクリックします。
- [ファイル名] ボックスに「exported- Certificate」と入力し、Save を選択します。
- 次の各値を右クリックし、 Delete を選択し、 Yes を選択して削除を確認します。
- 証明書
- X509 Certificate
- X509 Certificate ID
- X509 証明書 2
その他のトラブルシューティング方法
ライセンスの構成が正しいことを確認してもシステムが CAL を正しく発行しない場合は、次の手順に従います。
- RD ライセンス診断ツールを使用して問題を確認する
- RDS CAL、RD セッション ホスト、および RD ライセンス サーバーのバージョンが互換性があることを確認する
- RDS 環境に適した種類の RDS CAL を使用していることを確認する
手順 1: RD ライセンス診断ツールを使用して問題を確認する
RD ライセンス診断ツールを開くには、サーバー マネージャーを開いて [ツール]、>[ターミナル サービス]、>RD ライセンス診断ツール] を選択します。
RD ライセンス診断ツールの上部ウィンドウには、診断ツールで検出された問題が一覧表示されます。 たとえば、次のようなメッセージが表示されることがあります。
このリモート デスクトップ セッション ホスト サーバーではライセンスを使用できず、RD ライセンス診断ツールによって RD セッション ホスト サーバーのライセンスに関する問題が特定されました
[RD ライセンス診断情報] セクションには、問題の原因や修復のための手順など、問題に関する詳細情報が表示されます。
手順 2: RDS CAL、RD セッション ホスト、および RD ライセンス サーバーのバージョンが互換性があることを確認する
次の表は、どの RDS CAL と RD セッション ホストのバージョンが相互に互換性があるかを示しています。
セッション ホストのバージョン | RDS 2016 CAL | RDS 2019 CAL | RDS 2022 CAL | RDS 2025 CAL |
---|---|---|---|---|
Windows Server 2016 セッション ホスト | はい | はい | はい | はい |
Windows Server 2019 セッション ホスト | いいえ | はい | はい | はい |
Windows Server 2022 セッション ホスト | いいえ | 番号 | はい | はい |
Windows Server 2025 セッション ホスト | いいえ | いいえ | 番号 | はい |
次の表は、どの RDS CAL とライセンス サーバーのバージョンが相互に互換性があるかを示しています。
ライセンス サーバーのバージョン | RDS 2016 CAL | RDS 2019 CAL | RDS 2022 CAL | RDS 2025 CAL |
---|---|---|---|---|
Windows Server 2016 ライセンス サーバー | はい | いいえ | いいえ | いいえ |
Windows Server 2019 ライセンス サーバー | はい | はい | いいえ | いいえ |
Windows Server 2022 ライセンス サーバー | はい | はい | はい | いいえ |
Windows Server 2025 ライセンス サーバー | はい | はい | はい | はい |
詳細については、「RDS CAL バージョンの互換性」を参照してください。
手順 3: RDS 環境に適した種類の RDS CAL を使用していることを確認する
RDS 展開にドメイン参加済みのサーバーを使用する場合は、ユーザーごととデバイスごとの CAL の両方を使用できます。 RDS の展開にワークグループ サーバーを使用する場合は、デバイスごとの CAL を使用する必要があります。その場合、ユーザーごとの CAL は許可されません。