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RD ライセンス サーバーがないため、RDS に接続できない

この記事は、リモート デスクトップ セッション ホスト (RDSH) サーバーとリモート デスクトップ ライセンス サーバーを含む展開で発生する「ライセンスなし」エラーのトラブルシューティングに役立ちます。

現象

クライアントはリモート デスクトップ サービスに接続できず、次のようなメッセージが表示されます。

The remote session was disconnected because there are no Remote Desktop License Servers available to provide a license.
Access was denied because of a security error.

ドメイン管理者として RD セッション ホストにサインインし、RD ライセンス診断機能を開きます。 次のようなメッセージを探します。

The grace period for the Remote Desktop Session Host server has expired, but the RD Session Host server hasn't been configured with any license servers. Connections to the RD Session Host server will be denied unless a license server is configured for the RD Session Host server.
License server <computer name> is not available. This could be caused by network connectivity problems, the Remote Desktop Licensing service is stopped on the license server, or RD Licensing isn't available.

原因

これらの問題は、次のユーザー メッセージによって発生する可能性があります。

  • このコンピューターで利用できるリモート デスクトップ クライアント アクセス ライセンスがないため、リモート セッションは切断されました。
  • ライセンスを提供するためのリモート デスクトップ ライセンス サーバーがないため、リモート セッションは切断されました。

この場合は、 RD ライセンス構成を確認します

「RDP プロトコル コンポーネント X.224 がプロトコル ストリームでエラーを検出し、クライアントを切断しました」などの他の問題がRD ライセンス診断ツールに一覧表示されている場合は、ライセンス証明書に影響を与える問題がある可能性があります。 そのような問題は、次のようなユーザー メッセージと関連することがよくあります。

Because of a security error, the client could not connect to the Terminal server. After making sure that you are signed in to the network, try connecting to the server again. (セキュリティのエラーのため、クライアントはターミナル サーバーに接続できません。ネットワークにサインインしていることを確認した後、もう一度サーバーに接続してみてください。)

この場合は、X509 証明書のレジストリ キーを更新します。

RD ライセンス構成を確認する

サーバー マネージャーと RD ライセンス マネージャーを使用して、RD ライセンス構成を確認できます。 次の点を確認します。

RD 接続ブローカーの役割を含む RDS 展開のライセンスを構成する

  1. RD 接続ブローカー コンピューターで、サーバー マネージャーを開きます。

  2. サーバー マネージャーで、[リモート デスクトップ サービス]>[概要]>[Edit Deployment Properties] (展開のプロパティの編集)>[RD ライセンス] を選択します。

    [展開プロパティの編集] オプションを選択して、サーバー マネージャーのリモート デスクトップ ライセンス設定を開きます。

  3. リモート デスクトップ ライセンス モード (展開に合わせて、[ユーザーごと] または [デバイスごと]) を選択します。

    Note

    RDS 展開にドメイン参加済みサーバーを使用する場合は、ユーザーごととデバイスごとの両方の CAL を使用できます。 RDS 展開にワークグループ サーバーを使用する場合は、デバイスごとの CAL を使用する必要があります。その場合、ユーザーごとの CAL は許可されません。

  4. ライセンス サーバーを指定し、[追加] を選択します。

    RD ライセンスの展開を構成します。

RD セッション ホスト ロールと RD ライセンス ロールのみを含む RDS 展開のライセンスを構成する

  1. RD セッション ホスト コンピューターで [スタート] を選択し、「gpedit.msc」と入力してローカル グループ ポリシー エディターを開きます。

  2. [コンピューターの構成]>[管理用テンプレート]>[Windows コンポーネント]>[リモート デスクトップ サービス]>[リモート デスクトップ セッション ホスト]>[ライセンス] に移動します。

    リモート デスクトップ ライセンスのポリシーの一覧。

  3. ポリシーの一覧で、[指定のリモート デスクトップ ライセンス サーバーを使用する] を右クリックし、[プロパティ] を選択します。

  4. [有効] を選択し、[使用するライセンス サーバー] にライセンス サーバーの名前を入力します。 複数のライセンス サーバーがある場合は、コンマを使用して名前を区切ります。

    [指定したリモート デスクトップ ライセンス サーバーを使用する] ダイアログ ボックスで、使用するライセンス サーバーを設定します。

  5. [OK] を選択します。

  6. ポリシーの一覧で、[リモート デスクトップ ライセンス モードの設定] を右クリックし、[プロパティ] を選択します。

  7. [Enabled] を選択します。

  8. [Specify the licensing mode for the Remote Desktop Session Host server] (リモート デスクトップ セッション ホスト サーバーのライセンス モードを指定する) で、展開に合わせて、[デバイスごと] または [ユーザーごと] を選択します。

    [リモート デスクトップ ライセンス モードの設定] ダイアログ ボックスで、リモート デスクトップ セッション ホスト サーバーのライセンス モードを指定します。

X509 証明書のレジストリ キーを更新する

重要

このセクションの手順には、慎重に従ってください。 レジストリに正しくない変更を加えると、重大な問題が発生する可能性があります。 レジストリの変更を開始する前に、レジストリをバックアップして、何らかの問題が発生した場合に復元できるようにします。

この問題を解決するには、レジストリをバックアップした後、X509 証明書のレジストリ キーを削除し、コンピューターを再起動してから、RD ライセンス サーバーを再びアクティブ化します。 次の手順に従います。

注意

RDSH サーバーごとに、次の手順を実行します。

RD ライセンス サーバーを再アクティブ化する方法は、次のとおりです。

  1. レジストリ エディターを開き、HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Terminal Server\RCM に移動します。
  2. [レジストリ] メニューで [レジストリ ファイルのエクスポート] を選択します。
  3. [ファイル名] ボックスに「exported- Certificate」と入力し、 [保存] を選択します。
  4. 次の各値を右クリックし、 Delete を選択し、 Yes を選択して削除を確認します。
    • 証明書
    • X509 Certificate
    • X509 Certificate ID
    • X509 Certificate2

その他のトラブルシューティング方法

ライセンスの構成が正しいことを確認してもシステムが CAL を正しく発行しない場合は、次の手順に従います。

  1. RD ライセンス診断ツールを使用して問題を確認する
  2. RDS CAL、RD セッション ホスト、および RD ライセンス サーバーのバージョンが互換性があることを確認する
  3. RDS 環境に適した種類の RDS CAL を使用していることを確認する

手順 1: RD ライセンス診断ツールを使用して問題を確認する

RD ライセンス診断ツールを開くには、サーバー マネージャーを開いて [ツール]、>[ターミナル サービス]、>RD ライセンス診断ツール] を選択します。

[RD ライセンス診断ツール] ダイアログ ボックスのスクリーンショット。

RD ライセンス診断ツールの上部ウィンドウには、診断ツールで検出された問題が一覧表示されます。 たとえば、次のようなメッセージが表示されることがあります。

このリモート デスクトップ セッション ホスト サーバーではライセンスを使用できず、RD ライセンス診断ツールによって RD セッション ホスト サーバーのライセンスに関する問題が特定されました

[RD ライセンス診断情報] セクションには、問題の原因や修復のための手順など、問題に関する詳細情報が表示されます。

手順 2: RDS CAL、RD セッション ホスト、および RD ライセンス サーバーのバージョンが互換性があることを確認する

次の表は、どの RDS CAL と RD セッション ホストのバージョンが相互に互換性があるかを示しています。

RDS 2008 R2 以前の CAL RDS 2012 CAL RDS 2016 CAL RDS 2019 CAL
2008、2008 R2 セッション ホスト はい イエス イエス はい
2012 セッション ホスト いいえ イエス イエス はい
2012 R2 セッション ホスト いいえ イエス イエス はい
2016 セッション ホスト いいえ 番号 イエス はい
2019 セッション ホスト いいえ いいえ 番号 はい

次の表は、どの RDS CAL とライセンス サーバーのバージョンが相互に互換性があるかを示しています。

RDS 2008 R2 以前の CAL RDS 2012 CAL RDS 2016 CAL RDS 2019 CAL
2008、2008 R2 ライセンス サーバー はい いいえ いいえ いいえ
2012 ライセンス サーバー はい はい いいえ いいえ
2012 R2 ライセンス サーバー はい はい いいえ いいえ
2016 ライセンス サーバー はい イエス はい いいえ
2019 ライセンス サーバー はい イエス イエス はい

詳細については、「RDS CAL バージョンの互換性」を参照してください。

手順 3: RDS 環境に適した種類の RDS CAL を使用していることを確認する

RDS 展開にドメイン参加済みサーバーを使用する場合は、ユーザーごととデバイスごとの両方の CAL を使用できます。 RDS の展開にワークグループ サーバーを使用する場合は、デバイスごとの CAL を使用する必要があります。その場合、ユーザーごとの CAL は許可されません。