インプレース アップグレードを実行すると、"Windows could not parse or process the unattend answer file for pass [specialize]" というエラー メッセージが表示される
この記事では、インプレース アップグレードの実行時に発生するエラー (Windows ではパス [特殊] の無人応答ファイルを解析または処理できませんでした) を修正するためのヘルプを提供します。
適用対象: Windows 7 Service Pack 1、Windows Server 2012 R2
元の KB 番号: 2425962
現象
以下のシナリオについて考えてみます。
- Unattend.xml ファイルを使用してインストールされた Windows 7 または Windows Server 2008 R2 のバージョンを実行している。
- このイメージからコンピューターを起動し、 インプレース アップグレード (上書きインストール) オプションを選択します。
- インプレース アップグレードを開始します。
このシナリオでは、次のエラー メッセージが表示されます。Windows では、パス [特殊] の無人応答ファイルを解析または処理できませんでした。
一般に、Unattend.xml ファイルは OEM または企業環境の展開に使用されます。 そのため、イメージにUnattend.xmlファイルが含まれている可能性があり、このファイルが含まれていることに気付かない場合があります。
原因
この問題は、Unattend.xml ファイルがインプレース アップグレード中に適用されるために発生します。 このシナリオはサポートされません。
詳細
重要
このセクション、方法、またはタスクには、レジストリの編集方法が記載されています。 レジストリを誤って変更すると、深刻な問題が発生することがあります。 したがって、次の手順を注意深く実行してください。 保護のために、レジストリを変更する前に、バックアップします。 その後、問題が起こった場合は、レジストリを復元できます。 レジストリをバックアップおよび復元する方法の詳細については、マイクロソフト サポート技術情報の記事を表示するには、次の資料番号をクリックします。 322756 Windows でレジストリをバックアップおよび復元する方法
この動作が発生した場合、システムを回復することはできません。 そのため、クリーン インストールを実行する必要があります。
この動作を回避するには、OEM インストール イメージを使用してインプレース アップグレードを実行する前に、レジストリ サブキーを削除します。 これを行うには、次の手順を実行します。
- 管理アクセス許可を持つユーザー アカウントを使用して、コンピューターにログオンします。
- [スタート] をクリックし、[スタート検索] ボックスに「regedit」と入力し、Programs 一覧で [regedit.exe] をクリックします。
- 次のレジストリ サブキーを見つけて右クリックします。 HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer\UnattendBackup\ActiveSetup\FavoritesList\Favorite<XX>
Note
このサブキーでは、 <XX> は 1 で始まる数値のプレースホルダーです。
- [削除] クリックしYesをクリックし、レジストリ エディターを終了します。
状態
この動作は仕様によるものです。
データ収集
Microsoft サポートの支援が必要な場合は、「展開関連の問題について TSS を使用して情報を収集する」に記載している手順に従って情報を収集することをお勧めします。