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アクセス許可または特権の問題により、Field Service モバイル アプリの起動に失敗する

この記事では、Field Service モバイル アプリの起動に失敗したときに発生する "プリンシパル ユーザーに特権がありません" エラーの解決策を示します。

現象

Dynamics 365 Field Service モバイル アプリは、次のエラーで開始できません。

エンティティ 'msdyn_mobilesource' の OTC=<INT> のプリンシパル ユーザー (Id=<GUID>, ...) に 'prvReadmsdyn_Mobile' 特権 (Id=<GUID>) がありません。

原因

Dynamics 365 Field Service モバイル アプリの 新しいユーザー エクスペリエンス には、ユーザーのセキュリティ ロールの特定の特権が必要です。

解決方法

システムは、すべての既定のセキュリティ ロールに必要な特権を自動的に追加します。 ただし、組織でカスタム セキュリティ ロールを使用している場合は、セキュリティ ロールを 編集して 次の テーブル特権を追加する必要があります

  • 名前= "msdyn_richtextfile" 権限=「作成」値=「ユーザー」
  • 名前= "msdyn_richtextfile" 権限=「削除」値=「ユーザー」
  • 名前= "msdyn_richtextfile" 権限=「読み取り」値=「ユーザー」
  • 名前= "msdyn_richtextfile" 権限=「書き込み」値=「ユーザー」
  • 名前= "msdyn_MobileSource" 権限=「読み取り」値=「組織」
  • 名前= "msdyn_solutioncomponentsummary" 権限=「読み取り」値=「組織」
  • 名前= "SettingDefinition" 権限=「読み取り」値=「組織」
  • 名前= "Solution" 権限=「読み取り」値=「組織」
  • 名前= "SettingDefinition" 権限=「読み取り」値=「組織」

ヒント

カスタム セキュリティ ロールの名前がわからない場合は、 Users + permissions を展開し、 Users を選択して、エラー メッセージを受け取ったユーザーを探します。 ユーザーのセキュリティ ロールをメモし、そのセキュリティ ロールのテーブル特権を確認します。