"Delta Lake インジェスト ジョブがバージョンを取得できませんでした" エラー
Note
2023 年 9 月 1 日に、マイクロソフトは Dynamics 365 Marketing と Dynamics 365 Customer Insights を統合して名前を変更しました。 Dynamics 365 Marketing は Dynamics 365 Customer Insights - Journeys という名前に変更されました。 Dynamics 365 Customer Insights は Dynamics 365 Customer Insights - Data という名前に変更されました。 詳細については、Dynamics 365 Customer Insights のよくあるご質問 をご覧ください。
この記事は、Microsoft Dynamics 365 Customer Insights - Data でデルタ形式で格納されているデータに接続 場合に発生する可能性がある "Delta Lake インジェスト ジョブがバージョンを取得できませんでした" エラー 解決するのに役立ちます。
現象
Dynamics 365 Customer Insights のデルタ データ ソース - データは、Databricks minReaderVersion
3
以降を必要とする機能を使用するテーブルへの接続を試みます。 この場合、 Data ソース ページに次のエラー メッセージが表示されます。
Delta Lake インジェスト ジョブは、バージョン <DataSourceId> を取得できませんでした。
テーブル内の列を表示すると、"データ ソース スキーマの保存に失敗しました" というエラーが表示されます。
原因
Dynamics 365 Customer Insights - Data は、2
以前のminReaderVersion
を備えた Databricks 機能をサポートします。 Databricks リーダー バージョン 3
以降を必要とする Databricks 機能はサポートされていません。
解決方法
この問題を解決するには、Databricks のインストールから機能を削除し、 minReaderVersion
を 2
に戻します。 詳細については、「 Supported Databricks の機能とバージョンを参照してください。