次の方法で共有


ドライブ E または F に空き領域がありません

この記事では、Microsoft Azure Cloud Services のドライブ E または F で空き領域が不足するシナリオを解決する方法について説明します。

現象

Cloud Services のインスタンスをホストしますが、ドライブ E または F に空き領域がゼロである場合があります。

原因

ドライブ E と F はアプリケーション ディスク ドライブとして使用されるため、それらのドライブにはアプリケーション関連のデータを格納しないでください。 データ ストレージを使用すると、領域の使用量が個々のファイル サイズの合計よりもはるかに大きくなる可能性があります。 詳細については、「 自分のスペースはどこに行きましたか?」を参照してください。

使用されるストレージ領域は、アプリケーションの操作に影響を与えるべきではありません。 ドライブが作成された後、Azure 仮想マシンは、アプリケーション コードが書き込まない限り、ドライブに書き込まれません。 とにかく、アプリケーション コードは、これらのドライブに書き込むべきではありません。

ソリューション

アプリケーションの読み取りと書き込みが必要なデータの場合は、Azure Storage、Azure SQL Server などの外部ストレージ サービスを使用することをお勧めします。

ローカル データ ストアの場所が必要な場合は、アプリケーション コードでローカル ストレージ リソースが使用されていることを確認します。 これらはローカル ドライブ C に格納されます。詳細については、「ローカル ストレージ リソースの構成azure ディスク パーティションを参照してください。

サードパーティの情報に関する免責事項

この資料に記載されているサードパーティ製品は、マイクロソフトと関連のない他社の製品です。 明示的か黙示的かにかかわらず、これらの製品のパフォーマンスや信頼性についてマイクロソフトはいかなる責任も負わないものとします。

お問い合わせはこちらから

質問がある場合やヘルプが必要な場合は、サポート要求を作成するか、Azure コミュニティ サポートにお問い合わせください。 Azure フィードバック コミュニティに製品フィードバックを送信することもできます。