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電子情報開示 (Standard) の検索エラーを解決する

Microsoft Purview eDiscovery (Standard) での検索に関連する問題またはエラーが発生した場合は、操作を再試行して一時的な問題を除外してください。 問題が解決しない場合は、次の一覧から該当する説明を選択します。

これらの解決策が検索の問題に該当しない場合は、Microsoft サポートにお問い合わせください。 問題に応じて、サポート ケースを作成する前に、 Get-ComplianceSearch または Get-ComplianceSearchAction PowerShell コマンドレットを使用して出力を収集します。 Microsoft サポート必要なその他の診断情報については、「電子情報開示の診断情報を参照してください。

電子情報開示の保留に関する問題については、「 電子情報開示 (Standard)での保留エラーの解決」を参照してください。

検索の問題: 推定検索結果とダウンロードされた検索結果の違い

現象

ダウンロードされた電子情報開示検索結果フォルダーの Export Summary <timestamp>.csv ファイルで検索結果の統計情報を表示すると推定検索結果とダウンロードされた検索結果の統計情報が異なることがわかります。 推定検索結果の統計情報は、Microsoft Purview コンプライアンス ポータルの検索の詳細ウィンドウと電子情報開示エクスポート ツールにも表示されます。

原因

検索結果の見積もりは、単なる推定値であり、検索クエリ条件を満たす項目の実際の数ではありません。 推定検索結果とダウンロードされた検索結果が異なる理由の詳細については、「 見積もりと実際の電子情報開示の検索結果の差」を参照してください

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検索エラー: "場所があいまいです"

現象

電子情報開示検索を実行すると検索は失敗し、次のエラー メッセージが返されます。

コンプライアンス検索には、次の無効な場所が含まれています: <mailbox 識別子>。 場所 <メール ボックス識別子> があいまいです。

原因

エラー メッセージで指定された場所が無効です。 各無効な場所のメールボックス識別子は、Exchange Online Protection (EOP) の重複または競合するオブジェクトによって使用されます。

解決方法

無効な場所ごとに、次の手順に従います。

  1. セキュリティとコンプライアンスの PowerShell に接続

  2. メールボックス識別子を使用する重複または競合するオブジェクトを検索します。 これを行うには、次の Get-Recipient コマンドを実行します。

    Get-Recipient -Identity "<mailbox identifier from error message>"
    
  3. 重複するオブジェクトまたは競合するオブジェクトを削除します。

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検索エラー: "受信者が見つかりません"

現象

電子情報開示検索が失敗し、"受信者が見つかりません" というエラー メッセージが返されます。

原因

Exchange Online Protection (EOP) での同期の遅延のため、電子情報開示検索で recipients のいずれかが見つかりません。

解決方法

  1. セキュリティとコンプライアンスの PowerShell に接続

  2. Get-Recipient コマンドレットを使用して、検索クエリの受信者が EOP で同期されているかどうかを確認します。 次のコマンドを実行します。

    Get-Recipient -Identity "<user identifier>" | FL
    
  3. このコマンドで受信者のユーザー オブジェクトが返されない場合は、同期が完了するまで 30 分待ってから、再確認します。

  4. 受信者が EOP で同期されたことを確認したら、検索を再試行します。

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検索エラー: CS007

現象

電子情報開示検索は失敗し、CS007エラー コードが返されます。

原因

次のいずれかの問題が発生すると、このエラーが発生する可能性があります。

  • 一時的な問題

  • システムが処理するには多すぎる結果を返す検索クエリ。 たとえば、複数のワイルドカードを使用するクエリでは、大きな結果セットを返すことができます。

解決方法

検索を再試行します。 それでも検索が失敗する場合は、検索をより小さな検索に分割します。 たとえば、日付範囲を使用するか、検索場所の数を制限して、より小さな結果セットを返します。

検索エラー: "内部サーバー エラー (500) が発生しました"

現象

電子情報開示検索が失敗し、"内部サーバー エラー (500) が発生しました" というエラー メッセージが返されます。

原因

このエラーの原因となる問題は次のとおりです。

  • システムが処理するには多すぎる結果を返す検索クエリ。 たとえば、複数のワイルドカードを使用するクエリでは、大きな結果セットを返すことができます。

  • その他の検索エラー。 これらのエラーを確認するには、次のコマンドを実行して検索に関する情報を取得し、出力でエラー メッセージを探します。

    Get-ComplianceSearch -Identity <search name> | FL ResultDetails
    

解決方法

検索を再試行します。 それでも検索が失敗する場合は、検索をより小さな検索に分割します。 たとえば、日付範囲を使用するか、検索場所の数を制限して、より小さな結果セットを返します。

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検索またはエクスポートのエラー: "組織のジョブの最大数が現在実行中です"

現象

電子情報開示の検索結果をまたはエクスポートしようとすると操作が失敗し、次のエラー メッセージが表示されます。

組織のジョブの最大数が現在実行されているため、要求を開始できません。

原因

組織は、 最大 50 個の同時ジョブの上限に達しました。 通常、エクスポート ジョブは検索ジョブよりも完了に時間がかかるため、エクスポート ジョブはクォータを満たす可能性が高くなります。

解決方法

現在実行中のエクスポート ジョブを確認するには、次の手順に従います。

Note

次の手順を使用するには、電子情報開示マネージャーの役割グループのメンバーであり、そのグループの電子情報開示管理者である必要があります。 組織内の電子情報開示管理者を表示または割り当てる方法の詳細については、「 電子情報開示のアクセス許可の割り当てGet-eDiscoveryCaseAdmin、および Add-eDiscoveryCaseAdmin を参照してください。

  1. セキュリティとコンプライアンスの PowerShell に接続

  2. 次のスクリプトを実行します。

    $date = Get-Date
    $exports = @(Get-ComplianceSearchAction -Export -ResultSize Unlimited)
    $cases = Get-ComplianceCase | ?{$_.status -like "Active"}
    $i = 1
    foreach ($case in $cases) {
      $exports += Get-ComplianceSearchAction -Export -Case $case.Name
      Write-Host "Processing case $($i) of $($cases.Count)"
      $i++
    }
    $inProgressExports = $exports | ?{$_.Results -eq $null -or (!$_.Results.Contains("Export status: Completed") -and !$_.Results.Contains("Export status: none"))}
    $inProgressExportsSince = $inProgressExports | ?{$_.JobStartTime -ge $date.AddDays(-7)} | Sort-Object JobStartTime -Descending
    Write-Host "In-progress export jobs:"
    $inProgressExports | Format-Table Name,JobStartTime,JobEndTime,Status | More
    Write-Host "In-progress export jobs started in the last 7 days:"
    $inProgressExportsSince | Format-Table Name,JobStartTime,JobEndTime,Status | More
    

エラーを解決するには、次の手順に従います。

  1. 実行中のジョブの数を減らします。 次の方法のいずれかまたは両方を使用します。

    • 1 つ以上の実行中のジョブが完了するまで待ちます。

    • Remove-ComplianceSearchAction PowerShell コマンドレットを使用して、不要になった 1 つ以上の実行中のジョブを削除します。

  2. 検索またはエクスポート操作を再試行します。

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エクスポートの問題: エクスポートがストールしているように見える

現象

電子情報開示の検索結果 エクスポートしようとするとエクスポートが完了せず、ストールしているように見えます。

原因

一時的な問題により、エクスポート プロセスがストールする可能性があります。

解決方法

エクスポートを再起動します。

Note

7 日以上前に生成された検索結果のエクスポートを再開することはできません。 代わりに、検索を再実行し、エクスポートを開始します。

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エクスポート エラー: "アイテムが移動または削除されました" または "タイムアウトのためアイテムを取得できません"

現象

電子情報開示の検索結果 ダウンロードするとダウンロードしたエクスポート フォルダーの Export Warnings and Errors.csv ファイルに次のエラーが表示されます。

  • FailedToExportItem_Microsoft.Exchange.EDiscovery.Export.ExportException: "FailedToExportItem" というエラーの種類でエクスポートに失敗しました。 メッセージ: アイテムが移動または削除されました。

  • FailedToExportItem_Microsoft.Exchange.EDiscovery.Export.ExportException: "FailedToExportItem" というエラーの種類でエクスポートに失敗しました。 メッセージ: 複数回の再試行後にタイムアウトのため、アイテムを取得できません。

原因

これらの "FailedToExportItem" エラー メッセージは、システムがすべての検索結果アイテムをエクスポートしなかったことを示します。 エクスポートされていないアイテムは、システムがメールボックスのアーカイブ中に作成した一時的なバックアップです。 電子情報開示では一時的なバックアップ項目を検索できますが、これらの項目はエクスポートできません。

解決方法

システムが一時バックアップに関連付けられている元のメールボックス アイテムを取得してエクスポートするまで待ちます。

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エクスポート エラー: "状態コード 500 で要求が失敗しました" または "500 内部サーバー エラー"

現象

電子情報開示検索結果を エクスポートまたはダウンロードしようとすると、次のいずれかのエラー メッセージが表示

  • 状態コード 500 で要求が失敗しました

  • 500 内部サーバー エラー

原因

この問題は、次のいずれかの理由で発生する可能性があります。

原因 1

Export ロールがありません。 エクスポート ロールは、電子情報開示マネージャー役割グループのメンバーに自動的に割り当てられます。 エクスポート ロールは、組織管理役割グループのメンバーには自動的に割り当てられません。

原因 2

このエラーは、検索結果をエクスポートした管理者でない場合に、エクスポートされた検索結果をダウンロードしようとしたときに発生します。

原因 3

ユーザー アカウントのアクセス許可フィルター は、検索およびエクスポートできるメールボックス、ストレージの場所、またはコンテンツを制限します。

原因 4

検索のエクスポート可能なデータの量が 2 TB を超えています。 1 回の検索でエクスポートできるデータの最大量は 2 TB です。 エクスポート可能なデータ サイズを確認するには、次のコマンドを実行します。

Get-ComplianceSearch -Identity <search name> | FL Size,SuccessResults,SearchStatistics

解決方法

該当する原因に対応する解決策を選択します。

解決策 1

組織の管理役割グループのメンバーである場合は、自分 電子情報開示マネージャーの役割グループに追加します。 これを行うには、Microsoft Purview コンプライアンス ポータルの Permissions ページ、または powerShell コマンドレット Add-eDiscoveryCaseAdmin を使用します。

解決策 2

エクスポートを作成した管理者にダウンロードを完了するよう依頼します。 その管理者を見つけるには、次のコマンドを実行します。

Get-ComplianceSearchAction -Export -Case <case name> | FL Name,CreatedBy

解決策 3

検索およびエクスポートするメールボックスと記憶域の場所について、 アクセス禁止フィルターがあるかどうかを確認 これらの操作を禁止します。 必要に応じて、管理者にアクセス許可フィルターを構成するよう依頼します。

解決策 4

検索を小さな検索に分割して、ダウンロード サイズを小さくします。 たとえば、日付範囲を使用するか、検索場所の数を制限して、より小さな結果セットを返します。

指定された管理者アカウントに検索、エクスポート、またはプレビューロールが割り当てられているかどうかを確認するには、Microsoft 365 管理センターで次のテストを実行します。 次の手順を使用するには、 Global または Compliance 管理者権限が必要です。

Note

この診断は、GCC High または DoD 環境や、21Vianet が運営する Microsoft 365 では利用できません。

  1. Microsoft 365 管理センターで、Run Tests: eDiscovery RBAC check ボタンを選択して、関連するテストを設定します。

  2. 実行診断 セクションで、検索、エクスポート、またはプレビュー タスクを実行しようとしているユーザーの UPN または電子メール アドレスを入力します。

  3. [テスト 実行を選択します。

  4. ユーザーに必要な電子情報開示ロールが割り当てられない場合は、それらのロールを割り当てて、ユーザーが目的のタスクを実行できるようにします。

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エクスポート エラー: "ファイルが存在しないため、エクスポートされませんでした" または "ファイルが見つかりません"

現象

電子情報開示の検索結果を ダウンロードすると次のいずれかのエラー メッセージが Export Warnings and Errors.csvSkipped Items.csv、またはダウンロードしたエクスポート フォルダー内の trace.log ファイルに表示されます。

  • このファイルはもう存在しないため、エクスポートされませんでした。 このファイルは、インデックスにまだ一覧表示されているため、推定検索結果の数に含まれていました。 ファイルは最終的にインデックスから削除され、今後エラーは発生しません。

  • コンテンツをダウンロードするFailedToExportItem_Failed。 追加の診断情報: Microsoft.Office.Compliance.EDiscovery.ExportWorker.Exceptions.ContentDownloadTemporaryFailure: ドキュメントの種類のコンテンツ <ドキュメント ID> からダウンロードできませんでした。 関連付け ID: <関連付け ID>。 ServerErrorCode: -2147024894 ---> Microsoft.SharePoint.Client.ServerException: ファイルが見つかりません。 microsoft.SharePoint.Client.ClientRequest.ProcessResponseStream(Stream responseStream) at Microsoft.SharePoint.Client.ClientRequest.ProcessResponse() ---内部例外スタック トレースの終了---

原因

電子情報開示検索にMicrosoft Office SharePoint Onlineまたは Microsoft OneDrive for Business の場所が含まれている場合、このエラー メッセージが表示されることがあります。 電子情報開示は、両方の場所のファイルを識別するために SharePoint Online インデックスに依存しています。 このエラーは、検索が完了した後、システムが SharePoint Online インデックスを更新する前に、ユーザーが検索結果内のファイルの名前を変更、移動、または削除した場合に発生します。 該当する SharePoint Online または OneDrive for Business の場所でファイルを探して、ファイルの名前が変更、移動、または削除されたかどうかを確認できます。

解決方法

この問題を解決するには、「 サイト、ライブラリ、またはリストのクロールとインデックス再作成を要求する」で提供されているいずれかの手順を使用して、SharePoint Online または OneDrive for Business の場所のインデックスを再作成。 検索結果に名前の変更または移動されたファイルを含める場合は、電子情報開示検索を再実行します。

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エクスポートのダウンロードに関する問題: エクスポートされた検索結果のダウンロードが遅い

現象

電子情報開示検索結果 ダウンロードするとダウンロードに予想以上の時間がかかります。

原因

ダウンロード速度が低下する可能性がある問題は次のとおりです。

  • 大量のエクスポート データ。 ダウンロード サイズを確認するには、次のコマンドを実行します。

    Get-ComplianceSearch -Identity <search name> | FL Size,SuccessResults,SearchStatistics
    
  • メールボックス サーバーでの通常より高い負荷。

  • その他のダウンロード エラー。 これらのエラーを確認するには:

    • 次のコマンドを実行して、進行中のエクスポートに関する情報を取得します。 コマンド出力でエラー メッセージを探します。

      Get-ComplianceSearchAction | FL Results
      
    • ダウンロードしたエクスポート フォルダーの trace.log ファイルでエラー メッセージを探します。

解決方法

ダウンロード サイズを小さくするには、検索を小さな検索に分割します。 たとえば、日付範囲を使用するか、検索場所の数を制限して、より小さな結果セットを返します。

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エクスポートのダウンロードの問題: 電子情報開示エクスポート ツールでファイルがダウンロードされない

現象

電子情報開示エクスポート ツールを実行して、電子情報開示検索結果 ダウンロードします。 ただし、操作が完了すると、ツール ウィンドウの Estimated Total フィールドに、ファイルがダウンロードされなかったことが示されます。

原因

この問題は、次のいずれかの理由で発生する可能性があります。

  • ターゲット コンピューター上のウイルス対策ソフトウェアによってダウンロードがブロックされます。

  • ローカル ドライブではないダウンロード ドライブを選択します。

  • 次のいずれかの宛先フォルダーを選択します。

    • 別の電子情報開示エクスポートのダウンロード フォルダー。

    • 別の電子情報開示エクスポートのダウンロード フォルダーの親フォルダー。 エクスポート ツールはメタデータ ファイルを親フォルダーに保存するため、さまざまなダウンロードのメタデータ ファイルが互いに競合する可能性があります。

解決方法

問題が解決されるまで、特定の順序で次の各メソッドを試してください。

  1. 対象のコンピューターでウイルス対策スキャナーを一時停止し、ダウンロードを再試行します。

  2. ローカル ドライブにダウンロードします。 必要に応じて、別のクライアント コンピューターにダウンロードします。

  3. 同時電子情報開示エクスポートと競合しない宛先フォルダーを選択します。

  4. 圧縮フォルダーへのエクスポートを無効にし、Exchange コンテンツの重複除去を無効にします。 この手順で問題が解決した場合は、ウイルス対策ソフトウェアがダウンロードをブロックしているか、リモート ドライブにダウンロードしようとした可能性があります。

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エクスポート のダウンロード エラー: "検索結果はフォルダーであるためダウンロードされませんでした"

現象

電子情報開示検索結果 ダウンロードするとダウンロードしたエクスポート フォルダーの Skipped Items.csv ファイルに次のエラー メッセージが表示されます。

この検索結果は、単独ではダウンロードできないフォルダーまたはその他の成果物であるため、ダウンロードされませんでした。フォルダーまたはライブラリ内のアイテムはダウンロードされます。

原因

検索に Microsoft Office SharePoint Online または Microsoft OneDrive for Business の場所が含まれている場合、このエラー メッセージが表示されることがあります。 Skipped Items.csv ファイルには、検索結果内のすべてのフォルダーとその他のスキップされたアイテムが一覧表示されます。 通常、エラー メッセージはダウンロード可能なアイテムではないため、フォルダー パスの横に表示されます。

解決方法

解決は必要ありません。 エラー メッセージは無視しても問題ありません。

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エクスポート のダウンロード エラー: "ファイル 'ExportData.db' にアクセスできません"

現象

電子情報開示エクスポート ツールを実行して電子情報開示の検索結果を ダウンロードしますがダウンロードが停止するか、0 バイトのファイルが生成されます。 ダウンロードしたエクスポート フォルダーの trace.log ファイルに次のエラー メッセージが表示されます。

許容エラーが発生すると再試行されます。プロセスは別のプロセスで使用されているため、ファイル 'ExportData.db' にアクセスできません。

原因

この問題は、次の場合に発生する可能性があります。

  • ターゲット コンピューター上のウイルス対策ソフトウェアによってダウンロードがブロックされます。

  • ローカル ドライブではないダウンロード ドライブを選択します。

  • 次のいずれかの宛先フォルダーを選択します。

    • 別の電子情報開示エクスポートのダウンロード フォルダー。

    • 別の電子情報開示エクスポートのダウンロード フォルダーの親フォルダー。 エクスポート ツールはメタデータ ファイルを親フォルダーに保存するため、さまざまなダウンロードのメタデータ ファイルが競合する可能性があります。

解決方法

エラーが解決されるまで、指定された順序で次の各メソッドを試してください。

  1. 対象のコンピューターでウイルス対策スキャナーを一時停止し、ダウンロードを再試行します。

  2. ローカル ドライブにダウンロードします。 必要に応じて、別のクライアント コンピューターにダウンロードします。

  3. 同時電子情報開示エクスポートと競合しない宛先フォルダーを選択します。

  4. 圧縮フォルダーへのエクスポートを無効にし、Exchange コンテンツの重複除去を無効にします。 この手順で問題が解決した場合は、ウイルス対策ソフトウェアがダウンロードをブロックしているか、リモート ドライブにダウンロードしようとした可能性があります。

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