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Messaggio "La sessione verrà disconnessa in 60 minuti" quando ci si connette a Servizi Desktop remoto

Questo articolo illustra come risolvere gli errori di licenza di Servizi Desktop remoto che si verificano quando si usa l'imposizione temporanea delle licenze di Servizi Desktop remoto.

Si applica a: Windows Server 2022, Windows Server 2019, Windows Server 2016

Sintomi

Quando si usa il portale Web Desktop remoto (portale Web Desktop remoto) o una connessione RDP (Direct Remote Desktop Protocol) per connettersi a una farm Servizi Desktop remoto (RDS), viene visualizzato un messaggio simile al seguente:

Si è verificato un problema con la licenza desktop remoto e la sessione verrà disconnessa in 60 minuti. Contattare l'amministratore di sistema per risolvere il problema.

Causa

Questo messaggio è causato dalla funzionalità di licenza soft enforcement introdotta in Windows Server 2016 per le licenze per dispositivo e in Windows Server 2019 per le licenze per utente. Indica che si è verificato un problema nel server licenze Desktop remoto o un problema che impedisce la comunicazione tra il server licenze Desktop remoto e il server Host sessione Desktop remoto (Host sessione Desktop remoto).

Nei casi in cui l'applicazione normale delle licenze impedisce a un utente di connettersi all'host sessione Desktop remoto, l'imposizione temporanea consente all'utente di connettersi per 60 minuti alla volta. L'utente riceve il messaggio quando si connette. Dopo 60 minuti, l'utente viene disconnesso. Tuttavia, l'utente può riconnettersi alla stessa sessione.

Questo articolo illustra separatamente gli scenari di licenza per utente e per dispositivo.

Applicazione temporanea delle licenze per utente (Windows Server 2019)

In uno scenario di licenza per utente (solo Windows Server 2019), il comportamento di applicazione temporanea delle licenze è diverso da quello in scenari per dispositivo. Se gli utenti visualizzano questo messaggio in uno scenario per utente, assicurarsi che tutti i server Desktop remoto dispongano degli aggiornamenti più recenti installati. Se il problema persiste, contattare il supporto tecnico Microsoft.

Importante

La funzionalità di applicazione temporanea delle licenze Desktop remoto è stata rimossa in Windows Server 2022.

Applicazione temporanea delle licenze per dispositivo

In uno scenario di licenza per dispositivo, le cause più comuni di questo messaggio includono quanto segue:

  • Il servizio licenze Desktop remoto non è in esecuzione.
  • Le proprietà delle licenze non sono configurate correttamente.
  • I server Host sessione Desktop remoto non possono connettersi al server licenze Desktop remoto.
  • I server Host sessione Desktop remoto, il server licenze Desktop remoto e gli utenti non si trovano in un singolo dominio e l'attendibilità tra i domini non è configurata correttamente per Servizi Desktop remoto.

Risoluzione

Prima di iniziare la risoluzione dei problemi, controllare i punti seguenti:

  • Assicurarsi che le versioni delle licenze di accesso client (CAL) in uso siano compatibili sia con le versioni host sessione Desktop remoto che con le versioni del server licenze Desktop remoto. Per altre informazioni, vedere Concedere in licenza la distribuzione di Servizi Desktop remoto con licenze di accesso client (CAL): compatibilità delle versioni cal di Servizi Desktop remoto.
  • Se si dispone di una farm Servizi Desktop remoto che usa un server Gestore connessione Desktop remoto, provare a riprodurre il problema usando l'app Connessione Web Desktop remoto per connettersi al server Host sessione Desktop remoto.
  • Se si dispone di una farm Servizi Desktop remoto che non usa un server Gestore connessione Desktop remoto, provare a riprodurre il problema usando il client Microsoft Terminal Services (MSTSC) per connettersi al server Host sessione Desktop remoto.

Le sezioni seguenti forniscono informazioni su come verificare e risolvere i problemi comuni relativi alle licenze.

Controllare il servizio licenze Desktop remoto

Se il servizio licenze Desktop remoto non è in esecuzione, il server licenze Desktop remoto non riesce a recuperare la licenza client.

È possibile usare lo snap-in Servizi MMC (Services.msc, disponibile anche nel menu Strumenti in Server Manager) per gestire i servizi in locale o in remoto. Puoi anche usare PowerShell per gestire i servizi in locale o in remoto se il computer remoto è configurato in modo da accettare cmdlet di PowerShell remoti.

Controllare lo stato del servizio Licenze Desktop remoto. Se il servizio non è in esecuzione, avviarlo.

Controllare il ruolo Licenze Desktop remoto

Usare Server Manager per verificare che i ruoli del server siano stati assegnati correttamente.

In Server Manager selezionare Servizi Desktop remoto, individuare il riquadro Panoramica e quindi selezionare l'elenco Server di distribuzione. Assicurarsi che tutti i ruoli del server siano associati ai server corretti.

Controllare la configurazione delle licenze Desktop remoto

È possibile usare uno dei metodi seguenti per controllare la configurazione delle licenze Desktop remoto, a seconda della modalità di gestione dei server.

Importante

Tutte le impostazioni configurate tramite Criteri di gruppo sostituiscono le impostazioni configurate tramite la console servizi Desktop remoto in Server Manager.

È anche possibile usare l'editor del Registro di sistema per controllare la configurazione delle licenze.

Per usare Server Manager per controllare la configurazione delle licenze, seguire questa procedura:

  1. Nel server Gestore connessione Desktop remoto o nel server Host sessione Desktop remoto aprire Server Manager.
  2. Selezionare Panoramica di Servizi>Desktop remoto, individuare la sezione Panoramica della distribuzione e quindi selezionare Attività>Modifica proprietà distribuzione.
  3. Selezionare Gestione licenze Desktop remoto e quindi controllare la modalità di licenza e l'elenco dei server di licenza.
  4. Se necessario, correggere la configurazione e quindi selezionare OK.

Per usare Criteri di gruppo per controllare la configurazione delle licenze, seguire questa procedura:

  1. A seconda che si voglia configurare Criteri di gruppo centralmente dal dominio o localmente in ogni host di sessione, eseguire una delle operazioni seguenti:
    • Se si gestiscono Criteri di gruppo a livello di dominio, aprire Console Gestione Criteri di gruppo, fare clic con il pulsante destro del mouse sull'oggetto Criteri di gruppo destinato agli host sessione Desktop remoto e quindi scegliere Modifica. Questa operazione apre l'Editor Criteri di gruppo.
    • Se si gestiscono Criteri di gruppo a livello di server, aprire l'Editor Criteri di gruppo locali nell'host sessione Desktop remoto.
  2. Selezionare Configurazione>computer Modelli>amministrativi Componenti>di Windows Servizi Desktop>remoto Licenze host>sessione Desktop remoto.
  3. Controllare la modalità di licenza e l'elenco dei server di gestione delle licenze.
  4. Se necessario, correggere la configurazione.

Per altre informazioni sulle configurazioni delle licenze, vedere Licenze host sessione Desktop remoto.

È possibile usare l'editor del Registro di sistema per controllare la configurazione delle licenze. Aprire l'editor del Registro di sistema (o connettersi al Registro di sistema) nell'host sessione Desktop remoto. Le sottochiavi che contengono queste informazioni variano a seconda della modalità di gestione dei server.

Se si usano Criteri di gruppo per gestire Servizi Desktop remoto, controllare la sottochiave e le voci seguenti:

  • HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows NT\Terminal Services
    • LicenseServers (valore stringa)
    • LicensingMode (valore DWORD)

Se si usa la console servizi Desktop remoto in Server Manager, controllare le sottochiavi e le voci seguenti:

  • HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Terminal Server\RCM\Licensing Core

    • LicensingMode (valore DWORD)
  • HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\TermService\Parameters\LicenseServers\SpecifiedLicenseServers

    • SpecifiedLicenseServers (Valore multi-stringa)

    Nota

    Questa voce esiste solo se è stata usata la console di Servizi Desktop remoto per configurare le licenze.

Per altre informazioni su LicensingMode, vedere LicensingMode.

Verificare la presenza di porte bloccate tra i server Servizi Desktop remoto

Assicurarsi che le porte necessarie siano aperte nei firewall tra l'host sessione Desktop remoto e il server licenze Desktop remoto.

Per gli elenchi delle porte che devono essere aperte tra i diversi componenti di Servizi Desktop remoto, vedere gli articoli seguenti:

Controllare la configurazione del gruppo di lavoro o del dominio

Se si distribuisce Servizi Desktop remoto in più domini, esaminare le procedure consigliate e la possibilità di supportare la configurazione delle licenze Desktop remoto tra domini, foreste o gruppi di lavoro. Per altre informazioni, vedere Procedure consigliate per la configurazione delle licenze di Servizi Desktop remoto tra domini/foreste o gruppi di lavoro di Active Directory.

Contattare il supporto tecnico Microsoft

Se i passaggi precedenti non risolvono il problema, contattare supporto tecnico Microsoft per ulteriori informazioni. Prima di contattare supporto tecnico Microsoft, raccogliere informazioni pertinenti usando TSS per i problemi relativi all'esperienza utente.