Assegnazioni e flusso di lavoro (Agile)
I campi di stato e assegnazioni vengono utilizzati per tenere traccia di storie utente, attività, bug e altri tipi di elementi di lavoro. La maggior parte degli elementi di lavoro passa dallo stato attivo allo stato chiuso, mentre i test case passano dallo stato di progettazione allo stato chiuso. Quando si verifica un passaggio di stato di un determinato elemento di lavoro, quest'ultimo può anche essere riassegnato ai vari membri del team. Ad esempio, un tester può creare un bug che durante la valutazione viene assegnato a un altro membro del team. Quando l'altro membro del team risolve il bug, quest'ultimo viene riassegnato al tester che l'ha creato.
I campi di stato e assegnazioni supportano molte query Team e rapporti.
In questo argomento
Rilevamento dei campi visualizzati nei form di elementi di lavoro
Campi aggiuntivi che supportano le query e la creazione di rapporti
I campi Assegnato a e Stato vengono rilevati per ogni tipo di elemento di lavoro fornito con il modello di processo di Microsoft Solutions Framework (MSF) for Agile Software Development versione 5.0. A eccezione dei test case e dei passi condivisi, il campo Motivo viene rilevato per tutti i tipi di elementi di lavoro.
Rilevamento dei campi visualizzati nei form di elementi di lavoro
Nella tabella seguente vengono descritti i campi che tengono traccia delle assegnazioni e dello stato di avanzamento dei flussi di lavoro. Per informazioni sui tipi di dati e sugli attributi di campo predefiniti, vedere Utilizzo dei campi elementi di lavoro.
Nome campo |
Descrizione |
Nome di riferimento |
Tipo di dati |
Valore predefinito dell'attributo di tipo Reportable |
Valore predefinito dell'attributo indice |
---|---|---|---|---|---|
Assegnato a |
Nome del membro del team che attualmente è proprietario dell'elemento di lavoro. |
System.AssignedTo |
Stringa |
Dimensione |
True |
Motivo |
Indica il motivo per cui l'elemento di lavoro si trova nello stato corrente. I valori sono specifici sia per lo stato sia per il tipo dell'elemento di lavoro. Il campo non viene rilevato per i test case o per i passi condivisi. |
System.Reason |
Stringa |
Dimensione |
True |
Motivo di risoluzione |
Motivo per cui è stato risolto il bug o la storia utente. Ad esempio, il codice della storia utente è completo o il bug è corretto. Questo è un campo di sola lettura. |
Microsoft.VSTS.Common.ResolvedReason |
Stringa |
Dimensione |
False |
Stato |
Stato corrente dell'elemento di lavoro. I valori validi per lo stato sono specifici di ogni tipo di elemento di lavoro. Per ulteriori informazioni sulle transizioni dei flussi di lavoro per ogni tipo di elemento di lavoro, vedere uno degli argomenti seguenti: |
System.State |
Stringa |
Dimensione |
True |
Campi aggiuntivi che supportano le query e la creazione di rapporti
Quando un elemento di lavoro passa da uno stato all'altro alcuni campi aggiuntivi vengono popolati con informazioni. Questi campi non vengono visualizzati nel form dell'elemento di lavoro, ma vengono rilevati per ogni tipo di elemento di lavoro, così come indicato nella tabella seguente. È possibile utilizzare questi campi per filtrare query e creare rapporti.
Nome campo |
Storia utente |
Attività |
Problema |
Test case |
Passo condiviso |
Bug |
---|---|---|---|---|---|---|
Attivato da |
||||||
Data di attivazione |
||||||
Chiuso da |
||||||
Data di chiusura |
||||||
Creato da |
||||||
Data creazione |
||||||
Risolto da |
||||||
Data di risoluzione |
||||||
Motivo di risoluzione |
||||||
Data di modifica dello stato |
I campi che tengono traccia delle informazioni per ogni stato di flusso di lavoro registrano la transizione più recente dello stato di un elemento di lavoro a uno stato attivo, risolto, chiuso o di altro tipo. Ognuno di questi tipi viene descritto nella tabella seguente.
Nome campo |
Descrizione |
Nome di riferimento |
Tipo di dati |
Valore predefinito dell'attributo di tipo Reportable |
Valore predefinito dell'attributo indice |
---|---|---|---|---|---|
Attivato da |
Nome del membro del team che ha attivato o riattivato l'elemento di lavoro. |
Microsoft.VSTS.Common.ActivatedBy |
Stringa |
Dimensione |
False |
Data di attivazione |
Data e ora in cui l'elemento di lavoro è stato attivato o riattivato. |
Microsoft.VSTS.Common.ActivatedDate |
DateTime |
Dimensione |
False |
Chiuso da |
Nome del membro del team che ha chiuso l'elemento di lavoro. |
Microsoft.VSTS.Common.ClosedBy |
Stringa |
Dimensione |
False |
Data di chiusura |
Data e ora di chiusura di un elemento di lavoro. |
Microsoft.VSTS.Common.ClosedDate |
DateTime |
Dimensione |
False |
Creato da |
Nome del membro del team che ha creato l'elemento di lavoro. |
Microsoft.VSTS.Common.CreatedBy |
Stringa |
Dimensione |
False |
Data creazione |
Data e ora di creazione di un elemento di lavoro. |
Microsoft.VSTS.Common.CreatedDate |
DateTime |
Dimensione |
False |
Risolto da |
Nome del membro del team che ha risolto il bug o la storia utente. |
Microsoft.VSTS.Common.ResolvedBy |
Stringa |
Dimensione |
False |
Data di risoluzione |
Data e ora di risoluzione del bug o della storia utente. |
Microsoft.VSTS.Common.ResolvedDate |
DateTime |
Dimensione |
False |
Data di modifica dello stato |
Data e ora di modifica del valore del campo Stato. |
Microsoft.VSTS.Common.StateChangeDate |
DateTime |
Nessuno |
False |
Vedere anche
Concetti
Pianificazione, classificazione e priorità
Utilizzo dei campi di sistema e dei campi definiti tramite i modelli di processo MSF
Individuazione di bug, attività e altri elementi di lavoro
Altre risorse
Elementi di lavoro e flusso di lavoro (Agile)
Definizione e personalizzazione del flusso di lavoro degli elementi di lavoro