Erreur « Champ obligatoire manquant » lors des importations historiques
Symptômes
Lorsque vous importez des données historiques à partir d’un fichier .csv dans Viva Glint, vous recevez un message d’erreur au format suivant :
Erreur à la ligne 2 : champ obligatoire manquant – [<utilisateur>, <réponses aux questions> de l’enquête]
Voici un exemple :
Erreur à la ligne 2 : champ requis manquant - [reed@contoso.com, 4, Nous avons une progression de carrière merveilleuse dans le organization., 4,, 3, Il y a de belles opportunités de promotion dans le organization. Ça me rend fier. Je suis vraiment excité par l’avenir ici. 4,, 3,, 5, Nous avons un travail d’équipe cool dans le organization., 5, Nous avons une reconnaissance fantastique dans mon équipe. , 2,, 4, Il y a un soutien énergisant., 4, Nous avons une structure de service dynamique. C’est vraiment important pour moi.,...]
Cause
Ce problème se produit car le fichier .csv importé dans Viva Glint n’est pas encodé correctement.
Résolution
Pour résoudre ce problème, procédez comme suit :
- Ouvrez le fichier .csv dans un éditeur de texte, tel que Notepad++ ou Sublime.
- Réenregistrez le fichier en encodage UTF-8. (N’enregistrez pas le fichier en UTF-8 avec l’encodage boM.)
- Réimportez le fichier.