Erreur « Champ obligatoire manquant » lors des importations historiques
Symptômes
Lorsque vous importez des données historiques à partir d’un fichier .csv dans Viva Glint, vous recevez un message d’erreur au format suivant :
Erreur à la ligne 2 : champ obligatoire manquant : [<utilisateur>, <réponses aux questions d’enquête>]
Voici un exemple :
Erreur à la ligne 2 : champ obligatoire manquant - [reed@contoso.com, 4, Nous avons une belle progression de carrière dans l’organisation., 4,3, Il existe des opportunités de promotion cool dans l’organisation. Ça me rend fier. Je suis vraiment excitée de l’avenir ici. 4,3,5, Nous avons un travail d’équipe cool dans l’organisation., 5, Nous avons une reconnaissance fantastique sur mon équipe. , 2,, 4, Il y a un support énergétique., 4, Nous avons une structure de service énergétique. C’est vraiment important pour moi.,...]
Cause
Ce problème se produit, car le fichier .csv importé dans Viva Glint ne contient pas l’un des champs requis pour votre fichier de score brut.
Résolution
Pour résoudre ce problème, procédez comme suit :
- Si le fichier de données a une extension .csv, utilisez l’Assistant Importation de texte pour importer les données dans Excel en conservant les données au format d’origine.
- Passez en revue les colonnes requises pour les fichiers de score brut d’importation historique.
- Mettez à jour les en-têtes de colonne et les colonnes pour qu’ils correspondent aux exigences.
- Enregistrez le fichier modifié en tant que .csv avec l’encodage UTF-8 (avec ou sans BOM), puis chargez à nouveau le fichier.