Partager via


Résoudre les problèmes liés aux produits

Suivez les instructions de cet article pour résoudre les problèmes que vous pouvez rencontrer lors de l’utilisation de produits dans Dynamics 365 Sales.

Problème 1 - Le réparentage ne fonctionne pas ou le champ Parent n’est pas visible

La réparentation de produit vous permet de modifier le parent d’un enregistrement de produit existant afin que les produits enfants héritent des propriétés de produit appropriées. Pour plus d’informations, consultez Modifier le parent d’un produit.

Cause

Si vous ne voyez pas le champ Parent sur le formulaire Produit, cela peut être dû au fait que vous avez personnalisé le formulaire Principal du produit à l’aide de la solution non managée. Pour en savoir plus, consultez Présentation des solutions.

Dans certains cas, les formulaires produit ne sont pas fusionnés correctement et, en raison de cela, le champ Parent requis n’est pas ajouté au formulaire.

Résolution

Pour résoudre ce problème, vous devez ajouter le champ Parent au formulaire. Vous pouvez le faire via la personnalisation ou à l’aide de l’Assistant Importation/exportation de solution. Pour plus d’informations, consultez Exporter des solutions et importer des solutions.

Pour ajouter le champ Parent via la personnalisation

  1. Dans votre application, sélectionnez l’icône Paramètres, puis sélectionnez Paramètres avancés.

    Option Paramètres avancés dans le menu Paramètres.

    La page Gestion d’entreprise s’ouvre.

  2. Sur la barre de navigation, sélectionnez Paramètres, puis sous Personnalisation, sélectionnez Personnalisations.

  3. Sélectionnez Personnaliser le système.

  4. Sous Composants dans Explorateur de solutions, développez Entités, puis développez la table Product.

  5. Sélectionnez Formulaires, puis ouvrez le formulaire Produit de type Main dans l’état Actif .

  6. Dans l’éditeur de formulaire, sélectionnez le champ Parent dans l’Explorateur de champs et faites-le glisser vers la section Résumé sur le côté gauche de l’éditeur de formulaire.

    Ajoutez le champ Parent au formulaire Produit.

  7. Sélectionnez Enregistrer, puis Publier.

Pour ajouter le champ Parent via l’Assistant Importation/Exportation de la solution

Dans la solution non managée, ajoutez la ligne suivante sous la forme principale du produit :

<row>
    <cell id="{faaa2942-4737-4721-9a19-7dcbf4eb2911}" showlabel="true" locklevel="0" colspan="2" solutionaction="Added">
        <control id="editableParentControl" classid="{270BD3DB-D9AF-4782-9025-509E298DEC0A}" datafieldname="parentproductid" disabled="false">
            <parameters>
                <DefaultViewId>{19d7f2e0-e427-40fb-85e8-53e7cef2b166}</DefaultViewId>
                <IsInlineNewEnabled>false</IsInlineNewEnabled>
                <DisableMru>true</DisableMru>
            </parameters>
        </control>
    </cell>
</row>

Problème 2 - Les champs Prix de liste, Coût standard ou Coût actuel ne respectent pas la valeur de précision de champ prise en charge décimale

Résolution

Il n’existe aucune relation entre le champ Decimal Supported et le champ List Price . La valeur définie dans le champ Pris en charge décimal n’affecte pas la valeur de précision du champ Prix de liste. La valeur de précision décimale du champ Prix de liste, Coût standard ou Coût actuel est contrôlée par le paramètre De précision décimale de tarification. Par défaut, « Précision décimale de tarification » est défini sur 2. Pour plus d’informations sur ce paramètre, consultez l’onglet Général des paramètres système. Pour plus d’informations sur la précision décimale, consultez Précision décimale dans la devise et la tarification.

Problème 3 : une erreur se produit lors de la définition du champ Quantité sur une valeur décimale dans l’enregistrement Commande Produit, Devis Produit, Facture Produit

Résolution

Le champ Option de vente de quantités de l’enregistrement de l’élément de liste de prix détermine si le produit ou le service peut être commandé en entier, partiel ou les deux types de quantités. Pour pouvoir entrer des valeurs décimales dans le champ Quantity , vérifiez que le champ Option de vente de quantité n’est pas défini sur Entier. Pour plus d’informations, consultez Définir la tarification des produits avec des listes de prix et des éléments de liste de prix.

Problème 4 : une erreur se produit lors de l’ouverture ou de l’enregistrement d’un enregistrement produit lorsque le champ Decimal Supported a la valeur > 2

Résolution

Si le champ Quantity On Hand est utilisé sur le formulaire, la valeur du champ Decimal Supported ne doit pas être supérieure à la précision de Quantity On Hand.

Pour résoudre ce problème, accédez à Paramètres>Personnalisations des champs Quantité des>champs>Entités>à la main. Vérifiez que la valeur de précision est identique à la valeur prise en charge décimale.