Une demande d’optimisation ne parvient pas à modifier certaines réservations
Cet article aide les administrateurs à résoudre les demandes d’optimisation dans le complément Optimisation de la planification des ressources pour Microsoft Dynamics 365 Field Service.
Symptômes
Une demande d’optimisation échoue avec le message d’erreur « Le système n’a pas pu modifier certaines réservations ».
Cause
La demande d’optimisation peut échouer dans les scénarios suivants :
- Un utilisateur met manuellement à jour une réservation lors d’une exécution d’optimisation de la planification des ressources. L’optimisation de la planification des ressources ne remplace pas les modifications.
- Un workflow ou un plug-in met à jour les mêmes réservations lors d’une exécution d’optimisation de la planification des ressources. L’optimisation de la planification des ressources ne remplace pas les modifications apportées par d’autres logiques système.
- Plusieurs planifications d’optimisation de la planification des ressources partagent les mêmes ressources et s’exécutent en même temps. Si les planifications incluent des ressources, des exigences et des réservations qui se chevauchent, une planification ultérieure est annulée avec un état bloqué.
Résolution
Pour l’analyse et la résolution des problèmes, consultez les options suivantes :
- Passez en revue la grille de réservation des demandes d’optimisation et examinez la colonne Détails de l’opération pour chaque exigence et réservation.
- Vérifiez si plusieurs planifications qui partagent les mêmes ressources, exigences et réservations s’exécutent en même temps. Si c’est le cas, mettez à jour les planifications pour qu’elles s’exécutent séquentiellement ou les reconfigurent pour éviter les chevauchements. Pour plus d’informations, consultez Résoudre les conflits de réservation dans l’optimisation de la planification des ressources.
- Vérifiez si un autre utilisateur ou workflow tente de mettre à jour une réservation pendant l’exécution de la demande d’optimisation.