Résoudre les problèmes de déploiement de fonctionnalités
Important
La fonctionnalité Suivi des modifications et inventaire avec l’agent Log Analytics a été mise hors service le 31 août 2024 et fonctionnera avec un support limité jusqu’au 1er février 2025. Nous vous recommandons d’utiliser Azure Monitoring Agent comme nouvel agent de prise en charge. Suivez les instructions de la migration du Suivi des modifications et inventaire en utilisant Log Analytics vers le Suivi des modifications et inventaire en tirant parti de l’agent Azure Monitor.
Vous pouvez recevoir des messages d’erreur lorsque vous déployez la fonctionnalité Update Management ou la fonctionnalité Change Tracking and Inventory d’Azure Automation sur vos machines virtuelles. Cet article décrit les erreurs qui pourraient se produire et explique comment les résoudre.
Problèmes connus
Scénario : le changement de nom d’un nœud inscrit nécessite une désinscription ou une nouvelle inscription
Problème
Un nœud est inscrit sur Azure Automation, puis le nom d’ordinateur du système d’exploitation est modifié. Les rapports du nœud continuent à s’afficher avec le nom d’origine.
Cause
La modification du nom d’un nœud inscrit n’a pas pour effet de modifier son nom dans Azure Automation.
Résolution
Annulez l’inscription du nœud dans le service State Configuration d’Azure Automation, puis réinscrivez-le. Les rapports publiés sur le service avant ce délai ne seront plus disponibles.
Scénario : la réinscrire des certificats via le proxy HTTPS n’est pas prise en charge
Problème
Quand vous vous connectez via un proxy qui met fin au trafic HTTPS, puis chiffre à nouveau le trafic à l’aide d’un nouveau certificat, le service n’autorise pas la connexion.
Cause
Azure Automation ne prend pas en charge la nouvelle signature de certificats utilisés pour chiffrer le trafic.
Résolution
Il n’existe actuellement aucun moyen de contourner ce problème.
Erreurs générales.
Scénario : Le déploiement de fonctionnalités échoue avec le message « Impossible d’activer la solution »
Problème
L’un des messages suivants s’affiche lorsque vous tentez d’activer une fonctionnalité sur une machine virtuelle :
The solution cannot be enabled due to missing permissions for the virtual machine or deployments
The solution cannot be enabled on this VM because the permission to read the workspace is missing
Cause
Cette erreur est due à des autorisations incorrectes ou manquantes sur la machine virtuelle ou dans l’espace de travail, ou bien pour l'utilisateur.
Résolution
Vérifiez que vous disposez des autorisations de déploiement de fonctionnalité nécessaires, puis réessayez de déployer la fonctionnalité. Si vous recevez le message d’erreur The solution cannot be enabled on this VM because the permission to read the workspace is missing
, consultez les informations de dépannage suivantes.
Scénario : Le déploiement de fonctionnalités échoue avec le message « Échec de la configuration du compte Automation pour la journalisation des diagnostics »
Problème
Le message suivant s’affiche lorsque vous tentez d’activer une fonctionnalité sur une machine virtuelle :
Failed to configure automation account for diagnostic logging
Cause
Cette erreur peut survenir si le niveau tarifaire ne correspond pas au modèle de facturation de l’abonnement. Pour plus d’informations, consultez Surveiller l’utilisation et l’estimation des coûts dans Azure Monitor.
Résolution
Créez votre espace de travail Log Analytics manuellement, puis répétez la procédure de déploiement de fonctionnalité pour sélectionner l’espace de travail créé.
Scénario : ComputerGroupQueryFormatError
Problème
Ce code d’erreur signifie que la requête de recherche de groupe d’ordinateurs enregistrée utilisée pour cibler la fonctionnalité n’est pas au bon format.
Cause
Vous avez peut-être modifié la requête, ou le système l’a peut-être modifiée.
Résolution
Vous pouvez supprimer la requête pour cette fonctionnalité, puis réactiver la fonctionnalité, ce qui aura pour effet de recréer la requête. La requête se trouve dans votre espace de travail, sous Recherches enregistrées. Le nom de la requête est MicrosoftDefaultComputerGroup, et la catégorie de la requête est le nom de la fonctionnalité associée. Si plusieurs fonctionnalités sont activées, la requête MicrosoftDefaultComputerGroup s’affiche plusieurs fois sous Recherches enregistrées.
Scénario : PolicyViolation
Problème
Ce code d’erreur indique que le déploiement a échoué en raison d’une violation d’une ou de plusieurs affectations d’Azure Policy.
Cause
Une affectation d’Azure Policy empêche l’opération de se terminer.
Résolution
Pour déployer correctement la fonctionnalité, vous devez envisager de modifier la définition de la stratégie indiquée. Étant donné qu’il existe plusieurs types de définitions de stratégie pouvant être définis, les modifications requises dépendent de la définition de stratégie enfreinte. Par exemple, si une définition de stratégie est affectée à un groupe de ressources qui refuse l’autorisation de modifier le contenu de certaines ressources contenues, vous pouvez choisir l’un de ces correctifs :
- Supprimez l’affectation de stratégie tout entière.
- Essayez d’activer la fonctionnalité pour un autre groupe de ressources.
- Ciblez de nouveau l’affectation de stratégie sur une ressource spécifique, par exemple un compte Automation.
- Révisez l’ensemble de ressources que la définition de stratégie doit refuser.
Consultez les notifications dans l’angle supérieur droit du portail Azure, ou accédez au groupe de ressources comportant votre compte Automation, puis sélectionnez Déploiements sous Paramètres pour afficher le déploiement en échec. Pour en savoir plus sur Azure Policy, consultez Présentation d’Azure Policy.
Scénario : Erreurs lors de la tentative de dissociation d’un espace de travail
Problème
Vous recevez le message d’erreur suivant lorsque vous tentez de dissocier un espace de travail :
The link cannot be updated or deleted because it is linked to Update Management and/or ChangeTracking Solutions.
Cause
Cette erreur se produit lorsque des fonctionnalités de votre espace de travail Log Analytics qui dépendent de votre compte Automation et de l’espace de travail Log Analytics associé sont toujours actives.
Résolution
Dans votre espace de travail, supprimez les ressources des fonctionnalités suivantes, si vous les utilisez :
- Update Management
- Suivi des modifications et inventaire
- Démarrer/arrêter des machines virtuelles pendant les heures creuses
Une fois les ressources des fonctionnalités supprimées, vous pouvez dissocier votre espace de travail. Il est important de supprimer tous les artefacts existants de ces fonctionnalités dans votre espace de travail et votre compte Automation :
- Pour Update Management, supprimez les déploiements de mises à jour (planifications) de votre compte Automation.
- Pour « Start/Stop VMs during off-hours », supprimez tous les verrous des composants de la fonctionnalité dans votre compte Automation sous Paramètres>Verrous. Pour plus d’informations, consultez Supprimer la fonctionnalité.
Log Analytics pour les échecs de l’extension Windows
Remarque
Dans le cadre de la transition en cours entre Microsoft Operations Management Suite et Azure Monitor, l’agent Operations Management Suite pour Windows ou Linux sera appelé l’agent Log Analytics pour Windows et l’agent Log Analytics pour Linux.
Une installation de l’agent Log Analytics pour l’extension Windows peut échouer pour diverses raisons. La section suivante décrit les problèmes de déploiement de fonctionnalité qui peuvent provoquer des échecs lors du déploiement de l’agent Log Analytics pour l’extension Windows.
Remarque
L’agent Log Analytics pour Windows est le nom utilisé actuellement dans Azure Automation pour l’agent Microsoft Monitoring Agent (MMA).
Scénario : Une exception s’est produite lors d’une requête WebClient
Log Analytics pour l’extension Windows de la machine virtuelle ne peut pas communiquer avec les ressources externes, et le déploiement échoue.
Problème
Voici quelques exemples des messages d’erreur qui peuvent s’afficher :
Please verify the VM has a running VM agent, and can establish outbound connections to Azure storage.
'Manifest download error from https://<endpoint>/<endpointId>/Microsoft.EnterpriseCloud.Monitoring_MicrosoftMonitoringAgent_australiaeast_manifest.xml. Error: UnknownError. An exception occurred during a WebClient request.
Cause
Voici des causes possibles de cette erreur :
- Un proxy configuré dans la machine virtuelle autorise uniquement certains ports.
- Un paramètre du pare-feu a bloqué l’accès aux adresses et aux ports nécessaires.
Résolution
Vérifiez que les bons ports et adresses sont ouverts à la communication. Pour obtenir la liste des ports et adresses, consultez Planification de votre réseau.
Scénario : Échec de l’installation en raison de problèmes d’environnement temporaires
L’installation de l’extension Log Analytics pour Windows a échoué pendant le déploiement, car une autre installation ou action bloque l’installation.
Problème
Voici quelques exemples des messages d’erreur qui peuvent s’afficher :
The Microsoft Monitoring Agent failed to install on this machine. Please try to uninstall and reinstall the extension. If the issue persists, please contact support.
'Install failed for plugin (name: Microsoft.EnterpriseCloud.Monitoring.MicrosoftMonitoringAgent, version 1.0.11081.4) with exception Command C:\Packages\Plugins\Microsoft.EnterpriseCloud.Monitoring.MicrosoftMonitoringAgent\1.0.11081.4\MMAExtensionInstall.exe of Microsoft.EnterpriseCloud.Monitoring.MicrosoftMonitoringAgent has exited with Exit code: 1618'
'Install failed for plugin (name: Microsoft.EnterpriseCloud.Monitoring.MicrosoftMonitoringAgent, version 1.0.11081.2) with exception Command C:\Packages\Plugins\Microsoft.EnterpriseCloud.Monitoring.MicrosoftMonitoringAgent\1.0.11081.2\MMAExtensionInstall.exe of Microsoft.EnterpriseCloud.Monitoring.MicrosoftMonitoringAgent has exited with Exit code: 1601'
Cause
Voici des causes possibles de cette erreur :
- Une autre installation est en cours d’exécution.
- Le redémarrage du système est déclenché pendant le déploiement du modèle.
Résolution
Cette erreur est temporaire par nature. Recommencez le déploiement pour installer l’extension.
Scénario: Expiration du délai d’installation
L’installation de l’extension Log Analytics pour Windows n’a pas pu se terminer, car le délai d’attente a expiré.
Problème
Voici un exemple de message d’erreur qui pourrait s’afficher :
Install failed for plugin (name: Microsoft.EnterpriseCloud.Monitoring.MicrosoftMonitoringAgent, version 1.0.11081.4) with exception Command C:\Packages\Plugins\Microsoft.EnterpriseCloud.Monitoring.MicrosoftMonitoringAgent\1.0.11081.4\MMAExtensionInstall.exe of Microsoft.EnterpriseCloud.Monitoring.MicrosoftMonitoringAgent has exited with Exit code: 15614
Cause
Ce type d’erreur se produit car la machine virtuelle est surchargée pendant l’installation.
Résolution
Essayez d’installer l’agent Log Analytics pour l’extension Windows quand la machine virtuelle est moins sollicitée.
Étapes suivantes
Si votre problème ne figure pas ici ou que vous ne pouvez pas le résoudre, utilisez un des canaux suivants pour obtenir une aide supplémentaire :
- Obtenez des réponses de la part d’experts Azure via les Forums Azure.
- Connectez-vous à @AzureSupport, le compte Microsoft Azure officiel pour améliorer l’expérience client. Le Support Azure fournit à la communauté Azure des réponses, un support technique et des experts.
- Signaler un incident au support Azure Accédez au site du support Azure, puis sélectionnez Obtenir de l’aide.