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Se produce un error en Sysprep después de quitar o actualizar aplicaciones de Microsoft Store que incluyen imágenes de Windows integradas

En este artículo se describe un problema que se produce al quitar o actualizar una aplicación de Microsoft Store aprovisionada mediante Microsoft Store y, a continuación, ejecutar sysprep en el equipo.

Se aplica a: Windows 10: todas las ediciones, Windows 11
Número de KB original: 2769827

Introducción

Sysprep es una herramienta para los administradores de TI que desean preparar una instalación de Windows para la duplicación, la auditoría y la entrega de clientes. Las instrucciones de este artículo están pensadas para su uso por parte de agentes de soporte técnico y profesionales de TI. Si eres un usuario principal que encuentra problemas al usar aplicaciones de Microsoft Store, consulta Corregir problemas con aplicaciones de Microsoft Store.

Varias aplicaciones de Microsoft Store están integradas en imágenes de Windows. Estas aplicaciones incluyen las aplicaciones Mail, Maps, Messaging, Bing, Travel y News, entre otras. Estas aplicaciones se conocen como aplicaciones aprovisionadas . Las aplicaciones aprovisionadas se almacenan provisionalmente en la imagen y están programadas para instalarse para cada usuario de la imagen de Windows al iniciar sesión. Además de las aplicaciones integradas, puedes cargar localmente tus propias aplicaciones de línea de negocio de Microsoft Store en la imagen de Windows sin tener que publicarlas en Microsoft Store. Puede cargar Appx paquetes en paralelo mediante comandos de mantenimiento en línea o sin conexión que están disponibles en DISM.exe o a través del módulo dism de PowerShell.

Síntomas

Considere los casos siguientes:

Escenario 1

  • Va a crear un equipo de referencia personalizado de Windows 10 o Windows 11 que quiera capturar y sysprep.
  • Quiere quitar algunas de las aplicaciones de Microsoft Store (Appx paquetes) aprovisionadas de este equipo de referencia.
  • Se ejecuta dism -online /Remove-ProvisionedAppxPackage /PackageName:<packagename> para desaprovisionar los Appx paquetes.

Al ejecutar la operación sysprep en este escenario, la operación puede producir el siguiente error:

Herramienta de preparación del sistema 3.14
Error irrecuperable al intentar sysprep la máquina

Escenario 2

  • Tiene una imagen de Windows existente y varias aplicaciones de Microsoft Store se cargan en paralelo en la imagen.
  • Quiere quitar algunos de los paquetes cargados localmente Appx de la imagen y personalizarlos más.
  • Inicie en el equipo de referencia y ejecute uno de los siguientes comandos de PowerShell para quitar el aprovisionamiento del Appx paquete:
    • Remove-AppxProvisionedPackage -PackageName <packagename>
    • Remove-ProvisionedAppxPackage -PackageName <packagename>

Al ejecutar la operación sysprep en este escenario, la operación puede producir el siguiente error:

Herramienta de preparación del sistema 3.14
Error irrecuperable al intentar sysprep la máquina

Escenario 3

  • Está creando una imagen de referencia de Windows 10 o Windows 11.
  • Se conecta a Microsoft Store y, a continuación, actualiza las aplicaciones integradas de Microsoft Store mediante Microsoft Store.

Al ejecutar la operación sysprep en este escenario, la operación puede producir el siguiente error:

Herramienta de preparación del sistema 3.14 Se produjo un error irrecuperable al intentar sysprep la máquina

Además, en el SetupErr.log, puede observar las siguientes entradas de error:

<Fecha><y hora>, Error SYSPRP PackageFullName> <se instaló para un usuario, pero no se aprovisionó para todos los usuarios. Este paquete no funcionará correctamente en la imagen sysprep.
<Fecha><y hora>, error SYSPRP No se pudieron quitar las aplicaciones del usuario actual: 0x80073cf2.
<Fecha><y hora>, error SYSPRP Código de salida del subproceso RemoveAllApps se 0x3cf2.
<Fecha><y hora>, error [0x0f0082] Acción SYSPRPPlatform::LaunchModule: Error al ejecutar "SysprepGeneralize" desde C:\Windows\System32\AppxSysprep.dll; dwRet = 0x3cf2
<Fecha><y hora>, Error ACCIÓN SYSPRPPlatform::ExecuteAction: Error al ejecutar la acción; dwRet = 0x3cf2
<Fecha><y hora>, Error SYSPRP ActionPlatform::ExecuteActionList: Error en acciones de ejecución; dwRet = 0x3cf2
<Fecha><y hora>, error SYSPRP SysprepSession::Execute: Error al ejecutar acciones desde C:\Windows\System32\Sysprep\ActionFiles\Generalize.xml; dwRet = 0x3cf2
<Fecha><y hora>, error SYSPRP RunPlatformActions:Failed al ejecutar acciones de SysprepSession; dwRet = 0x3cf2
<Fecha><y hora>, error [0x0f0070] SYSPRP RunExternalDlls:Se produjo un error al ejecutar archivos DLL de sysprep del registro, lo que detiene la ejecución de sysprep. dwRet = 0x3cf2
<Date><Time>, Error [0x0f00a8] SYSPRP WinMain:Hit failure while processing sysprep generalize internal providers; hr = 0x80073cf2

Causa

Sysprep tiene un proveedor adicional que se agrega en Windows para limpiar Appx paquetes y generalizar la imagen. El proveedor solo funciona si el Appx paquete es un paquete por usuario o un paquete aprovisionado por usuario.

  • El paquete por usuario significa que el Appx paquete está instalado para una cuenta de usuario determinada y no está disponible para otros usuarios del equipo.
  • Todo el paquete de usuario significa que Appx se ha aprovisionado en la imagen para que todos los usuarios que usen esta imagen puedan acceder a la aplicación.

Si un paquete de todos los usuarios que se aprovisiona en la imagen se desaprovisionó manualmente de la imagen, pero no se quitó para un usuario determinado, el proveedor encontrará un error al limpiar este paquete durante sysprep. El proveedor también producirá un error si uno de los usuarios actualizó un paquete de todos los usuarios aprovisionados en la imagen en este equipo de referencia.

Solución

Para resolver este problema, quite el paquete para el usuario que ejecuta sysprep y también quite el aprovisionamiento. Para hacerlo, siga estos pasos.

Nota:

Para evitar que Microsoft Store actualice las aplicaciones, desconecte la conexión a Internet o deshabilite Las actualizaciones automáticas en modo auditoría antes de crear la imagen.

  1. Ejecute los siguientes cmdlets de PowerShell:

    Import-Module Appx
    Import-Module Dism
    Get-AppxPackage -AllUsers | Where PublisherId -eq 8wekyb3d8bbwe | Format-List -Property PackageFullName,PackageUserInformation
    

Nota:

  • En la salida de este último cmdlet, compruebe los usuarios para los que el paquete aparece como Instalado. Elimine estas cuentas de usuario del equipo de referencia o inicie sesión en el equipo mediante estas cuentas de usuario. A continuación, ejecute el cmdlet en el paso 2 para quitar el Appx paquete.
  • Este comando enumera todos los paquetes publicados por Microsoft e instalados por cualquier usuario de ese equipo de referencia. Dado que el equipo debe estar en desuso, se supone que estos perfiles de usuario ya no requieren el paquete.
  • Si ha aprovisionado manualmente aplicaciones que pertenecen a otros publicadores, ejecute el siguiente comando para enumerarlos:

Get-AppxPackage -AllUsers | Format-List -Property PackageFullName,PackageUserInformation

  1. Quite Appx el paquete mediante la ejecución del cmdlet siguiente:

    Remove-AppxPackage -Package <packagefullname>
    
  2. Quite el aprovisionamiento mediante la ejecución del siguiente cmdlet:

    Remove-AppxProvisionedPackage -Online -PackageName <packagefullname>
    

Si intenta recuperarse de un problema de actualización, puede volver a aprovisionar la aplicación después de seguir estos pasos.

Nota:

El problema no se produce si está atendiendo una imagen sin conexión. En ese escenario, el aprovisionamiento se borra automáticamente para todos los usuarios. Esto incluye al usuario que ejecuta el comando.

Más información

Para obtener más información sobre cómo agregar y quitar aplicaciones, consulte:

Recolección de datos

Si necesita ayuda del soporte técnico de Microsoft, le recomendamos que recopile la información siguiendo los pasos mencionados en Recopilación de información mediante TSS para problemas relacionados con la implementación.