"Windows no pudo analizar ni procesar el archivo de respuesta desatendida para el paso [especial]" mensaje de error al realizar una actualización local
En este artículo se proporciona ayuda para corregir un error (Windows no pudo analizar ni procesar el archivo de respuesta desatendida para el paso [especial]) que se produce cuando se realiza una actualización local.
Se aplica a: Windows 7 Service Pack 1, Windows Server 2012 R2
Número de KB original: 2425962
Síntomas
Considere el caso siguiente:
- Está ejecutando una versión de Windows 7 o de Windows Server 2008 R2 que se instaló mediante un archivo Unattend.xml.
- Inicie el equipo desde esta imagen y, a continuación, seleccione la opción Reparar actualización local (sobrescribir la instalación).
- Inicie la actualización local.
En este escenario, recibirá el siguiente mensaje de error: Windows no pudo analizar ni procesar el archivo de respuesta desatendido para el pase [especial].
Por lo general, los archivos de Unattend.xml se usan para la implementación del entorno oem o corporativo. Por lo tanto, la imagen podría contener un archivo Unattend.xml y es posible que no tenga en cuenta que este archivo está incluido.
Causa
Este problema se produce porque el archivo Unattend.xml se aplica durante la actualización local. No se admite este escenario.
Más información
Importante
Esta sección, método o tarea contiene pasos que le indican cómo modificar el Registro. No obstante, pueden producirse problemas graves si modifica el registro de manera incorrecta. Por lo tanto, asegúrese de que sigue estos pasos con atención. Para la protección añadida, realice una copia de seguridad del Registro antes de modificarlo. A continuación, puede restaurar el Registro si se produce un problema. Para obtener más información sobre cómo realizar copias de seguridad y restaurar el registro, haga clic en el siguiente número de artículo para ver el artículo de Microsoft Knowledge Base: 322756 Cómo realizar copias de seguridad y restaurar el registro en Windows.
Cuando se produce este comportamiento, no se puede recuperar el sistema. Por lo tanto, debe realizar una instalación limpia.
Para evitar este comportamiento, puede quitar una subclave del Registro antes de usar la imagen de instalación de OEM para ejecutar una actualización local. Para ello, siga estos pasos:
- Inicie sesión en el equipo mediante una cuenta de usuario que tenga permisos administrativos.
- Haga clic en Inicio, escriba regedit en el cuadro de búsqueda Inicioy, a continuación, en la lista Programas, haga clic en regedit.exe.
- Busque y haga clic con el botón derecho en la siguiente subclave del Registro: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer\UnattendBackup\ActiveSetup\FavoritesList\Favorite<XX>
Nota:
En esta subclave, <XX> es un marcador de posición para los números que comienzan por 1.
- Haga clic en Eliminar, haga clic en Sí y, a continuación, salga del Editor del Registro.
Estado
Este comportamiento es por diseño.
Recolección de datos
Si necesita ayuda del soporte técnico de Microsoft, le recomendamos que recopile la información siguiendo los pasos mencionados en Recopilación de información mediante TSS para problemas relacionados con la implementación.