Solución de problemas con la calificación de cliente potencial para administradores del sistema
Problema 1: Error de permisos insuficientes o acceso denegado cuando un usuario intenta calificar un cliente potencial
La forma de resolver este error depende de los siguientes escenarios de propiedad para los registros de cliente potencial.
Escenario de propiedad | Pasos de resolución |
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El cliente potencial es propiedad del usuario que intenta calificarlo. |
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El cliente potencial que el usuario intenta calificar está en su unidad de negocio. |
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El cliente potencial que el usuario está intentando calificar está en su organización. |
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Durante la calificación de un cliente potencial, los registros que se crean (opcionalmente) son: Oportunidad, Contacto y Cuenta. Para obtener más información, consulte Calificar o convertir clientes potenciales.
Si el usuario recibe errores relacionados con privilegios incluso después de asignar los privilegios adecuados como se mencionó anteriormente en esta sección, es posible que falten privilegios en algunas entidades a las que se accede durante la creación de la cuenta, el contacto o los registros de oportunidades. Por ejemplo, el usuario podría faltar privilegios en algunas entidades personalizadas a las que se accede cuando algunos complementos o flujos de trabajo se ejecutan en alguna operación de la cuenta, el contacto o las entidades de oportunidad.
Para solucionar este problema, siga estos pasos:
Aísle el problema a la creación de un registro de oportunidad, cuenta o contacto: pida al usuario que intente crear registros individuales de cuenta, contacto y oportunidad y vea si obtiene el mismo problema relacionado con los privilegios al crear estos registros. Pueden tener problemas de privilegios en uno o varios tipos de registros, por lo que es importante realizar este paso para cada tipo de registro. Por ejemplo, es posible que no tengan privilegios adecuados en las entidades Cuenta y Contacto.
Identifique si algún complemento o flujo de trabajo registrado al crear la entidad está causando problemas: después de aislar el problema para crear un registro de entidad determinado, compruebe si algún complemento o flujo de trabajo que se ejecuta al crear estos registros de entidad tiene acceso a otras entidades en las que faltan privilegios al usuario actual. Para ello, averigüe todos los complementos o flujos de trabajo registrados en la creación de registros de entidad y desactive uno por uno para identificar el complemento o el flujo de trabajo que causa el problema. Una vez que identifique el complemento o el flujo de trabajo que causa el problema, desactive para desbloquear el proceso de creación de registros. Para obtener más información sobre cómo identificar todos los flujos de trabajo registrados para una entidad, consulte Desactivación del proceso de flujo de trabajo personalizado.
Para obtener más información sobre cómo identificar complementos registrados en la creación de un registro de entidad, consulte Desactivación de un complemento personalizado.
Problema 2: el comando "Calificar cliente potencial" no está disponible en el registro de cliente potencial
Causa
El comando de cliente potencial apto listo para usar solo está visible en el formulario cliente potencial si las entidades Account, Contact, Lead y Opportunity se establecen como editables en Unified Interface y las entidades Account, Contact y Opportunity están disponibles en Mobile offline.
Solución
Si el comando Calificar cliente potencial no está disponible, compruebe lo siguiente:
- Las entidades Account, Contact, Lead o Opportunity se establecen en solo lectura para dispositivos móviles. Si son, desactive la casilla Solo lectura en dispositivos móviles en la personalización de entidades para que la entidad se pueda editar para la interfaz unificada. Para obtener más información, consulte Solución de problemas con la interfaz unificada.
- Compruebe si las entidades Cuenta, Contacto y Oportunidad forman parte del perfil móvil sin conexión. Si no lo son, agregue estas entidades al perfil y publique los cambios. Para obtener más información, consulte Habilitación de entidades para la sincronización sin conexión móvil.