Solución de problemas con correos electrónicos
Este artículo le ayuda a solucionar problemas relacionados con los correos electrónicos de Dynamics 365 Sales.
Problema 1: El editor de correo electrónico muestra un título incorrecto en la ventana emergente del correo electrónico contextual
Después de actualizar a dynamics 365 2020 release wave 2, el editor de correo electrónico muestra un título incorrecto en la ventana emergente del correo electrónico contextual.
Causa
Para formularios de correo electrónico de fábrica, los onload
eventos y onchange
se desencadenan que ayudan a actualizar el título del correo electrónico y otros atributos en el menú emergente de correo electrónico contextual. Si tiene un formulario de correo electrónico personalizado o un formulario de capa no administrada, los onload
eventos y onchange
no estarán disponibles. Por lo tanto, el título del correo electrónico se muestra incorrectamente.
Solución
Para resolver este problema, debe agregar los onload
eventos y onchange
a los formularios de correo electrónico personalizados.
Agregue el formulario de correo electrónico personalizado a la solución recién creada.
Agregue el código siguiente en el XML del formulario:
<events> <event name="onload" application="true" active="true"> <InternalHandlers> <Handler functionName="Activities.Email.formOnload" libraryName="Activities/SystemLibraries/Email_main_system_library.js" handlerUniqueId="ecdfe4d8-d6d3-4d21-ab68-8ea75bb30a79" enabled="true" parameters="" passExecutionContext="true" /> <Handler functionName="Activities.Email.NotifyPanelSubjectChange" libraryName="Activities/SystemLibraries/Email_main_system_library.js" handlerUniqueId="{706607A8-4424-4C9A-847A-602FC8035B48}" enabled="true" parameters="" passExecutionContext="true" solutionaction="Added"/> </InternalHandlers> </event> <event name="onchange" application="true" active="true" attribute="subject" solutionaction="Added"> <Handlers> <Handler functionName="Activities.Email.NotifyPanelSubjectChange" libraryName="Activities/SystemLibraries/Email_main_system_library.js" handlerUniqueId="{706607A8-4424-4C9A-847A-602FC8035B48}" enabled="true" parameters="" passExecutionContext="true"/> </Handlers> </event> </events> <clientresources> <internalresources> <clientincludes> <internaljscriptfile src="$webresource:Activities/SystemLibraries/Email_main_system_library.js" /> </clientincludes> </internalresources> </clientresources>
Problema 2: No se pueden ver los correos electrónicos y reuniones sin realizar seguimiento en la captura automática
La captura automática no muestra correos electrónicos y reuniones sin seguimiento para algunos o todos los usuarios de una organización.
Causa
A partir de la versión 9.2.24031.00102, Dynamics 365 Sales sigue el principio de acceso con privilegios mínimos, lo que impide que los usuarios que tengan directivas de acceso condicional en sus inquilinos accedan a correos electrónicos y reuniones sin seguimiento.
Si un usuario no puede ver los correos electrónicos y reuniones sin seguimiento, realice los pasos siguientes para comprobar si el problema se debe a una directiva de acceso condicional.
Inicie sesión en el Centro de administración de Microsoft Entra como al menos un administrador de acceso condicional.
Vaya a Registros de inicio de sesión de supervisión de identidades>y estado.>
Cambie a la pestaña Inicios de sesión de usuario (no interactivos) y agregue los filtros siguientes:
- La aplicación contiene Dataverse
- El recurso contiene Microsoft Graph
- El estado es igual a Error
Si se devuelven algunos resultados para los usuarios afectados, el problema se debe a una directiva de acceso condicional.
Solución alternativa
No hay ninguna resolución disponible para este problema, ya que es el comportamiento esperado. Como alternativa, los usuarios pueden usar Microsoft Copilot for Sales en Outlook para registrar actividades individuales o usar la sincronización del lado servidor para realizar un seguimiento automático de todos los correos electrónicos y reuniones.