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Error 400 o 401 al establecer la visibilidad de la tabla virtual de Dataverse

Código de error: SYS81183

En este artículo se describen los códigos de error (400 y 401) que pueden producirse al establecer la visibilidad de la tabla virtual de Microsoft Dataverse para el servicio de cálculo fiscal en un entorno del Servicio de configuración normativa (RCS). También se explica qué causa los problemas y cómo corregirlos.

Nota:

Este artículo es aplicable a la versión 10.0.38 o anterior.

Error 400 con "InternalServerError"

Síntomas

Al establecer la visibilidad de la tabla virtual o realizar la búsqueda de datos maestros en la configuración de la característica fiscal, recibirá el siguiente mensaje de error:

Error en la conexión a Microsoft Dataverse. Detalles: El servidor remoto devolvió un error: (400) Solicitud incorrecta. 0x80048d0b: se obtuvo un token para llamar a Finance and Operations, pero Finance and Operations devolvió un error de tipo InternalServerError.

Causa

Este problema se produce si el servicio de finanzas y operaciones está inactivo o si la dirección URL de destino de finanzas y operaciones está establecida incorrectamente.

Solución

  1. Confirme que puede iniciar sesión en aplicaciones de finanzas y operaciones con la misma cuenta que usa para iniciar sesión en Dataverse.
  2. Vaya a Configuración avanzada de>Dataverse>Administración>de orígenes de datos de entidad virtual y seleccione el origen de datos denominado finanzas y operaciones.
  3. Confirme que la dirección URL de destino se puede abrir directamente en el explorador. Para obtener más información, consulte Configurar el origen de datos de entidades virtuales.

Error 400 con "No se pudo resolver el nombre remoto"

Síntomas

Al establecer la visibilidad de la tabla virtual o realizar la búsqueda de datos maestros en la configuración de la característica fiscal, recibirá el siguiente mensaje de error:

Error en la conexión a Microsoft Dataverse. Detalles: El servidor remoto devolvió un error: (400) Solicitud incorrecta. 0x80040224: TokenProvider.AcquireTokenAsync(Clientld '{ApplicationId}', Authority '{IncorrectURL}', Recurso '00000015-0000-0000-c0000-0000000000'): excepción no controlada: Microsoft.IdentityModel.Clients.ActiveDirectory.AdalServiceException: Error devuelto por el servicio. Consulte InnerException para obtener más detalles ---> System.Net.WebException: No se pudo resolver el nombre remoto: ...

Causa

Este problema se produce si la dirección URL de open Authorization (OAuth) o el identificador de inquilino son incorrectos. Para obtener más información, consulte Configurar el origen de datos de entidades virtuales.

Solución

  1. Vaya a Configuración avanzada de>Dataverse>Administración>de orígenes de datos de entidad virtual y seleccione el origen de datos denominado finanzas y operaciones.

  2. Confirme que la dirección URL de OAuth y el identificador de inquilino son correctos. Para obtener más información, consulte Configurar el origen de datos de entidades virtuales.

    • La dirección URL de OAuth es un valor codificado de forma rígida: https://login.windows.net/.
    • Para buscar el identificador de inquilino correcto, inicie sesión en Azure Portal con la misma cuenta que usa para iniciar sesión en Dataverse y RCS. Seleccione Microsoft Entra ID y, a continuación, seleccione la instancia de Microsoft Entra ID. El identificador de inquilino o el dominio principal aparecen en el campo Inquilino .

Error 400 con "Aplicación con identificador {ApplicationId} no encontrado"

Síntomas

Al establecer la visibilidad de la tabla virtual o realizar la búsqueda de datos maestros en la configuración de la característica fiscal, recibirá el siguiente mensaje de error:

Error en la conexión a Microsoft Dataverse. Detalles: El servidor remoto devolvió un error: (400) Solicitud incorrecta. 0x80040224: TokenProvider.AcquireTokenAsync(Clientid '{IncorrectApplicationId}', Authority '<https://login.windows.net/microsoft.com>', Resource '00000015-0000-0000-c0000-00000000000'): excepción no controlada: Microsoft.IdentityModel.Clients.ActiveDirectory.AdalServiceException: AADSTS700016: Application with identifier '{IncorrectApplicationId}' no se encontró en el directorio 'Microsoft'. Esto puede pasar si el administrador del inquilino no es el que ha instalado el administrador del inquilino o no ha recibido el consentimiento de ningún usuario del inquilino. Es posible que haya enviado la solicitud de autenticación al inquilino incorrecto.

Causa

Este problema se produce si el identificador de aplicación es incorrecto. Para obtener más información, consulte Configurar el origen de datos de entidades virtuales.

Solución

  1. Vaya a Configuración avanzada de>Dataverse>Administración>de orígenes de datos de entidad virtual y seleccione el origen de datos denominado finanzas y operaciones.
  2. Confirme que el identificador de aplicación es correcto. Para obtener más información, consulte Configurar el origen de datos de entidades virtuales.

Debe obtener el identificador de aplicación durante el paso Registrar la aplicación en Azure Portal . Asegúrese de que escribió el identificador de aplicación correcto.

Error 401

Síntomas

Al establecer la visibilidad de la tabla virtual, realice la búsqueda de datos maestros en la configuración de la característica fiscal o realice la validación de asignación de modelos, recibirá uno de los siguientes mensajes de error:

Error en la conexión a Microsoft Dataverse. Detalles: el servidor remoto devolvió un error: (401) No autorizado.

Error de conexión de entidad de almacenamiento de entidades de almacenamiento filtradas a Microsoft Dataverse. Detalles: el servidor remoto devolvió un error: (401) No autorizado.

Causa

El error 401 "No autorizado" se produce si el proceso "Comprobar conexión" para las aplicaciones conectadas en RCS no es correcto o si el proceso "Comprobar conexión" no se ejecuta después de que se realicen cambios en la configuración de las aplicaciones conectadas en RCS.

Nota:

La cuenta que se usa para iniciar sesión en RCS también debe poder iniciar sesión en la instancia de Dataverse.

Solución

  1. En el entorno rcs, vaya a Registro de aplicaciones>conectadas de informes>electrónicos de aplicaciones conectadas a Dataverse.
  2. El campo Aplicación muestra la dirección URL de la instancia de base de datos. Confirme que puede iniciar sesión en esa instancia de Dataverse con la misma cuenta que usa para iniciar sesión en el entorno de RCS.
  3. Confirme que el campo Inquilino está establecido en el identificador de inquilino de la cuenta (por ejemplo, d335a570-a05b-4bc5-8eb3-c42c65f9560d) o la dirección URL del inquilino (por ejemplo, taxserviceint.onmicrosoft.com).
  4. Seleccione Comprobar conexión. El proceso debe realizarse correctamente.

Importante

Si el proceso "Comprobar conexión" no se realiza correctamente, la configuración de Dataverse no es correcta. Consulte Habilitación de la búsqueda de datos maestros para la configuración del cálculo fiscal y asegúrese de que los pasos 1, 2 y 3 se realizan correctamente.