La aplicación móvil de Field Service no se puede iniciar debido a problemas de permisos o privilegios
En este artículo se proporciona una resolución para el error "El usuario principal no tiene privilegios" que se produce cuando no se puede iniciar la aplicación móvil de Field Service.
Síntomas
La aplicación móvil dynamics 365 Field Service no se inicia con el siguiente error:
El usuario principal (Id=<GUID>, ...) falta el privilegio "prvReadmsdyn_Mobile" (Id=<GUID>) en OTC=<INT> para la entidad "msdyn_mobilesource" ...
Causa
La nueva experiencia de usuario en la aplicación móvil dynamics 365 Field Service requiere ciertos privilegios en los roles de seguridad de los usuarios.
Solución
El sistema agrega automáticamente los privilegios necesarios a todos los roles de seguridad predeterminados. Sin embargo, si su organización usa roles de seguridad personalizados, debe editar los roles de seguridad para agregar los siguientes privilegios de tabla:
- Nombre=
"msdyn_richtextfile"
Permiso="Crear" Valor="Usuario" - Nombre=
"msdyn_richtextfile"
Permiso="Eliminar" Valor="Usuario" - Nombre=
"msdyn_richtextfile"
Permiso="Leer" Valor="Usuario" - Nombre=
"msdyn_richtextfile"
Permiso="Escribir" Valor="Usuario" - Nombre=
"msdyn_MobileSource"
Permiso="Leer" Valor="Organización" - Nombre=
"msdyn_solutioncomponentsummary"
Permiso="Leer" Valor="Organización" - Nombre=
"SettingDefinition"
Permiso="Leer" Valor="Organización" - Nombre=
"Solution"
Permiso="Leer" Valor="Organización" - Nombre=
"SettingDefinition"
Permiso="Leer" Valor="Organización"
Sugerencia
Si no conoce el nombre del rol de seguridad personalizado, expanda Usuarios y permisos, seleccione Usuarios y busque el usuario que recibe el mensaje de error. Anote el rol de seguridad del usuario y revise los privilegios de tabla de ese rol de seguridad.