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La aplicación móvil de Field Service no se puede iniciar debido a que faltan archivos

En este artículo se proporciona una solución para un problema por el que no se puede iniciar la aplicación móvil de Dynamics 365 Field Service.

Síntomas

Cuando empiece a usar la nueva experiencia de usuario en la aplicación móvil dynamics 365 Field Service, recibirá un mensaje de error que indica que faltan determinados archivos.

Causa

Faltan algunos registros fuente requeridos. Estos registros se deben crear al instalar la aplicación Field Service, pero en raras ocasiones, no se crean correctamente o están dañados. También es posible que un usuario elimine los registros.

Solución

Paso 1: Comprobar si la tabla MobileSource contiene datos

  1. Vaya a Power Apps y abra el entorno que desea comprobar.

  2. Seleccione Tablas, seleccione el filtro Todo y busque la MobileSource tabla (msdyn_mobilesource).

  3. Seleccione la tabla y compruebe si contiene los datos siguientes en la columna Nombre :

    • /card/bookingListViewItem.yml
    • /card/defaultViewItem.yml
    • /card/serviceTaskGridItem.yml
    • /sitemaps/mobile.yml

Si no hay datos en la tabla, algo salió mal con la actualización de la solución.

Paso 2: aplique nuevamente la actualización de la solución Field Service

  1. En Power Apps, abra su entorno y vaya a Soluciones.

  2. Busque fieldservice_anchor y elimine la solución FieldService_Anchor.

  3. Vaya al Centro de administración de Power Platform y seleccione el entorno donde eliminó la solución.

  4. En los detalles del entorno, en Recursos, seleccione Aplicaciones de Dynamics 365.

  5. Seleccione Install app Dynamics 365 for Field Service Next (Instalar la aplicación>Dynamics 365 para Field Service>Next).

  6. Acepte las condiciones de servicio y seleccione Instalar.

Después de instalar la solución, compruebe que la tabla contiene los datos necesarios mediante el paso 1.