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Windows muestra un error de pantalla azul al iniciar una máquina virtual de Azure.

Se aplica a: ✔️ Máquinas virtuales de Windows

En este artículo se describen los errores de pantalla azul que pueden surgir al iniciar una máquina virtual (VM) de Windows en Microsoft Azure. Se proporcionan los pasos para ayudarle a recopilar datos de una incidencia de soporte técnico.

Síntomas

Una máquina virtual de Windows no se inicia. Al revisar las capturas de pantalla de arranque en Diagnósticos de arranque, ve uno de los mensajes de error siguientes en una pantalla azul:

Se produjo un problema con su PC y se debe reiniciar. Solo vamos a recopilar alguna información de error y, a continuación, podrá reiniciar.

Se produjo un problema con su PC y se debe reiniciar.

Causa

Puede haber muchas razones por las que se produzca un error de detención. Las causas más comunes son los siguientes problemas:

  • Problema con un controlador
  • Memoria o archivo de sistema dañados
  • Una aplicación tiene acceso a un sector prohibido de la memoria

Solución

Sugerencia

Si tiene una copia de seguridad reciente de la VM, puede intentar restaurar la VM desde la copia de seguridad para corregir el problema de arranque.

Para resolver este problema, primero debe recopilar un archivo de volcado para el bloqueo antes de ponerse en contacto con el soporte técnico. Para recopilar el archivo de volcado de memoria, siga estos pasos:

Paso 1: busque el archivo de volcado y envíe una incidencia de soporte técnico

Parte 1: conecte el disco del sistema operativo a una máquina virtual de recuperación
  1. Tome una instantánea del disco del sistema operativo de la máquina virtual afectada para crear una copia de seguridad. Para obtener más información, consulte Creación de una instantánea de un disco duro virtual.

  2. Conecte el disco del sistema operativo a una máquina virtual de recuperación.

  3. Utilice el protocolo de escritorio remoto (RDP) para conectarse remotamente a la máquina virtual de recuperación.

  4. Si el disco del sistema operativo está cifrado, debe desactivar el cifrado antes de pasar al siguiente paso. Para obtener más información, consulte Descifrar el disco de SO cifrado.

Parte 2: busque el archivo de volcado y envíe una incidencia de soporte técnico
  1. En la máquina virtual de recuperación, vaya a la carpeta de Windows del disco del sistema operativo adjunto. Por ejemplo, si la letra de unidad asignada al disco del sistema operativo adjunto es F, vaya a F:\Windows.

  2. Busque el archivo memory.dmp y después envíe una incidencia de soporte técnico que contenga el archivo de volcado.

Si no encuentra el archivo de volcado, vaya a los siguientes pasos para habilitar el registro de volcado y la consola serie y luego reproduzca el problema.

Paso 2: habilite el registro de volcado y la consola serie

Importante

Esta sección, método o tarea contiene pasos que le indican cómo modificar el Registro. No obstante, pueden producirse problemas graves si modifica el registro de manera incorrecta. Por lo tanto, asegúrese de que sigue estos pasos con atención. Como medida de protección, haga una copia de seguridad del registro antes de modificarlo para poder restaurarlo si se produce algún problema. Para obtener más información sobre cómo realizar copias de seguridad y restaurar el registro, vea Cómo hacer copia de seguridad y restaurar el registro en Windows.

Para habilitar el registro del volcado y la consola serie, siga estos pasos:

  1. Abra una sesión de símbolo del sistema con privilegios elevados como administrador.

  2. Ejecute los siguientes comandos BCDEdit con las opciones /ems y /emssettings:

    Habilitación de la consola serie:

    bcdedit /store <volume-letter-containing-the-bcd-folder>:\boot\bcd /ems {<boot-loader-identifier>} ON
    bcdedit /store <volume-letter-containing-the-bcd-folder>:\boot\bcd /emssettings EMSPORT:1 EMSBAUDRATE:115200
    
  3. Compruebe que el espacio libre en el disco del sistema operativo es mayor que el tamaño de la memoria (RAM) de la máquina virtual.

    Si no hay suficiente espacio en el disco del sistema operativo, cambie la ubicación donde se creará el archivo de volcado y diríjala a cualquier disco de datos adjunto a la máquina virtual que tenga suficiente espacio libre. Para cambiar la ubicación, sustituya %SystemRoot% por la letra de la unidad del disco de datos, como F:, en los siguientes comandos.

    Para habilitar el archivo de volcado del sistema operativo, ejecute los siguientes comandos cargar, agregar y descargar para implementar la configuración sugerida mediante la herramienta reg:

    Carga del subárbol del Registro desde el disco de SO roto:

    reg load HKLM\<broken-system> <volume-letter-of-broken-os-disk>:\windows\system32\config\SYSTEM
    

    Habilitar en ControlSet001:

    reg add "HKLM\<broken-system>\ControlSet001\Control\CrashControl" /v CrashDumpEnabled /t REG_DWORD /d 1 /f
    reg add "HKLM\<broken-system>\ControlSet001\Control\CrashControl" /v DumpFile /t REG_EXPAND_SZ /d "%SystemRoot%\MEMORY.DMP" /f
    reg add "HKLM\<broken-system>\ControlSet001\Control\CrashControl" /v NMICrashDump /t REG_DWORD /d 1 /f
    

    Habilitar en ControlSet002:

    reg add "HKLM\<broken-system>\ControlSet002\Control\CrashControl" /v CrashDumpEnabled /t REG_DWORD /d 1 /f
    reg add "HKLM\<broken-system>\ControlSet002\Control\CrashControl" /v DumpFile /t REG_EXPAND_SZ /d "%SystemRoot%\MEMORY.DMP" /f
    reg add "HKLM\<broken-system>\ControlSet002\Control\CrashControl" /v NMICrashDump /t REG_DWORD /d 1 /f
    

    Descarga del disco roto del sistema operativo:

    reg unload HKLM\<broken-system>
    

Paso 3: reproduzca el problema

  1. Desconecte el disco del sistema operativo y después vuelva a conectar el disco del sistema operativo a la máquina virtual afectada.

  2. Inicie la máquina virtual para reproducir el problema para que se genere el archivo de volcado.

  3. Repita las instrucciones de la sección Paso 1: busque el archivo de volcado y envíe una incidencia de soporte técnico.

Ponte en contacto con nosotros para obtener ayuda

Si tiene preguntas o necesita ayuda, cree una solicitud de soporte o busque consejo en la comunidad de Azure. También puede enviar comentarios sobre el producto con los comentarios de la comunidad de Azure.