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LinkedInSalesNavigatorControlsForUnifiedClient isn't available in the organization

This article provides a resolution for an issue where the LinkedInSalesNavigatorControlsForUnifiedClient solution isn't available in the organization to configure LinkedIn Sales Navigator.

Cause

The LinkedInSalesNavigatorControlsForUnifiedClient solution is available only in an organization that has LinkedIn Sales Navigator solution version 2.2.0.1 or later installed. If the LinkedIn Sales Navigator solution version is earlier than 2.2.0.1, you should manually install the LinkedInSalesNavigatorControlsForUnifiedClient solution.

Resolution

To resolve this issue, delete the solutions and reinstall them.

Note

To avoid data loss, export the data from the li_inmails, li_message, and li_pointdrivepresentationviewed entities before deleting the solution, and restore the data when you install the LinkedIn Sales Navigator solution.

Follow these steps:

  1. Delete the LinkedIn Sales Navigator solution. Verify the dependencies before deleting the solution. If dependencies exist, contact your system administrator to remove the solutions. To remove the dependencies, follow these steps:

    1. Go to Advanced settings > Settings > Customizations > Solutions.

    2. Select the LinkedIn solution, and then select Show Dependencies.

      Screenshot of LinkedIn solution dependencies.

    3. Select the Required by entity name, and the dependent entity opens on a page.

    4. Select Form Properties and under the Events tab, go to the Event Handlers section.

    5. Select and remove the events.

    6. Save and publish the customization.

  2. Delete the msdyn_LinkedInSalesNavigatorAnchor solution.

  3. Install the LinkedIn Sales Navigator solution again and restore the data for the entities.