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Sysprep schlägt fehl, nachdem Sie Microsoft Store-Apps entfernt oder aktualisiert haben, die integrierte Windows-Images enthalten.

In diesem Artikel wird ein Problem erläutert, das auftritt, wenn Sie eine bereitgestellte Microsoft Store-App mithilfe des Microsoft Store entfernen oder aktualisieren und dann sysprep auf dem Computer ausführen.

Gilt für: Windows 10 – alle Editionen, Windows 11
Ursprüngliche KB-Nummer: 2769827

Einführung

Sysprep ist ein Tool für IT-Administratoren, die eine Installation von Windows für Duplizierung, Überwachung und Kundenübermittlung vorbereiten möchten. Die Anleitungen in diesem Artikel sind für die Verwendung durch Supportmitarbeiter und IT-Experten vorgesehen. Wenn Sie ein privater Benutzer sind, der probleme bei der Verwendung von Microsoft Store-Apps auftritt, lesen Sie "Beheben von Problemen mit Apps aus dem Microsoft Store".

Mehrere Microsoft Store-Apps sind in Windows-Images integriert. Zu diesen Apps gehören u. a. die Mail-, Karten-, Messaging-, Bing-, Reise- und Nachrichten-Apps. Diese Apps werden als bereitgestellte Apps bezeichnet. Bereitgestellte Apps werden im Image bereitgestellt und sollen für jeden Benutzer des Windows-Images bei der ersten Anmeldung installiert werden. Zusätzlich zu den integrierten Apps können Sie Ihre eigenen Branchen-Microsoft Store-Apps querladen, ohne sie im Microsoft Store veröffentlichen zu müssen. Sie können Pakete querladen Appx , indem Sie Online- oder Offlinewartungsbefehle verwenden, die in DISM.exe oder über das DISM PowerShell-Modul verfügbar sind.

Symptome

Betrachten Sie die folgenden Szenarien:

Szenario 1

  • Sie erstellen einen benutzerdefinierten Windows 10- oder Windows 11-Referenzcomputer, den Sie sysprep und erfassen möchten.
  • Sie möchten einige der bereitgestellten Microsoft Store-Apps (Appx Pakete) von diesem Referenzcomputer entfernen.
  • Sie werden ausgeführt dism -online /Remove-ProvisionedAppxPackage /PackageName:<packagename> , um die Appx Pakete aufzustellen.

Wenn Sie den Sysprep-Vorgang in diesem Szenario ausführen, schlägt der Vorgang möglicherweise mit dem folgenden Fehler fehl:

Tool für die Systemvorbereitung 3.14
Schwerwiegender Fehler beim Versuch, den Computer zu sysprepieren

Szenario 2

  • Sie verfügen über ein vorhandenes Windows-Image, und mehrere Microsoft Store-Apps werden im Image quergeladen.
  • Sie möchten einige der quergeladenen Appx Pakete aus Ihrem Image entfernen und weiter anpassen.
  • Starten Sie mit dem Referenzcomputer, und führen Sie einen der folgenden PowerShell-Befehle aus, um die Bereitstellung des Appx Pakets zu entfernen:
    • Remove-AppxProvisionedPackage -PackageName <packagename>
    • Remove-ProvisionedAppxPackage -PackageName <packagename>

Wenn Sie den Sysprep-Vorgang in diesem Szenario ausführen, schlägt der Vorgang möglicherweise mit dem folgenden Fehler fehl:

Tool für die Systemvorbereitung 3.14
Schwerwiegender Fehler beim Versuch, den Computer zu sysprepieren

Szenario 3

  • Sie erstellen ein Windows 10- oder Windows 11-Referenzimage.
  • Sie stellen eine Verbindung mit dem Microsoft Store her, und aktualisieren Sie dann die integrierten Microsoft Store-Apps mithilfe des Microsoft Store.

Wenn Sie den Sysprep-Vorgang in diesem Szenario ausführen, schlägt der Vorgang möglicherweise mit dem folgenden Fehler fehl:

Systemvorbereitungstool 3.14 Beim Versuch, den Computer zu sysprepieren, ist ein schwerwiegender Fehler aufgetreten.

Darüber hinaus können Sie in der SetupErr.log die folgenden Fehlereinträge bemerken:

<Date><Time>, Error SYSPRP Package <PackageFullName> wurde für einen Benutzer installiert, aber nicht für alle Benutzer bereitgestellt. Dieses Paket funktioniert im Sysprep-Image nicht ordnungsgemäß.
<Date><Time>, Error SYSPRP Failed to remove apps for the current user: 0x80073cf2.
<Date><Time>, Error SYSPRP Exit code of RemoveAllApps thread was 0x3cf2.
<Date><Time>, Error [0x0f0082] SYSPRP ActionPlatform::LaunchModule: Fehler beim Ausführen von 'SysprepGeneralize' von C:\Windows\System32\AppxSysprep.dll; dwRet = 0x3cf2
<Date><Time>, Error SYSPRP ActionPlatform::ExecuteAction: Error in executing action; dwRet = 0x3cf2
<Date><Time>, Error SYSPRP ActionPlatform::ExecuteActionList: Error in execute actions; dwRet = 0x3cf2
<Datumszeit><>, Fehler SYSPRP SysprepSession::Execute: Fehler beim Ausführen von Aktionen von C:\Windows\System32\Sysprep\ActionFiles\Generalize.xml; dwRet = 0x3cf2
<Date><Time>, Error SYSPRP RunPlatformActions:Failed while executing SysprepSession actions; dwRet = 0x3cf2
<Date><Time>, Error [0x0f0070] SYSPRP RunExternalDlls:An error occurred while running registry sysprep DLLs, halting sysprep execution. dwRet = 0x3cf2
<Date><Time>, Error [0x0f00a8] SYSPRP WinMain:Hit failure while processing sysprep generalize internal providers; hr = 0x80073cf2

Ursache

Sysprep verfügt über einen zusätzlichen Anbieter, der in Windows hinzugefügt wird, um Pakete zu bereinigen Appx und das Image zu generalisieren. Der Anbieter funktioniert nur, wenn es sich bei dem Appx Paket um ein Benutzerpaket oder ein vom Benutzer bereitgestelltes Paket handelt.

  • Pro Benutzerpaket bedeutet, dass das Appx Paket für ein bestimmtes Benutzerkonto installiert wird und für andere Benutzer des Computers nicht verfügbar ist.
  • Das Gesamte Benutzerpaket bedeutet, dass das Appx Bild in das Bild bereitgestellt wurde, damit alle Benutzer, die dieses Bild verwenden, auf die App zugreifen können.

Wenn ein im Image bereitgestelltes All-User-Paket manuell aus dem Image entfernt, aber nicht für einen bestimmten Benutzer entfernt wurde, tritt beim Bereinigen dieses Pakets während des Sysprep-Pakets ein Fehler auf. Der Anbieter schlägt auch fehl, wenn ein im Image bereitgestelltes All-User-Paket von einem der Benutzer auf diesem Referenzcomputer aktualisiert wurde.

Lösung

Um dieses Problem zu beheben, entfernen Sie das Paket für den Benutzer, der sysprep ausführt, und entfernen Sie auch die Bereitstellung. Gehen Sie hierzu wie folgt vor.

Notiz

Um zu verhindern, dass Der Microsoft Store Apps aktualisiert, trennen Sie die Internetverbindung, oder deaktivieren Sie automatische Updates im Überwachungsmodus, bevor Sie das Image erstellen.

  1. Führen Sie die folgenden PowerShell-Cmdlets aus:

    Import-Module Appx
    Import-Module Dism
    Get-AppxPackage -AllUsers | Where PublisherId -eq 8wekyb3d8bbwe | Format-List -Property PackageFullName,PackageUserInformation
    

Notiz

  • Überprüfen Sie in der Ausgabe dieses letzten Cmdlets die Benutzer, für die das Paket als installiert angezeigt wird. Löschen Sie diese Benutzerkonten vom Referenzcomputer, oder melden Sie sich mit diesen Benutzerkonten beim Computer an. Führen Sie dann das Cmdlet in Schritt 2 aus, um das Appx Paket zu entfernen.
  • Dieser Befehl listet alle Pakete auf, die von Microsoft veröffentlicht und von jedem Benutzer dieses Referenzcomputers installiert wurden. Da der Computer sysprepped sein soll, wird davon ausgegangen, dass diese Benutzerprofile das Paket nicht mehr benötigen.
  • Wenn Sie manuell Apps bereitgestellt haben, die zu anderen Herausgebern gehören, führen Sie den folgenden Befehl aus, um sie aufzulisten:

Get-AppxPackage -AllUsers | Format-List -Property PackageFullName,PackageUserInformation

  1. Entfernen Sie das Paket, indem Sie Appx das folgende Cmdlet ausführen:

    Remove-AppxPackage -Package <packagefullname>
    
  2. Entfernen Sie die Bereitstellung, indem Sie das folgende Cmdlet ausführen:

    Remove-AppxProvisionedPackage -Online -PackageName <packagefullname>
    

Wenn Sie versuchen, ein Updateproblem wiederherzustellen, können Sie die App erneut bereitstellen, nachdem Sie diese Schritte ausgeführt haben.

Notiz

Das Problem tritt nicht auf, wenn Sie ein Offlineimage warten. In diesem Szenario wird die Bereitstellung automatisch für alle Benutzer gelöscht. Dies schließt den Benutzer ein, der den Befehl ausführt.

Weitere Informationen

Weitere Informationen zum Hinzufügen und Entfernen von Apps finden Sie unter:

Datensammlung

Wenn Sie Unterstützung vom Microsoft-Support benötigen, empfehlen wir Ihnen, die Informationen zu sammeln, indem Sie die Schritte unter Sammeln von Informationen mithilfe von TSS für Bereitstellungsprobleme ausführen.